summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-25 22:12:27 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-25 22:12:27 +0000
commit5073f669e1ddc85c09c2210e768a51c1294bff3f (patch)
tree0b09dac3bf601d98ed0c8498f0a8e1a4e00aee9f /app-arch/bzip2
parentfix do_gcc_HTB_boundschecking_patches check and add a debug hook into the src... (diff)
downloadhistorical-5073f669e1ddc85c09c2210e768a51c1294bff3f.tar.gz
historical-5073f669e1ddc85c09c2210e768a51c1294bff3f.tar.bz2
historical-5073f669e1ddc85c09c2210e768a51c1294bff3f.zip
Fix the libbz2.so symlink #93867 and ldscript by psm.
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'app-arch/bzip2')
-rw-r--r--app-arch/bzip2/ChangeLog7
-rw-r--r--app-arch/bzip2/Manifest5
-rw-r--r--app-arch/bzip2/bzip2-1.0.3-r4.ebuild79
-rw-r--r--app-arch/bzip2/files/digest-bzip2-1.0.3-r41
4 files changed, 89 insertions, 3 deletions
diff --git a/app-arch/bzip2/ChangeLog b/app-arch/bzip2/ChangeLog
index 7aa1f66dc191..7426bac018e1 100644
--- a/app-arch/bzip2/ChangeLog
+++ b/app-arch/bzip2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/bzip2
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/bzip2/ChangeLog,v 1.25 2005/05/19 22:15:15 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/bzip2/ChangeLog,v 1.26 2005/05/25 22:12:27 vapier Exp $
+
+*bzip2-1.0.3-r4 (25 May 2005)
+
+ 25 May 2005; Mike Frysinger <vapier@gentoo.org> +bzip2-1.0.3-r4.ebuild:
+ Fix the libbz2.so symlink #93867 and ldscript by psm.
*bzip2-1.0.3-r3 (19 May 2005)
diff --git a/app-arch/bzip2/Manifest b/app-arch/bzip2/Manifest
index ad4f5f1ad1ff..4241ad99ee32 100644
--- a/app-arch/bzip2/Manifest
+++ b/app-arch/bzip2/Manifest
@@ -1,9 +1,10 @@
-MD5 4a142e2eed687a7113d4cd00274d0d33 ChangeLog 6283
+MD5 93e74da18f5e6544e5314e2b8f0381cc ChangeLog 6445
MD5 c7ae74d80c4fd172fc83b5f41de30ea4 bzip2-1.0.2-r5.ebuild 2203
MD5 cc2e9e810cc6b1cf37fd567e1699df91 bzip2-1.0.3-r3.ebuild 2295
MD5 2bced66d4d3c68070477627caa87f172 bzip2-1.0.3.ebuild 2021
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
MD5 328d582d46b23f945a883dd946d975a2 bzip2-1.0.3-r2.ebuild 2213
+MD5 8ba714af581ba34afae6c1b219f471cc bzip2-1.0.3-r4.ebuild 2300
MD5 9c63b399f71b03f2a58b061c1e038d0c files/bzip2-1.0.2-saneso.patch 457
MD5 f413035bf75710d87670f302692e1233 files/digest-bzip2-1.0.3 63
MD5 5f7a98f0aaaed6554126d30e28383ee0 files/bzip2-1.0.2-progress.patch 6141
@@ -14,4 +15,4 @@ MD5 be84e51b1bd56731f5d7762980e3ad47 files/bzip2-1.0.3-makefile-CFLAGS.patch 489
MD5 d1cf85cb43e35c9ecba9954295318ab8 files/bzip2-1.0.3-saneso.patch 323
MD5 a0833247f0c02ccb65cceb33ea521457 files/bzip2-1.0.2-chmod.patch 2780
MD5 f413035bf75710d87670f302692e1233 files/digest-bzip2-1.0.3-r2 63
-MD5 f413035bf75710d87670f302692e1233 files/digest-bzip2-1.0.3-r3 63
+MD5 f413035bf75710d87670f302692e1233 files/digest-bzip2-1.0.3-r4 63
diff --git a/app-arch/bzip2/bzip2-1.0.3-r4.ebuild b/app-arch/bzip2/bzip2-1.0.3-r4.ebuild
new file mode 100644
index 000000000000..b063165c5bd7
--- /dev/null
+++ b/app-arch/bzip2/bzip2-1.0.3-r4.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/bzip2/bzip2-1.0.3-r4.ebuild,v 1.1 2005/05/25 22:12:27 vapier Exp $
+
+inherit eutils multilib toolchain-funcs flag-o-matic
+
+DESCRIPTION="A high-quality data compressor used extensively by Gentoo Linux"
+HOMEPAGE="http://www.bzip.org/"
+SRC_URI="http://www.bzip.org/${PV}/${P}.tar.gz"
+
+LICENSE="BZIP2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="build static"
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-1.0.2-NULL-ptr-check.patch
+ epatch "${FILESDIR}"/${P}-makefile-CFLAGS.patch
+ epatch "${FILESDIR}"/${P}-saneso.patch
+ epatch "${FILESDIR}"/${PN}-1.0.2-progress.patch
+ epatch "${FILESDIR}"/${PN}-1.0.2-chmod.patch
+ sed -i -e 's:\$(PREFIX)/man:\$(PREFIX)/share/man:g' Makefile || die "sed manpath"
+
+ # - Generate symlinks instead of hardlinks
+ # - pass custom variables to control libdir
+ sed -i \
+ -e 's:ln $(PREFIX)/bin/:ln -s :' \
+ -e 's:$(PREFIX)/lib:$(PREFIX)/$(LIBDIR):g' \
+ Makefile || die "sed links"
+
+ # bzip2 will to run itself after it has built itself which we
+ # can't do if we are cross compiling. -solar
+ if [[ -x /bin/bzip2 ]] && tc-is-cross-compiler ; then
+ sed -i -e 's:./bzip2 -:bzip2 -:g' Makefile || die "sed cross-compile"
+ fi
+}
+
+src_compile() {
+ local makeopts="
+ CC=$(tc-getCC)
+ AR=$(tc-getAR)
+ RANLIB=$(tc-getRANLIB)
+ "
+ if ! use build ; then
+ emake ${makeopts} -f Makefile-libbz2_so all || die "Make failed libbz2"
+ fi
+ use static && append-flags -static
+ emake ${makeopts} all || die "Make failed"
+}
+
+src_install() {
+ if ! use build ; then
+ make PREFIX="${D}"/usr LIBDIR=$(get_libdir) install || die
+
+ # move bzip2 binaries to / and use the shared libbz2.so
+ mv "${D}"/usr/bin "${D}"/
+ into /
+ if ! use static ; then
+ newbin bzip2-shared bzip2 || die "dobin shared"
+ fi
+ dolib.so "${S}"/libbz2.so.${PV} || die "dolib shared"
+ for v in libbz2.so{,.{${PV%%.*},${PV%.*}}} ; do
+ dosym libbz2.so.${PV} /$(get_libdir)/${v}
+ done
+ gen_usr_ldscript libbz2.so
+
+ dodoc README* CHANGES Y2K_INFO bzip2.txt manual.*
+ else
+ into /
+ dobin bzip2 || die "dobin bzip2"
+ fi
+
+ dosym bzip2 /bin/bzcat
+ dosym bzip2 /bin/bunzip2
+}
diff --git a/app-arch/bzip2/files/digest-bzip2-1.0.3-r4 b/app-arch/bzip2/files/digest-bzip2-1.0.3-r4
new file mode 100644
index 000000000000..24bf9c7e285a
--- /dev/null
+++ b/app-arch/bzip2/files/digest-bzip2-1.0.3-r4
@@ -0,0 +1 @@
+MD5 8a716bebecb6e647d2e8a29ea5d8447f bzip2-1.0.3.tar.gz 669075