summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2004-07-13 17:11:44 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2004-07-13 17:11:44 +0000
commitdcc8c313fc5818900e6d9c7bba10eef15123e144 (patch)
tree951df6dc8fb68e5fcd87997a29c420a8b89a8ddc /app-admin
parentInitial import, closes bug #54032 (diff)
downloadhistorical-dcc8c313fc5818900e6d9c7bba10eef15123e144.tar.gz
historical-dcc8c313fc5818900e6d9c7bba10eef15123e144.tar.bz2
historical-dcc8c313fc5818900e6d9c7bba10eef15123e144.zip
Closing #56424.
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/pam_dotfile/ChangeLog5
-rw-r--r--app-admin/pam_dotfile/Manifest4
-rw-r--r--app-admin/pam_dotfile/pam_dotfile-0.7.ebuild22
3 files changed, 24 insertions, 7 deletions
diff --git a/app-admin/pam_dotfile/ChangeLog b/app-admin/pam_dotfile/ChangeLog
index d9dca95f5b52..ffb5a289db1f 100644
--- a/app-admin/pam_dotfile/ChangeLog
+++ b/app-admin/pam_dotfile/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-admin/pam_dotfile
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/pam_dotfile/ChangeLog,v 1.3 2004/06/24 21:33:26 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/pam_dotfile/ChangeLog,v 1.4 2004/07/13 17:11:44 aliz Exp $
+
+ 13 Jul 2004; Daniel Ahlberg <aliz@gentoo.org> pam_dotfile-0.7.ebuild:
+ Fixed lynx problems, closing #56424.
06 Jun 2004; Daniel Black <dragonheart@gentoo.org> +metadata.xml,
pam_dotfile-0.7.ebuild:
diff --git a/app-admin/pam_dotfile/Manifest b/app-admin/pam_dotfile/Manifest
index cc23a846403d..101a9b7100fa 100644
--- a/app-admin/pam_dotfile/Manifest
+++ b/app-admin/pam_dotfile/Manifest
@@ -1,4 +1,4 @@
-MD5 5dddd704247dff78fa46632cca598052 pam_dotfile-0.7.ebuild 792
-MD5 ebe87bd5e861cbeed8d2fc61b47d7989 ChangeLog 497
+MD5 b79cdb7efdaf9b880251965fb4e8d31a pam_dotfile-0.7.ebuild 975
+MD5 bea03c5ebb36c50a215824f9dd3fab86 ChangeLog 605
MD5 1652522405f5936eb29776ef8d5ffa5b metadata.xml 310
MD5 30fbae2d4d9759fde9c1ff733dac16b2 files/digest-pam_dotfile-0.7 67
diff --git a/app-admin/pam_dotfile/pam_dotfile-0.7.ebuild b/app-admin/pam_dotfile/pam_dotfile-0.7.ebuild
index e60bf22f93d4..00a266938367 100644
--- a/app-admin/pam_dotfile/pam_dotfile-0.7.ebuild
+++ b/app-admin/pam_dotfile/pam_dotfile-0.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/pam_dotfile/pam_dotfile-0.7.ebuild,v 1.6 2004/06/24 21:33:26 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/pam_dotfile/pam_dotfile-0.7.ebuild,v 1.7 2004/07/13 17:11:44 aliz Exp $
MY_P="${P/_beta/beta}"
S="${WORKDIR}/${MY_P}"
@@ -11,9 +11,23 @@ SRC_URI="http://www.stud.uni-hamburg.de/users/lennart/projects/pam_dotfile/${MY_
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86"
-IUSE=""
-DEPEND=">=sys-libs/pam-0.72"
+KEYWORDS="x86 ~amd64"
+IUSE="doc"
+DEPEND="doc? ( net-www/lynx )
+ >=sys-libs/pam-0.72"
+
+src_compile() {
+ local myconf
+
+ if use doc; then
+ myconf="--enable-lynx"
+ else
+ myconf="--disable-lynx"
+ fi
+
+ econf ${myconf} || die
+ emake || die
+}
src_install() {
make -C src DESTDIR=${D} install