summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenjamin Smee <strerror@gentoo.org>2006-03-30 10:11:56 +0000
committerBenjamin Smee <strerror@gentoo.org>2006-03-30 10:11:56 +0000
commit5f248f752c5ce684aced411fd731d8918a03cfa3 (patch)
treea4b15328a4da795f1cbc181367ffc99d54c0e373 /app-admin
parentAdded ~ppc64 (diff)
downloadhistorical-5f248f752c5ce684aced411fd731d8918a03cfa3.tar.gz
historical-5f248f752c5ce684aced411fd731d8918a03cfa3.tar.bz2
historical-5f248f752c5ce684aced411fd731d8918a03cfa3.zip
Version bump for bug #128011
Package-Manager: portage-2.0.54
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/denyhosts/ChangeLog8
-rw-r--r--app-admin/denyhosts/Manifest5
-rw-r--r--app-admin/denyhosts/denyhosts-2.2.ebuild63
-rw-r--r--app-admin/denyhosts/files/denyhosts-2.2-gentoo.patch77
-rw-r--r--app-admin/denyhosts/files/digest-denyhosts-2.21
5 files changed, 152 insertions, 2 deletions
diff --git a/app-admin/denyhosts/ChangeLog b/app-admin/denyhosts/ChangeLog
index 47defcbf8706..f17cdc782a9c 100644
--- a/app-admin/denyhosts/ChangeLog
+++ b/app-admin/denyhosts/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/denyhosts
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/denyhosts/ChangeLog,v 1.6 2006/02/28 11:31:19 strerror Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/denyhosts/ChangeLog,v 1.7 2006/03/30 10:11:56 strerror Exp $
+
+*denyhosts-2.2 (30 Mar 2006)
+
+ 30 Mar 2006; Benjamin Smee <strerror@gentoo.org>
+ +files/denyhosts-2.2-gentoo.patch, +denyhosts-2.2.ebuild:
+ Version bump for bug #128011
*denyhosts-2.1 (28 Feb 2006)
diff --git a/app-admin/denyhosts/Manifest b/app-admin/denyhosts/Manifest
index de1c3ca159f0..c97017ad105d 100644
--- a/app-admin/denyhosts/Manifest
+++ b/app-admin/denyhosts/Manifest
@@ -1,11 +1,14 @@
-MD5 088af50a95618bcf6055cfca0ce74135 ChangeLog 1153
+MD5 1cf8a018badd11d1f1803da6fd2aa409 ChangeLog 1326
MD5 c1714506803704c152614dfb848eed17 denyhosts-1.1.2-r1.ebuild 1644
MD5 96c066a233acc935e6f08f8af6b6d425 denyhosts-1.1.2.ebuild 1531
MD5 b6719ec83d25e68281fa96fec6c23808 denyhosts-2.1.ebuild 1629
+MD5 5c3d16636c8d5a8bdcdecfcb12dd0077 denyhosts-2.2.ebuild 1629
MD5 8bce87b9401354b35dd371bacb0039f3 files/denyhosts-2.1-gentoo.patch 2584
+MD5 ba9675b34ddb94cbaecceff353ec6156 files/denyhosts-2.2-gentoo.patch 2584
MD5 90c425b8fbcfa5fc084063999c2e3b9a files/denyhosts-gentoo.patch 2395
MD5 4e9d8193a9efd5714debeec451b6b777 files/denyhosts.init 345
MD5 de49bade96ff5bfa9d27a281c17a3e3e files/digest-denyhosts-1.1.2 66
MD5 de49bade96ff5bfa9d27a281c17a3e3e files/digest-denyhosts-1.1.2-r1 66
MD5 37e8683acb49f4b997aae081137a2d81 files/digest-denyhosts-2.1 64
+MD5 2cc6534ceb9ab501d97b2a297e60ce2b files/digest-denyhosts-2.2 64
MD5 82c6f940fc1a08d481d8d46de563bce7 metadata.xml 203
diff --git a/app-admin/denyhosts/denyhosts-2.2.ebuild b/app-admin/denyhosts/denyhosts-2.2.ebuild
new file mode 100644
index 000000000000..2fd7fad5cc42
--- /dev/null
+++ b/app-admin/denyhosts/denyhosts-2.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/denyhosts/denyhosts-2.2.ebuild,v 1.1 2006/03/30 10:11:56 strerror Exp $
+
+inherit distutils eutils
+
+my_PN="DenyHosts"
+my_P="${my_PN}-${PV}"
+DESCRIPTION="DenyHosts is a utility to help sys admins thwart ssh hackers"
+HOMEPAGE="http://www.denyhosts.net"
+SRC_URI="mirror://sourceforge/${PN}/${my_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~sparc ~x86"
+IUSE=""
+DEPEND=">=dev-lang/python-2.3"
+S="${WORKDIR}/${my_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # changes default file installations
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ sed -i -e 's:#!/usr/bin/env python:#!/usr/bin/python:' \
+ denyhosts.py || die "sed failed"
+}
+
+src_install() {
+ distutils_src_install
+
+ insinto /etc
+ insopts -m0640
+ newins denyhosts.cfg-dist denyhosts.conf
+
+ newinitd "${FILESDIR}"/denyhosts.init denyhosts
+
+ exeinto /usr/bin
+ newexe denyhosts.py denyhosts
+
+ dodoc CHANGELOG.txt README.txt
+
+ keepdir /var/lib/denyhosts
+}
+
+pkg_postinst() {
+ if [ ! -f /etc/hosts.deny ]
+ then
+ touch /etc/hosts.deny
+ fi
+
+ einfo "You can configure DenyHosts to run as a daemon by running:"
+ einfo
+ einfo "rc-update add denyhosts default"
+ einfo
+ einfo "or as a cronjob, by adding the following to /etc/crontab"
+ einfo "# run DenyHosts every 10 minutes"
+ einfo "*/10 * * * * root python /usr/bin/denyhosts -c /etc/denyhosts.conf"
+ einfo
+ einfo "More information can be found at http://denyhosts.sourceforge.net/faq.html"
+ einfo
+ ewarn "Modify /etc/denyhosts.conf to suit your environment system."
+}
+
diff --git a/app-admin/denyhosts/files/denyhosts-2.2-gentoo.patch b/app-admin/denyhosts/files/denyhosts-2.2-gentoo.patch
new file mode 100644
index 000000000000..d33467bf625a
--- /dev/null
+++ b/app-admin/denyhosts/files/denyhosts-2.2-gentoo.patch
@@ -0,0 +1,77 @@
+--- DenyHosts-2.2/denyhosts.cfg-dist 2006-02-28 10:28:21.000000000 +0000
++++ DenyHosts-2.2-new/denyhosts.cfg-dist 2006-02-28 10:42:13.000000000 +0000
+@@ -9,13 +9,16 @@
+ # argument
+ #
+ # Redhat or Fedora Core:
+-SECURE_LOG = /var/log/secure
++#SECURE_LOG = /var/log/secure
+ #
+ # Mandrake, FreeBSD or OpenBSD:
+ #SECURE_LOG = /var/log/auth.log
+ #
+-# SuSE:
+-#SECURE_LOG = /var/log/messages
++# Gentoo/SuSE:
++SECURE_LOG = /var/log/messages
++#
++# Metalog:
++#SECURE_LOG = /var/log/sshd/current
+ #
+ ########################################################################
+
+@@ -126,7 +129,7 @@
+ # Note: it is recommended that you use an absolute pathname
+ # for this value (eg. /home/foo/denyhosts/data)
+ #
+-WORK_DIR = /usr/share/denyhosts/data
++WORK_DIR = /var/lib/denyhosts
+ #
+ #######################################################################
+
+@@ -168,11 +171,14 @@
+ # running at a time.
+ #
+ # Redhat/Fedora:
+-LOCK_FILE = /var/lock/subsys/denyhosts
++#LOCK_FILE = /var/lock/subsys/denyhosts
+ #
+ # Debian
+ #LOCK_FILE = /var/run/denyhosts.pid
+ #
++# Gentoo
++LOCK_FILE = /var/run/denyhosts.pid
++#
+ # Misc
+ #LOCK_FILE = /tmp/denyhosts.lock
+ #
+diff -urN DenyHosts-2.1/setup.py DenyHosts-2.1-new/setup.py
+--- DenyHosts-2.1/setup.py 2006-02-10 01:03:39.000000000 +0000
++++ DenyHosts-2.1-new/setup.py 2006-02-13 11:03:08.000000000 +0000
+@@ -20,17 +20,17 @@
+ author="Phil Schwartz",
+ author_email="phil_schwartz@users.sourceforge.net",
+ url="http://denyhosts.sourceforge.net",
+- scripts=['denyhosts.py'],
++## scripts=['denyhosts.py'],
+ package_dir={'DenyHosts': 'DenyHosts'},
+ packages=["DenyHosts"],
+- data_files=[(libpath, glob("denyhosts.cfg-dist")),
+- (libpath, glob("setup.py")),
+- (libpath, glob("daemon-control-dist")),
+- (libpath, glob("CHANGELOG.txt")),
+- (libpath, glob("README.txt")),
+- (scriptspath, glob("scripts/*")),
+- (pluginspath, glob("plugins/*")),
+- (libpath, glob("LICENSE.txt"))],
++## data_files=[(libpath, glob("denyhosts.cfg-dist")),
++## (libpath, glob("setup.py")),
++## (libpath, glob("daemon-control-dist")),
++## (libpath, glob("CHANGELOG.txt")),
++## (libpath, glob("README.txt")),
++## (scriptspath, glob("scripts/*")),
++## (pluginspath, glob("plugins/*")),
++## (libpath, glob("LICENSE.txt"))],
+ license="GPL v2",
+ ##extra_path='denyhosts',
+ long_description="""
diff --git a/app-admin/denyhosts/files/digest-denyhosts-2.2 b/app-admin/denyhosts/files/digest-denyhosts-2.2
new file mode 100644
index 000000000000..3ffd43c3cc49
--- /dev/null
+++ b/app-admin/denyhosts/files/digest-denyhosts-2.2
@@ -0,0 +1 @@
+MD5 feba0e9a48dbf1fa9cbd2b5b8907f349 DenyHosts-2.2.tar.gz 40972