summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2006-01-27 23:13:47 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2006-01-27 23:13:47 +0000
commit3bbfac22b991018857b81929b7c33442cfc6ce34 (patch)
tree04db3dbcec2f10f6e96ae26159972678d5da0de2 /app-admin/webapp-config
parentqbankmanager bump (diff)
downloadhistorical-3bbfac22b991018857b81929b7c33442cfc6ce34.tar.gz
historical-3bbfac22b991018857b81929b7c33442cfc6ce34.tar.bz2
historical-3bbfac22b991018857b81929b7c33442cfc6ce34.zip
Version bump to 1.50.9. Fixed symlink handling, improved error message for
corrupt config files, corrected upgrade instructions and support for config/server-owned files Package-Manager: portage-2.0.54
Diffstat (limited to 'app-admin/webapp-config')
-rw-r--r--app-admin/webapp-config/ChangeLog9
-rw-r--r--app-admin/webapp-config/Manifest15
-rw-r--r--app-admin/webapp-config/files/digest-webapp-config-1.50.91
-rw-r--r--app-admin/webapp-config/webapp-config-1.50.9.ebuild52
4 files changed, 64 insertions, 13 deletions
diff --git a/app-admin/webapp-config/ChangeLog b/app-admin/webapp-config/ChangeLog
index 744f206d4acd..1c13674c2455 100644
--- a/app-admin/webapp-config/ChangeLog
+++ b/app-admin/webapp-config/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-admin/webapp-config
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/ChangeLog,v 1.14 2006/01/15 02:04:28 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/ChangeLog,v 1.15 2006/01/27 23:13:47 wrobel Exp $
+
+*webapp-config-1.50.9 (27 Jan 2006)
+
+ 27 Jan 2006; <wrobel@gentoo.org> +webapp-config-1.50.9.ebuild:
+ Version bump to 1.50.9. Fixed symlink handling, improved error message for
+ corrupt config files, corrected upgrade instructions and support for
+ config/server-owned files
15 Jan 2006; Marcus D. Hanwell <cryos@gentoo.org>
webapp-config-1.50.7.ebuild:
diff --git a/app-admin/webapp-config/Manifest b/app-admin/webapp-config/Manifest
index a5f6ae9e146c..9be1783c669e 100644
--- a/app-admin/webapp-config/Manifest
+++ b/app-admin/webapp-config/Manifest
@@ -1,16 +1,7 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 f1b1b2def03a5e51d8585e1fcb3d65bb ChangeLog 15839
+MD5 a0d1b51309efddd7bbd96e35d4f5f279 ChangeLog 16119
MD5 6aad9c4cd4548cb948cd4035286d6ac7 files/digest-webapp-config-1.11 70
-MD5 30507799237543cc743fb16415087f65 files/digest-webapp-config-1.50.7 71
+MD5 745177b975cd2bf3bf1da32b84315934 files/digest-webapp-config-1.50.9 71
MD5 4defd726d2b03decc5b7ff21b0aac1a3 metadata.xml 225
MD5 90bba75c31e392fd21e084681aeca6ae webapp-config-1.11.ebuild 1408
MD5 b1b3b0a28341f5bd2a35b175461a0399 webapp-config-1.50.7.ebuild 1674
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.2 (GNU/Linux)
-
-iD8DBQFDya23ntT9W3vfTuoRArXdAKCJhaEaQjkCiAO2s2vSgNwh/kMq8gCeM/il
-zwJ1Mb0E77QCSNvgBdP1Ks4=
-=WHCW
------END PGP SIGNATURE-----
+MD5 5d885361d688cf6292f4a10624e8a865 webapp-config-1.50.9.ebuild 1675
diff --git a/app-admin/webapp-config/files/digest-webapp-config-1.50.9 b/app-admin/webapp-config/files/digest-webapp-config-1.50.9
new file mode 100644
index 000000000000..759b538422b9
--- /dev/null
+++ b/app-admin/webapp-config/files/digest-webapp-config-1.50.9
@@ -0,0 +1 @@
+MD5 d70ff3c6cf573c629009fc565bfc8641 webapp-config-1.50.9.tar.gz 94563
diff --git a/app-admin/webapp-config/webapp-config-1.50.9.ebuild b/app-admin/webapp-config/webapp-config-1.50.9.ebuild
new file mode 100644
index 000000000000..ec99ba209dec
--- /dev/null
+++ b/app-admin/webapp-config/webapp-config-1.50.9.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/webapp-config-1.50.9.ebuild,v 1.1 2006/01/27 23:13:47 wrobel Exp $
+
+inherit eutils distutils
+
+DESCRIPTION="Gentoo's installer for web-based applications"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="http://dev.gentoo.org/~wrobel/webapp-config/${PF}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+S=${WORKDIR}/${PF}
+
+DEPEND=""
+
+src_install() {
+
+ # According to this discussion:
+ # http://mail.python.org/pipermail/distutils-sig/2004-February/003713.html
+ # distutils does not provide for specifying two different script install
+ # locations. Since we only install one script here the following should
+ # be ok
+ distutils_src_install --install-scripts="/usr/sbin"
+
+ dodir /etc/vhosts
+ cp config/webapp-config ${D}/etc/vhosts/
+ keepdir /usr/share/webapps
+ dodoc examples/phpmyadmin-2.5.4-r1.ebuild AUTHORS.txt TODO.txt CHANGES.txt examples/postinstall-en.txt
+ doman doc/webapp-config.5 doc/webapp-config.8 doc/webapp.eclass.5
+ dohtml doc/webapp-config.5.html doc/webapp-config.8.html doc/webapp.eclass.5.html
+}
+
+src_test() {
+ cd ${S}
+ einfo "Running webapp-config doctests..."
+ if ! PYTHONPATH="." ${python} WebappConfig/tests/dtest.py; then
+ eerror "DocTests failed - please submit a bug report"
+ die "DocTesting failed!"
+ fi
+}
+
+pkg_postinst() {
+ echo
+ einfo "Now that you have upgraded webapp-config, you **must** update your"
+ einfo "config files in /etc/vhosts/webapp-config before you emerge any"
+ einfo "packages that use webapp-config."
+ echo
+ epause 5
+}