summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-02-28 21:12:25 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-02-28 21:12:25 +0000
commitdfabb4f80ba5ffeaffdcb70f718d49cc5c28d5e4 (patch)
tree60f6d5d1b78fb329936905797054610b316f3272 /app-admin/ulogd
parentdeprecated (diff)
downloadhistorical-dfabb4f80ba5ffeaffdcb70f718d49cc5c28d5e4.tar.gz
historical-dfabb4f80ba5ffeaffdcb70f718d49cc5c28d5e4.tar.bz2
historical-dfabb4f80ba5ffeaffdcb70f718d49cc5c28d5e4.zip
version bump
Diffstat (limited to 'app-admin/ulogd')
-rw-r--r--app-admin/ulogd/files/digest-ulogd-0.981
-rw-r--r--app-admin/ulogd/files/ulogd-0.9847
-rw-r--r--app-admin/ulogd/ulogd-0.98.ebuild43
3 files changed, 91 insertions, 0 deletions
diff --git a/app-admin/ulogd/files/digest-ulogd-0.98 b/app-admin/ulogd/files/digest-ulogd-0.98
new file mode 100644
index 000000000000..e8709f4c1723
--- /dev/null
+++ b/app-admin/ulogd/files/digest-ulogd-0.98
@@ -0,0 +1 @@
+MD5 18c6db19de538c57a70b9cfbdb079781 ulogd-0.98.tar.gz 104373
diff --git a/app-admin/ulogd/files/ulogd-0.98 b/app-admin/ulogd/files/ulogd-0.98
new file mode 100644
index 000000000000..010829371852
--- /dev/null
+++ b/app-admin/ulogd/files/ulogd-0.98
@@ -0,0 +1,47 @@
+#!/sbin/runscript
+#
+# chkconfig: - 91 35
+# description: Starts and stops the ulogd daemon
+#
+# pidfile: /var/lock/samba/ulogd.pid
+# config: /usr/local/etc/ulogd.conf
+
+
+#opts="start stop restart status"
+
+depend() {
+ need net
+}
+
+initService() {
+# Avoid using root's TMPDIR
+unset TMPDIR
+
+# Check that ulogd.conf exists.
+[ -f /etc/ulogd.conf ] || exit 0
+
+RETVAL=0
+}
+
+start() {
+ initService
+ ebegin "Starting ulogd"
+ start-stop-daemon --start --quiet --exec /usr/sbin/ulogd -- -d >/dev/null 2>&1
+ eend $?
+}
+
+stop() {
+ initService
+ ebegin "Stopping ulogd"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/ulogd >/dev/null 2>&1
+ eend $?
+}
+
+reload() {
+ initService
+ ebegin "Reloading ulogd.conf file"
+ killproc ulogd -HUP
+ RETVAL=$?
+ echo
+ return $RETVAL
+}
diff --git a/app-admin/ulogd/ulogd-0.98.ebuild b/app-admin/ulogd/ulogd-0.98.ebuild
new file mode 100644
index 000000000000..69093360e202
--- /dev/null
+++ b/app-admin/ulogd/ulogd-0.98.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/ulogd/ulogd-0.98.ebuild,v 1.1 2003/02/28 21:12:25 liquidx Exp $
+
+DESCRIPTION="iptables daemon for ULOG target for userspace iptables filter logging"
+SRC_URI="ftp://ftp.netfilter.org/pub/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.gnumonks.org/gnumonks/projects/project_details?p_id=1"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc "
+IUSE="mysql"
+
+DEPEND="sys-apps/iptables"
+
+src_compile() {
+ cp ulogd.conf ulogd.conf.orig
+ sed -e "s:/usr/local/lib/:/usr/lib/:" ulogd.conf.orig > ulogd.conf
+
+ local myconf
+ use mysql && myconf="--with-mysql"
+
+ econf ${myconf}
+ make all || die "make failed"
+}
+
+src_install() {
+ # the Makefile seems to be "broken" -
+ # it relies on the existance of /usr, /etc ..
+ dodir /usr/sbin /etc/init.d
+
+ make DESTDIR=${D} install || die "install failed"
+
+ cp ${FILESDIR}/ulogd-${PV} ${D}/etc/init.d/ulogd
+
+ dodoc README AUTHORS Changes
+ cd doc/
+ dodoc ulogd.txt ulogd.a4.ps
+ if [ -n "`use mysql`" ]; then
+ dodoc mysql.table mysql.table.ipaddr-as-string
+ fi
+ dohtml ulogd.html
+}