summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2003-08-04 17:33:00 +0000
committerNed Ludd <solar@gentoo.org>2003-08-04 17:33:00 +0000
commit6ea430643938e30c434ff3a611fc880df8ec15a2 (patch)
tree38641f95fcdaf70518eb34e04915fcb54060718d /app-admin/paxtest
parentInitial import of paxtest into portage, PaX regression test suite developed b... (diff)
downloadhistorical-6ea430643938e30c434ff3a611fc880df8ec15a2.tar.gz
historical-6ea430643938e30c434ff3a611fc880df8ec15a2.tar.bz2
historical-6ea430643938e30c434ff3a611fc880df8ec15a2.zip
Initial import of paxtest into portage, PaX regression test suite developed by Peter Busser
Diffstat (limited to 'app-admin/paxtest')
-rw-r--r--app-admin/paxtest/Manifest3
-rw-r--r--app-admin/paxtest/files/digest-paxtest-0.9.11
-rw-r--r--app-admin/paxtest/metadata.xml25
-rw-r--r--app-admin/paxtest/paxtest-0.9.1.ebuild30
4 files changed, 58 insertions, 1 deletions
diff --git a/app-admin/paxtest/Manifest b/app-admin/paxtest/Manifest
index cc357c867bdb..56dba22acad6 100644
--- a/app-admin/paxtest/Manifest
+++ b/app-admin/paxtest/Manifest
@@ -1,3 +1,4 @@
-MD5 6b480b6b8fb1742e01bc522ad3ad36e6 paxtest-0.9.1.ebuild 861
+MD5 989c95de9ba485db09fe879c3e9ef365 paxtest-0.9.1.ebuild 868
MD5 9c3ac1379620120fbd744ce753b30ab5 metadata.xml 1075
+MD5 e7200b3ccfaf535f83b3decdc44fd171 ChangeLog 412
MD5 af6424bf6503521952ca07c9834cbc1a files/digest-paxtest-0.9.1 64
diff --git a/app-admin/paxtest/files/digest-paxtest-0.9.1 b/app-admin/paxtest/files/digest-paxtest-0.9.1
new file mode 100644
index 000000000000..9a4152f0b769
--- /dev/null
+++ b/app-admin/paxtest/files/digest-paxtest-0.9.1
@@ -0,0 +1 @@
+MD5 6149508864b8a8aa2e02d73bb15a338b paxtest-0.9.1.tar.gz 20059
diff --git a/app-admin/paxtest/metadata.xml b/app-admin/paxtest/metadata.xml
new file mode 100644
index 000000000000..da080aca94df
--- /dev/null
+++ b/app-admin/paxtest/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>hardened</herd>
+ <maintainer>
+ <email>solar@gentoo.org</email>
+ <description>Primary Maintainer</description>
+ </maintainer>
+<longdescription>Test suite for the PaX kernel patch
+ PaX is a Linux kernel patch which adds much stricter control on how memory
+ is being used by applications. A normal Linux kernel leaves the control to the
+ application and does not implement any enforcement. Especially buffer overflow
+ attacks benefit from the absense of kernel enforced memory control. PaX tries
+ to do its best to enforce this control of memory used by applications, thereby
+ making it harder to succesfully exploit buffer overflows.
+ .
+ Furthermore, it adds several randomisations, which also make it harder for
+ buffer overflows to succeed.
+ .
+ The test programs test all this functionality, but not all PaX functionality
+ is covered.
+ .
+ For more information about PaX, see http://pageexec.virtualave.net/.
+</longdescription>
+</pkgmetadata>
diff --git a/app-admin/paxtest/paxtest-0.9.1.ebuild b/app-admin/paxtest/paxtest-0.9.1.ebuild
new file mode 100644
index 000000000000..f7a51821efee
--- /dev/null
+++ b/app-admin/paxtest/paxtest-0.9.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/paxtest/paxtest-0.9.1.ebuild,v 1.1 2003/08/04 17:32:53 solar Exp $
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="PaX regression test suite"
+SRC_URI="http://pageexec.virtualave.net/paxtest-${PV}.tar.gz"
+HOMEPAGE="http://pageexec.virtualave.net"
+KEYWORDS="~x86"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE=""
+DEPEND="virtual/glibc"
+
+src_compile() {
+ # If you really paranoid you can uncomment this umask stuff.
+ # local mask=$(umask)
+ # umask 0077
+ emake DESTDIR=${D} BINDIR=${D}/usr/bin RUNDIR=/usr/lib/paxtest || die "Parallel Make Failed"
+ # umask $mask
+}
+
+src_install() {
+ emake DESTDIR=${D} BINDIR=/usr/bin RUNDIR=/usr/lib/paxtest install
+ for doc in Changelog COPYING LICENCE README ;do
+ [ -f "${doc}" ] && dodoc ${doc}
+ done
+}