summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2004-11-17 07:30:11 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2004-11-17 07:30:11 +0000
commitcd5822dc6dff8d585eb5f2dd196672cf029ce1b9 (patch)
treeb28128dbc330f96373a4f974df31da2a2c214e4d /app-admin/partgui/partgui-0.2.3-r2.ebuild
parentRDEPEND for selinux, bug #62906. (diff)
downloadhistorical-cd5822dc6dff8d585eb5f2dd196672cf029ce1b9.tar.gz
historical-cd5822dc6dff8d585eb5f2dd196672cf029ce1b9.tar.bz2
historical-cd5822dc6dff8d585eb5f2dd196672cf029ce1b9.zip
Fixing bug #38253
Diffstat (limited to 'app-admin/partgui/partgui-0.2.3-r2.ebuild')
-rw-r--r--app-admin/partgui/partgui-0.2.3-r2.ebuild13
1 files changed, 12 insertions, 1 deletions
diff --git a/app-admin/partgui/partgui-0.2.3-r2.ebuild b/app-admin/partgui/partgui-0.2.3-r2.ebuild
index 08738d6573cc..12e1fd8a8a8c 100644
--- a/app-admin/partgui/partgui-0.2.3-r2.ebuild
+++ b/app-admin/partgui/partgui-0.2.3-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/partgui/partgui-0.2.3-r2.ebuild,v 1.5 2004/10/05 02:58:11 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/partgui/partgui-0.2.3-r2.ebuild,v 1.6 2004/11/17 07:30:11 phosphan Exp $
DESCRIPTION="PartGUI is a nice graphical partitioning tool"
HOMEPAGE="http://part-gui.sourceforge.net/"
@@ -19,6 +19,17 @@ DEPEND=">=x11-libs/qt-3.1.0
>=sys-apps/sed-4"
src_compile() {
+ # fix the sandbox errors "can't writ to .kde or .qt" problems.
+ # this is a fake homedir that is writeable under the sandbox, so that the build process
+ # can do anything it wants with it.
+ REALHOME="$HOME"
+ mkdir -p $T/fakehome/.kde
+ mkdir -p $T/fakehome/.qt
+ export HOME="$T/fakehome"
+ addwrite "${QTDIR}/etc/settings"
+ # things that should access the real homedir
+ [ -d "$REALHOME/.ccache" ] && ln -sf "$REALHOME/.ccache" "$HOME/"
+
econf --disable-static || die "configure failed"
emake || die "emake failed"
}