summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2005-01-03 04:20:42 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2005-01-03 04:20:42 +0000
commit280421b310d8cc45bd12ae5e2c3d94ac52bd569e (patch)
tree4b5dd38bea5cc02e95fef9ae601e379960cfae22 /app-admin/monit/monit-4.4.ebuild
parentAdd PLATFORM=linux fix to one more spot. (diff)
downloadhistorical-280421b310d8cc45bd12ae5e2c3d94ac52bd569e.tar.gz
historical-280421b310d8cc45bd12ae5e2c3d94ac52bd569e.tar.bz2
historical-280421b310d8cc45bd12ae5e2c3d94ac52bd569e.zip
Version bumped.
Diffstat (limited to 'app-admin/monit/monit-4.4.ebuild')
-rw-r--r--app-admin/monit/monit-4.4.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-admin/monit/monit-4.4.ebuild b/app-admin/monit/monit-4.4.ebuild
new file mode 100644
index 000000000000..456788b363bf
--- /dev/null
+++ b/app-admin/monit/monit-4.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/monit/monit-4.4.ebuild,v 1.1 2005/01/03 04:20:42 matsuu Exp $
+
+DESCRIPTION="a utility for monitoring and managing daemons or similar programs running on a Unix system."
+HOMEPAGE="http://www.tildeslash.com/monit/"
+SRC_URI="http://www.tildeslash.com/monit/dist/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc"
+IUSE="ssl"
+
+RDEPEND="virtual/libc
+ ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ sys-devel/bison"
+
+src_compile() {
+ econf `use_with ssl` || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc CHANGES.txt CONTRIBUTORS FAQ.txt README* STATUS UPGRADE.txt
+ dohtml -r doc/*
+
+ insinto /etc; insopts -m700; doins monitrc || die
+ exeinto /etc/init.d; newexe ${FILESDIR}/monit.initd monit || die
+}
+
+pkg_postinst() {
+ einfo "Sample configurations are available at"
+ einfo "http://www.tildeslash.com/monit/examples.html"
+}