summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZack Gilburd <klasikahl@gentoo.org>2004-04-12 00:10:08 +0000
committerZack Gilburd <klasikahl@gentoo.org>2004-04-12 00:10:08 +0000
commitf34d250c8d26a19f8fde7ad77d6ee68eb018856f (patch)
tree0e68b7003d2ec27d6be910b31abe01bdb99a326c /app-admin/mailmin
parentadd IUSE (bug #47358); don't rdepend on sed; error check sed; tidy (diff)
downloadhistorical-f34d250c8d26a19f8fde7ad77d6ee68eb018856f.tar.gz
historical-f34d250c8d26a19f8fde7ad77d6ee68eb018856f.tar.bz2
historical-f34d250c8d26a19f8fde7ad77d6ee68eb018856f.zip
Fixing the ebuild to correspond with the new directory structure.
Diffstat (limited to 'app-admin/mailmin')
-rw-r--r--app-admin/mailmin/ChangeLog13
-rw-r--r--app-admin/mailmin/Manifest4
-rw-r--r--app-admin/mailmin/mailmin-0.0.1-r1.ebuild65
3 files changed, 82 insertions, 0 deletions
diff --git a/app-admin/mailmin/ChangeLog b/app-admin/mailmin/ChangeLog
new file mode 100644
index 000000000000..e537fdf5d8d4
--- /dev/null
+++ b/app-admin/mailmin/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for app-admin/virt-mail-admin
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/mailmin/ChangeLog,v 1.1 2004/04/12 00:10:08 klasikahl Exp $
+
+*virt-mail-admin-0.0.1 (09 Apr 2004)
+
+ 09 Apr 2004; Zack Gilburd <klasikahl@gentoo.org>
+ virt-mail-admin-0.0.1.ebuild:
+ Fixing a bad ebuild description.
+
+ 09 Apr 2004; Zack Gilburd <klasikahl@gentoo.org>
+ Initial import... Some stuff may be broken, so I'm hardmasking.
+
diff --git a/app-admin/mailmin/Manifest b/app-admin/mailmin/Manifest
new file mode 100644
index 000000000000..cb4d5654fcce
--- /dev/null
+++ b/app-admin/mailmin/Manifest
@@ -0,0 +1,4 @@
+MD5 eabb8de28bcb5bed9daabf636bb41b86 mailmin-0.0.1-r1.ebuild 1544
+MD5 29afb70fa933d9c4ddeace778c85944d ChangeLog 502
+MD5 a25140ae292051ac0f9868a73e4f3aeb files/digest-mailmin-0.0.1-r1 76
+MD5 a10351b42fd321c071bc6e434eee5cbd files/digest-virt-mail-admin-0.0.1 84
diff --git a/app-admin/mailmin/mailmin-0.0.1-r1.ebuild b/app-admin/mailmin/mailmin-0.0.1-r1.ebuild
new file mode 100644
index 000000000000..97741c2bb5b1
--- /dev/null
+++ b/app-admin/mailmin/mailmin-0.0.1-r1.ebuild
@@ -0,0 +1,65 @@
+#//Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/mailmin/mailmin-0.0.1-r1.ebuild,v 1.1 2004/04/12 00:10:08 klasikahl Exp $
+
+inherit webapp-apache
+
+DESCRIPTION="Mailmin is a PHP frontend to the virtual mail database that is needed in the Virtual/Mailhost Postfix Howto."
+
+HOMEPAGE="http://gentoo.org/proj/en/virt-mail-admin.xml"
+
+SRC_URI="mirror://gentoo/${P}-pre2-alpha.tar.bz2
+ http://dev.gentoo.org/~klasikahl/mailmin/${P}-pre2-alpha.tar.bz2"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+
+KEYWORDS="~x86"
+
+IUSE=""
+
+DEPEND="virtual/php
+ crypt? ( app-crypt/gnupg )
+ ldap? ( net-nds/openldap )"
+
+webapp-detect || NO_WEBSERVER=1
+
+S=${WORKDIR}/${P}-pre2-alpha/mail
+
+pkg_setup() {
+ webapp-pkg_setup "${NO_WEBSERVER}"
+ if [ -L ${HTTPD_ROOT}/${PN} ] ; then
+ ewarn "You need to unmerge your old virt-mail-admin version first."
+ ewarn "virt-mail-admin will be installed into ${HTTPD_ROOT}/${PN}"
+ ewarn "directly instead of a version-dependant directory."
+ die "need to unmerge old version first"
+ fi
+ einfo "Installing into ${ROOT}${HTTPD_ROOT}."
+}
+
+src_unpack() {
+ unpack ${P}-pre2-alpha.tar.bz2
+}
+
+src_compile() {
+ :;
+}
+
+src_install() {
+
+ webapp-mkdirs
+
+ local DocumentRoot=${HTTPD_ROOT}
+ local destdir=${DocumentRoot}/${PN}
+ dodir ${destdir}
+ cp -r . ${D}/${HTTPD_ROOT}/${PN}
+ cd ${D}/${HTTPD_ROOT}
+ chown -R ${HTTPD_USER}:${HTTPD_GROUP} ${PN}
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "Make sure to run http://domain.tld/${PN}/install.php FIRST"
+ ewarn
+}