summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Żołnowski <aidecoe@gentoo.org>2011-09-09 13:19:29 +0000
committerAmadeusz Żołnowski <aidecoe@gentoo.org>2011-09-09 13:19:29 +0000
commit3f58dd81ddc8484def74bf79bfe4848d87222b6a (patch)
tree6df1b4de8145d22ff9b92f961ce610fbfa998a31 /app-admin/hddtemp/hddtemp-0.3_beta15-r4.ebuild
parentUpdate homepage and download URL to Oracle site. (diff)
downloadhistorical-3f58dd81ddc8484def74bf79bfe4848d87222b6a.tar.gz
historical-3f58dd81ddc8484def74bf79bfe4848d87222b6a.tar.bz2
historical-3f58dd81ddc8484def74bf79bfe4848d87222b6a.zip
app-admin/hddtemp-0.3_beta15-r4: Bumped EAPI to 4. Fixed bug #374163.
Package-Manager: portage-2.1.10.13/cvs/Linux x86_64
Diffstat (limited to 'app-admin/hddtemp/hddtemp-0.3_beta15-r4.ebuild')
-rw-r--r--app-admin/hddtemp/hddtemp-0.3_beta15-r4.ebuild18
1 files changed, 8 insertions, 10 deletions
diff --git a/app-admin/hddtemp/hddtemp-0.3_beta15-r4.ebuild b/app-admin/hddtemp/hddtemp-0.3_beta15-r4.ebuild
index 507538948dfe..782d406c6be8 100644
--- a/app-admin/hddtemp/hddtemp-0.3_beta15-r4.ebuild
+++ b/app-admin/hddtemp/hddtemp-0.3_beta15-r4.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/hddtemp/hddtemp-0.3_beta15-r4.ebuild,v 1.4 2011/07/05 14:33:29 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/hddtemp/hddtemp-0.3_beta15-r4.ebuild,v 1.5 2011/09/09 13:19:29 aidecoe Exp $
+
+EAPI=4
inherit eutils autotools
@@ -21,9 +23,7 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_P}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}"/${P}-satacmds.patch
epatch "${FILESDIR}"/${P}-byteswap.patch
epatch "${FILESDIR}"/${P}-execinfo.patch
@@ -32,18 +32,17 @@ src_unpack() {
AT_M4DIR="m4" eautoreconf
}
-src_compile() {
+src_configure() {
local myconf
myconf="--with-db-path=/usr/share/hddtemp/hddtemp.db"
# disabling nls breaks compiling
use nls || myconf="--disable-nls ${myconf}"
- econf ${myconf} || die
- emake || die
+ econf ${myconf}
}
src_install() {
- make DESTDIR="${D}" install || die
+ default
dodoc README TODO ChangeLog
insinto /usr/share/hddtemp
@@ -59,8 +58,7 @@ src_install() {
if use network-cron ; then
exeinto /etc/cron.monthly
echo -e "#!/bin/sh\n/usr/sbin/update-hddtemp.db" > "${T}"/hddtemp.cron
- newexe "${T}"/hddtemp.cron update-hddtemp.db \
- || die "Failed to install update cronjob"
+ newexe "${T}"/hddtemp.cron update-hddtemp.db
fi
}