summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2005-11-14 21:15:54 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2005-11-14 21:15:54 +0000
commite6326d52f8ff0647313dd000a13b222089975f2b (patch)
tree85bdad98ba99c68417aff010be6fc9e35fd87a3c /app-admin/cancd/cancd-0.1.0.ebuild
parentnew version (diff)
downloadhistorical-e6326d52f8ff0647313dd000a13b222089975f2b.tar.gz
historical-e6326d52f8ff0647313dd000a13b222089975f2b.tar.bz2
historical-e6326d52f8ff0647313dd000a13b222089975f2b.zip
Initial commit, ebuild by Robin H. Johnson <robbat2@gentoo.org>.
Package-Manager: portage-2.0.53_rc7
Diffstat (limited to 'app-admin/cancd/cancd-0.1.0.ebuild')
-rw-r--r--app-admin/cancd/cancd-0.1.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-admin/cancd/cancd-0.1.0.ebuild b/app-admin/cancd/cancd-0.1.0.ebuild
new file mode 100644
index 000000000000..fa6b36f92533
--- /dev/null
+++ b/app-admin/cancd/cancd-0.1.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/cancd/cancd-0.1.0.ebuild,v 1.1 2005/11/14 21:15:54 robbat2 Exp $
+
+DESCRIPTION="This is the CA NetConsole Daemon, a daemon to receive output from
+the Linux netconsole driver."
+HOMEPAGE="http://oss.oracle.com/projects/cancd/"
+SRC_URI="http://oss.oracle.com/projects/cancd/dist/files/source/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND="virtual/libc"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ # slight makefile cleanup
+ sed -i.orig \
+ -e '/^CFLAGS/s,-g,,' \
+ -e '/^CFLAGS/s,-O2,,' \
+ -e '/rm cancd cancd.o/s,rm,rm -f,' \
+ ${S}/Makefile
+}
+
+src_compile() {
+ emake cancd
+}
+
+src_install() {
+ into /usr
+ dosbin cancd
+ newinitd ${FILESDIR}/cancd-init.d cancd
+ newconfd ${FILESDIR}/cancd-conf.d cancd
+ keepdir /var/crash
+ fowners adm:nobody /var/crash
+ fperms 700 /var/crash
+}