summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2007-04-28 17:07:20 +0000
committerTorsten Veller <tove@gentoo.org>2007-04-28 17:07:20 +0000
commitbd49d8cd8e4f789ab600a2c92db7c45e9bb00322 (patch)
treed56a2b850f640fa8f1c7e9a35c02edd773f43b4e /app-admin/bastille
parentFix *initd, *confd and *envd calls (#17388, #174266) (diff)
downloadhistorical-bd49d8cd8e4f789ab600a2c92db7c45e9bb00322.tar.gz
historical-bd49d8cd8e4f789ab600a2c92db7c45e9bb00322.tar.bz2
historical-bd49d8cd8e4f789ab600a2c92db7c45e9bb00322.zip
Fix *initd, *confd and *envd calls (#17388, #174266)
Package-Manager: portage-2.1.2.5
Diffstat (limited to 'app-admin/bastille')
-rw-r--r--app-admin/bastille/ChangeLog5
-rw-r--r--app-admin/bastille/bastille-3.0.2.ebuild18
2 files changed, 13 insertions, 10 deletions
diff --git a/app-admin/bastille/ChangeLog b/app-admin/bastille/ChangeLog
index 2d693c64c3ef..4e7d8c7f1034 100644
--- a/app-admin/bastille/ChangeLog
+++ b/app-admin/bastille/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-admin/bastille
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/bastille/ChangeLog,v 1.19 2007/01/24 13:57:14 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/bastille/ChangeLog,v 1.20 2007/04/28 17:02:54 tove Exp $
+
+ 28 Apr 2007; Torsten Veller <tove@gentoo.org> bastille-3.0.2.ebuild:
+ Fix *initd, *confd and *envd calls (#17388, #174266)
24 Jan 2007; Marius Mauch <genone@gentoo.org> bastille-2.1.1-r1.ebuild,
bastille-2.1.1-r2.ebuild, bastille-2.1.1-r3.ebuild, bastille-3.0.2.ebuild:
diff --git a/app-admin/bastille/bastille-3.0.2.ebuild b/app-admin/bastille/bastille-3.0.2.ebuild
index bd1d8efb3f25..4d2338ebabc8 100644
--- a/app-admin/bastille/bastille-3.0.2.ebuild
+++ b/app-admin/bastille/bastille-3.0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/bastille/bastille-3.0.2.ebuild,v 1.3 2007/01/24 13:57:14 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/bastille/bastille-3.0.2.ebuild,v 1.4 2007/04/28 17:02:54 tove Exp $
inherit eutils
@@ -26,27 +26,27 @@ RDEPEND="net-firewall/iptables
src_unpack() {
unpack ${A}
- epatch ${WORKDIR}/${P}-gentoo-${PATCHVER}.patch
+ epatch "${WORKDIR}"/${P}-gentoo-${PATCHVER}.patch
- cd ${S}
- cp ${FILESDIR}/bastille-${PV}-firewall.init ./bastille-firewall
+ cd "${S}"
+ cp "${FILESDIR}"/bastille-${PV}-firewall.init ./bastille-firewall
chmod a+x Install.sh bastille-ipchains bastille-netfilter
}
src_install() {
- cd ${S}
- DESTDIR=${D} ./Install.sh
+ cd "${S}"
+ DESTDIR="${D}" ./Install.sh
# Example configs
- cd ${S}
+ cd "${S}"
insinto /usr/share/Bastille
doins *.config
- exeinto /etc/init.d && newexe ${FILESDIR}/${P}-firewall.init ${PN}-firewall
+ newinitd "${FILESDIR}"/${P}-firewall.init ${PN}-firewall
# Documentation
- cd ${S}
+ cd "${S}"
dodoc *.txt BUGS Change* README*
}