summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Holland <tigger@gentoo.org>2004-07-15 20:32:50 +0000
committerRob Holland <tigger@gentoo.org>2004-07-15 20:32:50 +0000
commit10e1e1cfdae27e36a3f16b8f423d11d7d24782e3 (patch)
treef5fd2808bcaa4c05482cb756c5872fc017050e3b /app-admin/apachetop
parentRemoved old versions (diff)
downloadhistorical-10e1e1cfdae27e36a3f16b8f423d11d7d24782e3.tar.gz
historical-10e1e1cfdae27e36a3f16b8f423d11d7d24782e3.tar.bz2
historical-10e1e1cfdae27e36a3f16b8f423d11d7d24782e3.zip
Fix DEPEND/RDEPENDs. Should close #56756. Thanks to wood-worker@gmx.net for reporting the issue.
Diffstat (limited to 'app-admin/apachetop')
-rw-r--r--app-admin/apachetop/ChangeLog6
-rw-r--r--app-admin/apachetop/Manifest8
-rw-r--r--app-admin/apachetop/apachetop-0.12.ebuild16
3 files changed, 18 insertions, 12 deletions
diff --git a/app-admin/apachetop/ChangeLog b/app-admin/apachetop/ChangeLog
index 15c6d2cbd888..99bc5d7f869d 100644
--- a/app-admin/apachetop/ChangeLog
+++ b/app-admin/apachetop/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-admin/apachetop
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/apachetop/ChangeLog,v 1.16 2004/07/09 19:42:16 stuart Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/apachetop/ChangeLog,v 1.17 2004/07/15 20:32:50 tigger Exp $
+
+ 15 Jul 2004; Rob Holland <tigger@ereet.co.uk> apachetop-0.12.ebuild:
+ Fix DEPEND/RDEPENDs. Should close #56756. Thanks to wood-worker@gmx.net for
+ reporting the issue.
09 Jul 2004; Stuart Herbert <stuart@gentoo.org> apachetop-0.11.ebuild,
apachetop-0.12.ebuild:
diff --git a/app-admin/apachetop/Manifest b/app-admin/apachetop/Manifest
index 17d0553a5951..40c33238c5c6 100644
--- a/app-admin/apachetop/Manifest
+++ b/app-admin/apachetop/Manifest
@@ -1,6 +1,6 @@
-MD5 e111c664dba744cd0a477a650a84863c ChangeLog 2001
-MD5 f61bfa064e3acdfcd826e4a38b121196 metadata.xml 161
-MD5 0677aa728a32c73798f67b69fd579e21 apachetop-0.12.ebuild 988
+MD5 46a79f5a715501c677f436c5699fe2b0 apachetop-0.12.ebuild 1052
MD5 03397a63a4010f1064a5fd7aae65088a apachetop-0.11.ebuild 1025
-MD5 6e87f45d9828dcc07fc87b5f2c75d159 files/digest-apachetop-0.12 66
+MD5 61bbc1475229d1eabb758c4151cd91e1 ChangeLog 2174
+MD5 f61bfa064e3acdfcd826e4a38b121196 metadata.xml 161
MD5 fdecf3384b463c0f2b2d46f6417c7a69 files/digest-apachetop-0.11 66
+MD5 6e87f45d9828dcc07fc87b5f2c75d159 files/digest-apachetop-0.12 66
diff --git a/app-admin/apachetop/apachetop-0.12.ebuild b/app-admin/apachetop/apachetop-0.12.ebuild
index f058441c029b..6950db4cbc15 100644
--- a/app-admin/apachetop/apachetop-0.12.ebuild
+++ b/app-admin/apachetop/apachetop-0.12.ebuild
@@ -1,21 +1,21 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/apachetop/apachetop-0.12.ebuild,v 1.5 2004/07/09 19:42:16 stuart Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/apachetop/apachetop-0.12.ebuild,v 1.6 2004/07/15 20:32:50 tigger Exp $
DESCRIPTION="A realtime Apache log analyzer"
HOMEPAGE="http://clueful.shagged.org/apachetop/"
SRC_URI="http://clueful.shagged.org/apachetop/files/${P}.tar.gz"
-IUSE="apache2"
+IUSE="apache2 fam pcre"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ~sparc ~mips"
-DEPEND="!apache2? ( >=net-www/apache-1.3.28 )
- apache2? ( >=net-www/apache-2.0.47 )
- sys-apps/sed
- sys-libs/libtermcap-compat"
+DEPEND="sys-apps/sed"
+RDEPEND="sys-libs/libtermcap-compat
+ fam? ( app-admin/fam )
+ pcre? ( dev-libs/libpcre )"
src_compile() {
if use apache2
@@ -24,7 +24,9 @@ src_compile() {
else
sed -i 's%DEFAULT_LOGFILE "/var/httpd/apache_log"%DEFAULT_LOGFILE "/var/log/apache/access_log"%' src/apachetop.h
fi
- ./configure
+ local myconf
+ myconf="${myconf} $(use_with fam) $(use_with pcre)"
+ econf ${myconf}
emake || die
}