summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2006-01-25 08:01:02 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2006-01-25 08:01:02 +0000
commitf8575f867b04487965de25f5c9d526df1a50a0ae (patch)
treed85ca5d43449cd835ee219c18def010e3d249e95
parentstable on x86, security bug #115775 (diff)
downloadhistorical-f8575f867b04487965de25f5c9d526df1a50a0ae.tar.gz
historical-f8575f867b04487965de25f5c9d526df1a50a0ae.tar.bz2
historical-f8575f867b04487965de25f5c9d526df1a50a0ae.zip
(#118800) Fix modular X deps. USE=X did nothing, so remove it. Fix USE=-gtk.
Package-Manager: portage-2.1_pre3-r1
-rw-r--r--x11-misc/hotkeys/ChangeLog8
-rw-r--r--x11-misc/hotkeys/Manifest14
-rw-r--r--x11-misc/hotkeys/hotkeys-0.5.7.1-r1.ebuild14
3 files changed, 16 insertions, 20 deletions
diff --git a/x11-misc/hotkeys/ChangeLog b/x11-misc/hotkeys/ChangeLog
index 8eafb1d019bd..ebd01cd6df4e 100644
--- a/x11-misc/hotkeys/ChangeLog
+++ b/x11-misc/hotkeys/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-misc/hotkeys
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/hotkeys/ChangeLog,v 1.23 2005/07/11 23:05:34 swegener Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/hotkeys/ChangeLog,v 1.24 2006/01/25 08:01:02 spyderous Exp $
+
+ 25 Jan 2006; Donnie Berkholz <spyderous@gentoo.org>;
+ hotkeys-0.5.7.1-r1.ebuild:
+ (#118800) Fix modular X deps. USE=X did nothing, so remove it. Fix USE=-gtk.
11 Jul 2005; Sven Wegener <swegener@gentoo.org> hotkeys-0.5.7.1-r1.ebuild:
QA: Use use_with for econf.
diff --git a/x11-misc/hotkeys/Manifest b/x11-misc/hotkeys/Manifest
index 10883a0e5f2b..cea4025ceffa 100644
--- a/x11-misc/hotkeys/Manifest
+++ b/x11-misc/hotkeys/Manifest
@@ -1,16 +1,6 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 9c359f23befcae63972b0edced764724 ChangeLog 2722
+MD5 db451c53073c4ed25e8562be7f88a12f ChangeLog 2887
MD5 26aa28d3165265b8153adbb4a071d0af files/digest-hotkeys-0.5.7.1-r1 67
MD5 ceb23c573710586557d5f664975c6740 files/hotkeys-0.5.7.1-gentoo.diff 538
MD5 2b1987adcf943427133e4f897782604c files/hotkeys-0.5.7.1-r1-gentoo.diff 1379
-MD5 5719c86b1bdfd3769cd1b6725b49dff6 hotkeys-0.5.7.1-r1.ebuild 958
+MD5 8e45f9cd6f4699bc59b08e709401409e hotkeys-0.5.7.1-r1.ebuild 997
MD5 503ccb1138f9c49f0855884d830988a6 metadata.xml 253
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFC0vtLI1lqEGTUzyQRAqygAKCyeulVREThm4yGeMAeMWOSyCkP5QCg0rXc
-egD6TZniXq7NnxK3IuLvdao=
-=0Q+q
------END PGP SIGNATURE-----
diff --git a/x11-misc/hotkeys/hotkeys-0.5.7.1-r1.ebuild b/x11-misc/hotkeys/hotkeys-0.5.7.1-r1.ebuild
index 9e8ff578e27b..28bede886a4e 100644
--- a/x11-misc/hotkeys/hotkeys-0.5.7.1-r1.ebuild
+++ b/x11-misc/hotkeys/hotkeys-0.5.7.1-r1.ebuild
@@ -1,18 +1,18 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/hotkeys/hotkeys-0.5.7.1-r1.ebuild,v 1.11 2005/07/11 23:05:34 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/hotkeys/hotkeys-0.5.7.1-r1.ebuild,v 1.12 2006/01/25 08:01:02 spyderous Exp $
inherit eutils
DESCRIPTION="Make use of extra buttons on newer keyboards."
SRC_URI="http://ypwong.org/hotkeys/${PV}/${PN}_${PV}.tar.gz"
HOMEPAGE="http://ypwong.org/hotkeys/"
-IUSE="X gtk xosd"
+IUSE="gtk xosd"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ~sparc amd64 ppc"
-DEPEND="X? ( virtual/x11 )
+DEPEND="|| ( x11-libs/libXmu virtual/x11 )
>=dev-libs/libxml2-2.2.8
=sys-libs/db-3.2*
xosd? ( >=x11-libs/xosd-1.0.0 )
@@ -25,11 +25,13 @@ src_unpack() {
}
src_compile() {
+ if use gtk; then
+ opts="${opts} --with-gtk"
+ fi
econf \
--disable-db3test \
- $(use_with X) \
$(use_with xosd) \
- $(use_with gtk) \
+ ${opts} \
|| die "./configure failed"
emake || die
}