summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2008-07-27 22:21:48 +0000
committerCarsten Lohrke <carlo@gentoo.org>2008-07-27 22:21:48 +0000
commitebad057276a4a28e70ac9a82519fbbcc98eb5db8 (patch)
treeb1128ddc33172a8568afddd4890ae0604143148d
parentQA: Get rid of deprecated qt_min_version(). (diff)
downloadhistorical-ebad057276a4a28e70ac9a82519fbbcc98eb5db8.tar.gz
historical-ebad057276a4a28e70ac9a82519fbbcc98eb5db8.tar.bz2
historical-ebad057276a4a28e70ac9a82519fbbcc98eb5db8.zip
QA: Get rid of deprecated qt_min_version().
Package-Manager: portage-2.1.4.4
-rw-r--r--sci-mathematics/kseg/ChangeLog7
-rw-r--r--sci-mathematics/kseg/Manifest4
-rw-r--r--sci-mathematics/kseg/kseg-0.403.ebuild12
3 files changed, 14 insertions, 9 deletions
diff --git a/sci-mathematics/kseg/ChangeLog b/sci-mathematics/kseg/ChangeLog
index 2b5fbc200a4d..8729bbf1bfbc 100644
--- a/sci-mathematics/kseg/ChangeLog
+++ b/sci-mathematics/kseg/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-mathematics/kseg
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/kseg/ChangeLog,v 1.5 2007/07/18 02:11:03 cryos Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/kseg/ChangeLog,v 1.6 2008/07/27 22:21:48 carlo Exp $
+
+ 27 Jul 2008; Carsten Lohrke <carlo@gentoo.org> kseg-0.403.ebuild:
+ QA: Get rid of deprecated qt_min_version().
18 Jul 2007; Marcus D. Hanwell <cryos@gentoo.org>
-files/kseg-0.402-gentoo.patch, -kseg-0.402.ebuild, kseg-0.403.ebuild:
diff --git a/sci-mathematics/kseg/Manifest b/sci-mathematics/kseg/Manifest
index 79ec2d80a123..b9088be634a2 100644
--- a/sci-mathematics/kseg/Manifest
+++ b/sci-mathematics/kseg/Manifest
@@ -1,4 +1,4 @@
DIST kseg-0.403.tar.gz 656675 RMD160 abfabdae67be7d6af8d61cc159dbd91b7271e723 SHA1 24655ca2a50f3470aeee8a361f50cdd7a0646049 SHA256 233743ea0b5916c45f15e1780cc5a44e9b069d9841d34a5cb2f680f4a060c2d5
-EBUILD kseg-0.403.ebuild 1074 RMD160 887ac8d0210c7d1e051e1586dbd1173c70d4e53b SHA1 54fd4ed7665d62d12e599f207d1c47d0db0a31d5 SHA256 f78931b219cf7041dfcc30b7b1d1d0a3ebafdae1934388319f485095811c435a
-MISC ChangeLog 1146 RMD160 ff35794f736c6748da4e4e25aab219fac0874fea SHA1 abfa097b20139d9b6705fa67d8ab6ec50266feb4 SHA256 cea9c9901d8ee3fa027fdd4138ec5ff622f0b261046dd282297ddb2e1a9f4c4a
+EBUILD kseg-0.403.ebuild 1080 RMD160 928d9a167dd72723cc8b0ba1b132a93bdf72e518 SHA1 841c8e15a123080cbdf5d5868f8585e79353de79 SHA256 3e9464f9df1b7938d79298dcdaab1613504fc6e8fca1f6e5209ade5a9d631ba1
+MISC ChangeLog 1261 RMD160 8c83b6d236a19f49dbf7e1c410f366b1e75f2f24 SHA1 91d7c423179af88d7e7d67b5a07b8b19da268bcc SHA256 011a7c816c7071f7d5501362b6bb2b2de047b70e2f2f1efa50c605af88cd2802
MISC metadata.xml 592 RMD160 cf041bd5f27ef6d879929ca630c1b3aa1d58b719 SHA1 97b743caeababad4acbe87758205871a2b34ecf6 SHA256 6b26f7571638c101219d22cc43981a2cdb1747ac13745d9a166dba711a44da7f
diff --git a/sci-mathematics/kseg/kseg-0.403.ebuild b/sci-mathematics/kseg/kseg-0.403.ebuild
index e5ba61e29297..9a889fdc9321 100644
--- a/sci-mathematics/kseg/kseg-0.403.ebuild
+++ b/sci-mathematics/kseg/kseg-0.403.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/kseg/kseg-0.403.ebuild,v 1.4 2007/07/18 02:11:03 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/kseg/kseg-0.403.ebuild,v 1.5 2008/07/27 22:21:48 carlo Exp $
+
+EAPI=1
inherit eutils qt3
@@ -11,20 +13,20 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~ppc ~ppc64 ~x86"
IUSE="examples"
-DEPEND="$(qt_min_version 3.3)"
+DEPEND="x11-libs/qt:3"
S=${WORKDIR}/${PN}
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
# Fix silly hardcoded help file path and CCFLAGS.
#epatch ${FILESDIR}/${P}-gentoo.patch
sed -i -e "s|KSEG_HELP_DIR|${PF}/help|" main.cpp
}
src_compile() {
- ${QTDIR}/bin/qmake QMAKE=${QTDIR}/bin/qmake || die 'qmake failed.'
+ "${QTDIR}"/bin/qmake QMAKE="${QTDIR}"/bin/qmake || die 'qmake failed.'
emake || die 'emake failed.'
}