summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-03-31 01:21:49 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-03-31 01:21:49 +0000
commitdd72ea3184dd714ef009fe4fb76556f2571d9afa (patch)
tree26b4cadfa91c02d1e0c45df955c27f0cdcbcf495
parentver bump (diff)
downloadhistorical-dd72ea3184dd714ef009fe4fb76556f2571d9afa.tar.gz
historical-dd72ea3184dd714ef009fe4fb76556f2571d9afa.tar.bz2
historical-dd72ea3184dd714ef009fe4fb76556f2571d9afa.zip
Initial version. Player and xmms plugin for playstation music files.
-rw-r--r--media-sound/sexypsf/ChangeLog10
-rw-r--r--media-sound/sexypsf/Manifest5
-rw-r--r--media-sound/sexypsf/files/digest-sexypsf-0.4.51
-rw-r--r--media-sound/sexypsf/files/sexypsf-0.4.5-gentoo.patch53
-rw-r--r--media-sound/sexypsf/metadata.xml5
-rw-r--r--media-sound/sexypsf/sexypsf-0.4.5.ebuild59
6 files changed, 133 insertions, 0 deletions
diff --git a/media-sound/sexypsf/ChangeLog b/media-sound/sexypsf/ChangeLog
new file mode 100644
index 000000000000..dff5c8a2a329
--- /dev/null
+++ b/media-sound/sexypsf/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for media-sound/sexypsf
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sexypsf/ChangeLog,v 1.1 2004/03/31 01:21:49 eradicator Exp $
+
+*sexypsf-0.4.5 (30 Mar 2004)
+
+ 30 Mar 2004; Jeremy Huddleston <eradicator@gentoo.org> sexypsf-0.4.5.ebuild,
+ files/sexypsf-0.4.5-gentoo.patch:
+ Initial version. Player and xmms plugin for playstation music files.
+
diff --git a/media-sound/sexypsf/Manifest b/media-sound/sexypsf/Manifest
new file mode 100644
index 000000000000..53c3aed1d804
--- /dev/null
+++ b/media-sound/sexypsf/Manifest
@@ -0,0 +1,5 @@
+MD5 c95316140a7594b3745df7ab3fbf09f0 sexypsf-0.4.5.ebuild 1266
+MD5 a45f725e266a48fe6d417b4eefe270b8 ChangeLog 442
+MD5 a1eaeb2ae801daeb712c90c060e922dc metadata.xml 158
+MD5 41f230a0e2debf8b51025a2d796c6e31 files/digest-sexypsf-0.4.5 61
+MD5 ec1912f27a7e4330699ef6addc03a8b0 files/sexypsf-0.4.5-gentoo.patch 1608
diff --git a/media-sound/sexypsf/files/digest-sexypsf-0.4.5 b/media-sound/sexypsf/files/digest-sexypsf-0.4.5
new file mode 100644
index 000000000000..949cc1c17c28
--- /dev/null
+++ b/media-sound/sexypsf/files/digest-sexypsf-0.4.5
@@ -0,0 +1 @@
+MD5 e00a0002ac89383bd1d938a65c2d3fd6 sexypsf045.tar.gz 92140
diff --git a/media-sound/sexypsf/files/sexypsf-0.4.5-gentoo.patch b/media-sound/sexypsf/files/sexypsf-0.4.5-gentoo.patch
new file mode 100644
index 000000000000..9cd6052352c9
--- /dev/null
+++ b/media-sound/sexypsf/files/sexypsf-0.4.5-gentoo.patch
@@ -0,0 +1,53 @@
+diff -Naur sexypsf.vanilla/Linux/Makefile sexypsf/Linux/Makefile
+--- sexypsf.vanilla/Linux/Makefile 2004-02-07 10:29:54.000000000 -0800
++++ sexypsf/Linux/Makefile 2004-03-30 17:17:29.000000000 -0800
+@@ -8,8 +8,7 @@
+ RM = rm -f
+ STRIP = strip
+
+-OPTIMIZE = -O2 -fomit-frame-pointer -finline-functions -ffast-math
+-FLAGS = -g -D__LINUX__ -DPSS_STYLE=1
++FLAGS = -g -D__LINUX__ -DPSS_STYLE=1 -fPIC
+ #-DTIMEO
+ LIBS = -lz
+
+@@ -20,7 +19,7 @@
+
+ OBJS+= LnxMain.o
+
+-CFLAGS = -Wall -Winline ${OPTIMIZE} -I. -I.. -I/usr/include/g++ ${FLAGS}
++CFLAGS+= -Wall -Winline -I. -I.. -I/usr/include/g++ ${FLAGS}
+ CFLAGS+= $(shell gtk-config --cflags)
+ #CFLAGS+= $(shell pkg-config gtk+-2.0 --cflags)
+
+diff -Naur sexypsf.vanilla/xmms/Makefile sexypsf/xmms/Makefile
+--- sexypsf.vanilla/xmms/Makefile 2003-09-20 13:12:30.000000000 -0700
++++ sexypsf/xmms/Makefile 2004-03-30 17:17:38.000000000 -0800
+@@ -11,8 +11,7 @@
+ RM = rm -f
+ #LD = ld -shared
+ LIBS = -lz -shared $(shell gtk-config --libs)
+-OPTIMIZE = -O2 -finline-functions -ffast-math
+-FLAGS = -DPSS_STYLE=1
++FLAGS = -DPSS_STYLE=1 -fPIC
+
+ OBJS = ../PsxBios.o ../PsxCounters.o ../PsxDma.o \
+ ../Spu.o ../PsxHw.o ../PsxMem.o ../Misc.o \
+@@ -22,7 +21,7 @@
+ OBJS+= xmms.o
+
+ ifeq (${CPU}, ix86)
+- OPTIMIZE += -fomit-frame-pointer -mcpu=i686 -fno-exceptions
++# OPTIMIZE += -fomit-frame-pointer -mcpu=i686 -fno-exceptions
+ endif
+
+ ifeq (${CPU}, ppc)
+@@ -33,7 +32,7 @@
+ FLAGS+=-DMSB_FIRST
+ endif
+
+-CFLAGS = -Wall ${OPTIMIZE} -I. -I.. -I/usr/include/g++ ${FLAGS}
++CFLAGS+= -Wall -I. -I.. -I/usr/include/g++ ${FLAGS}
+ CFLAGS+= $(shell gtk-config --cflags)
+
+ #ifdef LD
diff --git a/media-sound/sexypsf/metadata.xml b/media-sound/sexypsf/metadata.xml
new file mode 100644
index 000000000000..e1774e3d9ad7
--- /dev/null
+++ b/media-sound/sexypsf/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sound</herd>
+</pkgmetadata>
diff --git a/media-sound/sexypsf/sexypsf-0.4.5.ebuild b/media-sound/sexypsf/sexypsf-0.4.5.ebuild
new file mode 100644
index 000000000000..4851e0dccfd5
--- /dev/null
+++ b/media-sound/sexypsf/sexypsf-0.4.5.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sexypsf/sexypsf-0.4.5.ebuild,v 1.1 2004/03/31 01:21:49 eradicator Exp $
+
+inherit eutils
+
+DESCRIPTION="sexyPSF is an open-source PSF (Playstation music) file player"
+
+MY_P="${PN}${PV//./}"
+HOMEPAGE="http://xodnizel.net/${PN}/"
+SRC_URI="http://xodnizel.net/${PN}/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="xmms"
+KEYWORDS="~x86"
+
+DEPEND="sys-libs/zlib
+ xmms? ( media-sound/xmms )"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gentoo.patch
+}
+
+src_compile() {
+ cd ${S}/Linux
+
+ # ppc and sparc are big-endian while all other keywords are
+ # little-endian (as far as I know)
+ use ppc64 || use ppc || use sparc && CPU="MSBFIRST" || CPU="LSBFIRST"
+
+ emake CPU="${CPU}" || die
+
+ if use xmms; then
+ cd ${S}/xmms
+ emake CPU="${CPU}" || die
+ fi
+}
+
+src_install() {
+ cd ${S}/Linux
+ dobin sexypsf
+
+ if use xmms; then
+ cd ${S}/xmms
+ exeinto `xmms-config --input-plugin-dir`
+ doexe libsexypsf.so
+ fi
+
+ dodoc ${S}/Docs/*
+}
+
+pkg_postinst() {
+ ewarn "The xmms plugin seems to be unstable. It does not play minipsf files,"
+ ewarn "but the command line works fine with them."
+}