summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoel Martin <kanaka@gentoo.org>2006-02-08 19:09:59 +0000
committerJoel Martin <kanaka@gentoo.org>2006-02-08 19:09:59 +0000
commitdbc0e0623f45f8bad80ed61bbdb1612a5bbe7bba (patch)
tree5faaa08a4bbf6219c86dc7b2fc0f9a871ecfe1fe
parentModified patchset to work with useflag bigpatch (See bug #122100) (diff)
downloadhistorical-dbc0e0623f45f8bad80ed61bbdb1612a5bbe7bba.tar.gz
historical-dbc0e0623f45f8bad80ed61bbdb1612a5bbe7bba.tar.bz2
historical-dbc0e0623f45f8bad80ed61bbdb1612a5bbe7bba.zip
Do not strip in makefile, this break cross-compile.
Package-Manager: portage-2.0.53
-rw-r--r--sys-apps/pciutils/ChangeLog7
-rw-r--r--sys-apps/pciutils/Manifest14
-rw-r--r--sys-apps/pciutils/pciutils-2.2.0-r1.ebuild6
3 files changed, 21 insertions, 6 deletions
diff --git a/sys-apps/pciutils/ChangeLog b/sys-apps/pciutils/ChangeLog
index 1b5fa916e512..27e10fd69882 100644
--- a/sys-apps/pciutils/ChangeLog
+++ b/sys-apps/pciutils/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-apps/pciutils
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/ChangeLog,v 1.69 2005/12/24 15:41:00 hansmi Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/ChangeLog,v 1.70 2006/02/08 19:09:59 kanaka Exp $
+
+ 08 Feb 2006; Joel Martin <kanaka@gentoo.org> pciutils-2.2.0-r1.ebuild:
+ Do not strip in makefile, this break cross-compile.
24 Dec 2005; Michael Hanselmann <hansmi@gentoo.org>
pciutils-2.2.0-r1.ebuild:
diff --git a/sys-apps/pciutils/Manifest b/sys-apps/pciutils/Manifest
index 038601c19e52..008d9dcc4bb0 100644
--- a/sys-apps/pciutils/Manifest
+++ b/sys-apps/pciutils/Manifest
@@ -1,4 +1,7 @@
-MD5 cba48e5796e564ad98e3d24f208d7c20 ChangeLog 9191
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 770315e54db9b30a85fb1b974d0bf19a ChangeLog 9319
MD5 60d79fbf53038186b939f83841d5f318 files/2.1.11-scan.patch 277
MD5 a6be9cf60dc5043160d757c9772b1e57 files/digest-pciutils-2.1.11-r5 131
MD5 ae29f04095b43ceb06e6b0cc94653c36 files/digest-pciutils-2.2.0-r1 130
@@ -11,4 +14,11 @@ MD5 f4d220c568a00c1ceafe6dc129ae6e95 files/pciutils-2.1.11-sysfs.patch 10374
MD5 cf455fe33057e081ba7aaec93e481642 files/pciutils-2.2.0-shared-lib.patch 496
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
MD5 61778080ed55196416ece68570ba885a pciutils-2.1.11-r5.ebuild 2298
-MD5 9eb53d5c8c8a991b6df900cdead1e8bc pciutils-2.2.0-r1.ebuild 1657
+MD5 3f1bfc65549f8a6daf759a56a0c73dd5 pciutils-2.2.0-r1.ebuild 1779
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2 (GNU/Linux)
+
+iD8DBQFD6kIbbaW+3NC9cLgRAmZ+AJ9Gn7/JDpNhtza9JL6KRDNTJeEzdgCfS9sb
+dUMV67P1O9CHMCImW43mH+0=
+=JK6f
+-----END PGP SIGNATURE-----
diff --git a/sys-apps/pciutils/pciutils-2.2.0-r1.ebuild b/sys-apps/pciutils/pciutils-2.2.0-r1.ebuild
index 72e427e2989d..38ff9dd11135 100644
--- a/sys-apps/pciutils/pciutils-2.2.0-r1.ebuild
+++ b/sys-apps/pciutils/pciutils-2.2.0-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/pciutils-2.2.0-r1.ebuild,v 1.11 2005/12/24 15:41:00 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/pciutils-2.2.0-r1.ebuild,v 1.12 2006/02/08 19:09:59 kanaka Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -26,9 +26,11 @@ src_unpack() {
epatch "${FILESDIR}"/${PN}-2.1.11-malloc.patch
# Set Gentoo paths
+ # and do not strip (breaks cross-compile), portage handles stripping
sed -i \
-e '/^PREFIX=/s:=.*:=/usr:' \
-e '/^IDSDIR=/s:=.*:=$(PREFIX)/share/misc:' \
+ -e '/INSTALL.* -s lspci /s: -s lspci : lspci :' \
Makefile || die
# Make sure we respect $AR / $RANLIB