summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-12-31 11:32:59 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-12-31 11:32:59 +0000
commitc782fd78b23d0f6571216fffc2dbcf5146eeb546 (patch)
tree7f223073db6063fd8381d8711e6f6e8c240fbc10
parentversion bump (diff)
downloadhistorical-c782fd78b23d0f6571216fffc2dbcf5146eeb546.tar.gz
historical-c782fd78b23d0f6571216fffc2dbcf5146eeb546.tar.bz2
historical-c782fd78b23d0f6571216fffc2dbcf5146eeb546.zip
version bump
Package-Manager: portage-2.2.0_alpha84/cvs/Linux x86_64
-rw-r--r--dev-ml/pcre-ocaml/ChangeLog7
-rw-r--r--dev-ml/pcre-ocaml/pcre-ocaml-6.2.4.ebuild44
-rw-r--r--dev-ml/postgresql-ocaml/ChangeLog8
-rw-r--r--dev-ml/postgresql-ocaml/postgresql-ocaml-1.17.0.ebuild42
4 files changed, 99 insertions, 2 deletions
diff --git a/dev-ml/pcre-ocaml/ChangeLog b/dev-ml/pcre-ocaml/ChangeLog
index cd0efc249cc9..9dd88316483f 100644
--- a/dev-ml/pcre-ocaml/ChangeLog
+++ b/dev-ml/pcre-ocaml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/pcre-ocaml
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/pcre-ocaml/ChangeLog,v 1.40 2011/12/07 13:20:42 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pcre-ocaml/ChangeLog,v 1.41 2011/12/31 11:30:27 aballier Exp $
+
+*pcre-ocaml-6.2.4 (31 Dec 2011)
+
+ 31 Dec 2011; Alexis Ballier <aballier@gentoo.org> +pcre-ocaml-6.2.4.ebuild:
+ version bump
*pcre-ocaml-6.2.3 (07 Dec 2011)
diff --git a/dev-ml/pcre-ocaml/pcre-ocaml-6.2.4.ebuild b/dev-ml/pcre-ocaml/pcre-ocaml-6.2.4.ebuild
new file mode 100644
index 000000000000..48244b0f6cd4
--- /dev/null
+++ b/dev-ml/pcre-ocaml/pcre-ocaml-6.2.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pcre-ocaml/pcre-ocaml-6.2.4.ebuild,v 1.1 2011/12/31 11:30:27 aballier Exp $
+
+EAPI="2"
+
+inherit findlib eutils
+
+DESCRIPTION="Perl Compatibility Regular Expressions for O'Caml"
+HOMEPAGE="http://www.ocaml.info/home/ocaml_sources.html"
+SRC_URI="http://www.ocaml.info/ocaml_sources/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+
+RDEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]
+ >=dev-libs/libpcre-4.5"
+DEPEND="${RDEPEND}"
+SLOT="0"
+IUSE="examples +ocamlopt"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-6.0.1-linkopts.patch"
+}
+
+src_compile() {
+ cd "${S}/lib"
+ emake byte-code-library || die "Failed to build byte code library"
+ if use ocamlopt; then
+ emake native-code-library || die "Failed to build native code library"
+ fi
+}
+
+src_install () {
+ export OCAMLFIND_INSTFLAGS="-optional"
+ findlib_src_install
+
+ # install documentation
+ dodoc README.txt Changelog
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
diff --git a/dev-ml/postgresql-ocaml/ChangeLog b/dev-ml/postgresql-ocaml/ChangeLog
index 231fb7178f44..f6d8e72490ce 100644
--- a/dev-ml/postgresql-ocaml/ChangeLog
+++ b/dev-ml/postgresql-ocaml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/postgresql-ocaml
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/ChangeLog,v 1.24 2011/07/24 16:08:09 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/ChangeLog,v 1.25 2011/12/31 11:32:59 aballier Exp $
+
+*postgresql-ocaml-1.17.0 (31 Dec 2011)
+
+ 31 Dec 2011; Alexis Ballier <aballier@gentoo.org>
+ +postgresql-ocaml-1.17.0.ebuild:
+ version bump
24 Jul 2011; Alexis Ballier <aballier@gentoo.org>
-postgresql-ocaml-1.4.6.ebuild, -postgresql-ocaml-1.14.0.ebuild:
diff --git a/dev-ml/postgresql-ocaml/postgresql-ocaml-1.17.0.ebuild b/dev-ml/postgresql-ocaml/postgresql-ocaml-1.17.0.ebuild
new file mode 100644
index 000000000000..48124c2c96eb
--- /dev/null
+++ b/dev-ml/postgresql-ocaml/postgresql-ocaml-1.17.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/postgresql-ocaml-1.17.0.ebuild,v 1.1 2011/12/31 11:32:59 aballier Exp $
+
+EAPI="2"
+
+inherit findlib eutils
+
+IUSE="examples +ocamlopt"
+
+DESCRIPTION="A package for ocaml that provides access to PostgreSQL databases."
+SRC_URI="http://ocaml.info/ocaml_sources/${P}.tar.gz"
+HOMEPAGE="http://ocaml.info/home/ocaml_sources.html#toc9"
+
+DEPEND=">=dev-lang/ocaml-3.11[ocamlopt?]
+ dev-db/postgresql-base
+ dev-db/postgresql-server"
+RDEPEND="${DEPEND}"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+src_compile() {
+ cd "${S}/lib"
+ emake -j1 byte-code-library || die "failed to build byte code library"
+ if use ocamlopt; then
+ emake -j1 native-code-library || die "failed to built nativde code library"
+ fi
+}
+
+src_install () {
+ use ocamlopt || export OCAMLFIND_INSTFLAGS="-optional"
+ findlib_src_preinst
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS Changelog README.txt
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}