summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChuck Short <zul@gentoo.org>2003-12-22 13:22:20 +0000
committerChuck Short <zul@gentoo.org>2003-12-22 13:22:20 +0000
commitc2ba29f1e8fecee55c2c9a35d006fb5ef9d90221 (patch)
tree31ea44175aff55fcab971ef56405d9bb85a1f821
parentInitial version, closes #35125. (diff)
downloadhistorical-c2ba29f1e8fecee55c2c9a35d006fb5ef9d90221.tar.gz
historical-c2ba29f1e8fecee55c2c9a35d006fb5ef9d90221.tar.bz2
historical-c2ba29f1e8fecee55c2c9a35d006fb5ef9d90221.zip
Initial version, closes #35125.
-rw-r--r--net-misc/gofish/Manifest6
-rw-r--r--net-misc/gofish/files/digest-gofish-0.291
-rw-r--r--net-misc/gofish/files/gofish.confd27
-rw-r--r--net-misc/gofish/files/gofish.rc33
-rw-r--r--net-misc/gofish/gofish-0.29.ebuild44
-rw-r--r--net-misc/gofish/metadata.xml8
6 files changed, 118 insertions, 1 deletions
diff --git a/net-misc/gofish/Manifest b/net-misc/gofish/Manifest
index a97237103dcc..f775e20293c1 100644
--- a/net-misc/gofish/Manifest
+++ b/net-misc/gofish/Manifest
@@ -1,2 +1,6 @@
-MD5 103b3030760c5040413033e3f6f8bf28 gofish-0.29.ebuild 1012
+MD5 c174bcf8600cd08499fcd9df055d83e8 gofish-0.29.ebuild 1093
+MD5 7af591e2c6b7eb43038ac5c0f2a6ae4d ChangeLog 443
+MD5 7e285f080272b311b0eb8b0028928e07 metadata.xml 219
+MD5 a4671e7c6f0585c6a7a9c31660facfca files/gofish.rc 606
+MD5 6af9d916a6e6222df07761444fdcdaac files/gofish.confd 429
MD5 15cc76b6e0734f9cd401828b760f0a73 files/digest-gofish-0.29 63
diff --git a/net-misc/gofish/files/digest-gofish-0.29 b/net-misc/gofish/files/digest-gofish-0.29
new file mode 100644
index 000000000000..ff998051cdf3
--- /dev/null
+++ b/net-misc/gofish/files/digest-gofish-0.29
@@ -0,0 +1 @@
+MD5 090010dff4dca4f9c3c6bcad61038665 gofish-0.29.tar.gz 122098
diff --git a/net-misc/gofish/files/gofish.confd b/net-misc/gofish/files/gofish.confd
new file mode 100644
index 000000000000..af244521a7e7
--- /dev/null
+++ b/net-misc/gofish/files/gofish.confd
@@ -0,0 +1,27 @@
+#
+# Config file for gofish Gentoo start-script.
+# Should be stored as: /etc/conf.d/gofish
+#
+
+# Application name
+GOFISH_APP=gofish
+
+# Path to gofish executable
+GOFISH_EXEC=/usr/sbin/gofish
+
+# The gofish config file
+GOFISH_CONF_FILE=/etc/gofish.conf
+
+# The start options
+GOFISH_START_OPTS="-d"
+
+# The stop options
+GOFISH_STOP_OPTS=""
+
+# The reload options
+GOFISH_RELOAD_OPTS=""
+
+# The pid file
+GOFISH_PIDFILE=/var/run/gofish.pid
+
+
diff --git a/net-misc/gofish/files/gofish.rc b/net-misc/gofish/files/gofish.rc
new file mode 100644
index 000000000000..aa49772f1379
--- /dev/null
+++ b/net-misc/gofish/files/gofish.rc
@@ -0,0 +1,33 @@
+#!/sbin/runscript
+#
+# Startup script for the Gofish Gopher Server (for Gentoo Linux)
+#
+# config: /etc/conf.d/gofish
+##
+# use: rc-update add gofish default
+#
+
+opts="start stop"
+
+depend() {
+ need net
+}
+
+
+start() {
+ ebegin "Starting ${GOFISH_APP} "
+ start-stop-daemon --start --verbose --pidfile ${GOFISH_PIDFILE} \
+ --exec ${GOFISH_EXEC} -- ${GOFISH_START_OPTS}
+ eend $?
+}
+
+
+stop() {
+ ebegin "Stopping ${GOFISH_APP} "
+ start-stop-daemon --stop --quiet --pidfile ${GOFISH_PIDFILE} \
+ --exec ${GOFISH_EXEC} -- ${GOFISH_STOP_OPTS}
+ eend $?
+}
+
+
+
diff --git a/net-misc/gofish/gofish-0.29.ebuild b/net-misc/gofish/gofish-0.29.ebuild
new file mode 100644
index 000000000000..c8038fd1c931
--- /dev/null
+++ b/net-misc/gofish/gofish-0.29.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/gofish/gofish-0.29.ebuild,v 1.1 2003/12/22 13:22:10 zul Exp $
+
+IUSE=""
+
+S="${WORKDIR}/gofish-${PV}"
+HOMEPAGE="http://gofish.sourceforge.net"
+DESCRIPTION="Gofish gopher server"
+SRC_URI="mirror://sourceforge/gofish/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="virtual/glibc
+ >=sys-apps/sed-4"
+RDEPEND=""
+
+
+src_compile() {
+ econf --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
+ --disable-http
+ emake || die
+}
+
+src_install () {
+ sed -i s/';uid = -1'/'uid = 30'/ ${S}/gofish.conf
+ sed -i s/';gid = -1'/'uid = 30'/ ${S}/gofish.conf
+ make DESTDIR=${D} install || die
+ exeinto /etc/init.d ; newexe ${FILESDIR}/gofish.rc gofish
+ insinto /etc/conf.d ; newins ${FILESDIR}/gofish.confd gofish
+}
+
+
+pkg_postinst() {
+ enewgroup "gopher" 30
+ enewuser "gopher" 30 "/bin/false" "/dev/null" "gopher"
+
+ einfo
+ einfo "You have to edit the configuration file"
+ einfo "/etc/gofish.conf if this is a new install"
+ einfo
+}
diff --git a/net-misc/gofish/metadata.xml b/net-misc/gofish/metadata.xml
new file mode 100644
index 000000000000..d66bb0cd26df
--- /dev/null
+++ b/net-misc/gofish/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>zul@gentoo.org</email>
+</maintainer>
+</pkgmetadata>