summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2004-10-02 17:04:38 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2004-10-02 17:04:38 +0000
commitb6d50e64df807df42a6a5e170d2ae0e8033b19d5 (patch)
tree98c61d0fba8842c716c198c55f1d9adacd141ae4
parentKeyword ~alpha, bug 65841. (diff)
downloadhistorical-b6d50e64df807df42a6a5e170d2ae0e8033b19d5.tar.gz
historical-b6d50e64df807df42a6a5e170d2ae0e8033b19d5.tar.bz2
historical-b6d50e64df807df42a6a5e170d2ae0e8033b19d5.zip
Add some die()'s (#54595).
-rw-r--r--app-sci/mpqc/ChangeLog6
-rw-r--r--app-sci/mpqc/Manifest6
-rw-r--r--app-sci/mpqc/mpqc-2.2.2-r1.ebuild8
-rw-r--r--app-sci/mpqc/mpqc-2.2.2.ebuild8
4 files changed, 16 insertions, 12 deletions
diff --git a/app-sci/mpqc/ChangeLog b/app-sci/mpqc/ChangeLog
index 3ef7e1570d93..c61f956d735d 100644
--- a/app-sci/mpqc/ChangeLog
+++ b/app-sci/mpqc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-sci/mpqc
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/mpqc/ChangeLog,v 1.14 2004/09/23 08:24:09 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/mpqc/ChangeLog,v 1.15 2004/10/02 17:04:38 spyderous Exp $
+
+ 02 Oct 2004; Donnie Berkholz <spyderous@gentoo.org>; mpqc-2.2.2-r1.ebuild,
+ mpqc-2.2.2.ebuild:
+ Add some die()'s (#54595).
23 Sep 2004; Donnie Berkholz <spyderous@gentoo.org>; mpqc-2.2.2-r1.ebuild:
Add previous KEYWORDS as ~arch.
diff --git a/app-sci/mpqc/Manifest b/app-sci/mpqc/Manifest
index 052c567f1674..c7feab1a6482 100644
--- a/app-sci/mpqc/Manifest
+++ b/app-sci/mpqc/Manifest
@@ -1,6 +1,6 @@
-MD5 f3c3e455689345363d4b649fa753479d mpqc-2.2.2-r1.ebuild 1336
-MD5 c1e7d1fb899d447a12ac37e3237a566c ChangeLog 1655
+MD5 b6eaeb36f3414a9581916c0d33541858 mpqc-2.2.2-r1.ebuild 1408
+MD5 95bdc8b319e8d559cd6ec46d826ce98a ChangeLog 1783
MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
-MD5 61825968a6fbb6705c8eed9ee80527c9 mpqc-2.2.2.ebuild 1331
+MD5 dd3d8c69dfa94b9bc43251ef63d0c094 mpqc-2.2.2.ebuild 1403
MD5 ef8f7cc3214e84dfd6bec6d38eacb3a6 files/digest-mpqc-2.2.2-r1 129
MD5 ef8f7cc3214e84dfd6bec6d38eacb3a6 files/digest-mpqc-2.2.2 129
diff --git a/app-sci/mpqc/mpqc-2.2.2-r1.ebuild b/app-sci/mpqc/mpqc-2.2.2-r1.ebuild
index 8989656132a8..7d57610b4452 100644
--- a/app-sci/mpqc/mpqc-2.2.2-r1.ebuild
+++ b/app-sci/mpqc/mpqc-2.2.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/mpqc/mpqc-2.2.2-r1.ebuild,v 1.2 2004/09/23 08:24:09 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/mpqc/mpqc-2.2.2-r1.ebuild,v 1.3 2004/10/02 17:04:38 spyderous Exp $
DESCRIPTION="The Massively Parallel Quantum Chemistry Program"
HOMEPAGE="http://www.mpqc.org/"
@@ -24,13 +24,13 @@ src_compile() {
myconf="${myconf} --prefix=/usr"
use X && myconf="${myconf} --x-includes=/usr/X11R6/include \
--x-libraries=/usr/X11R6/lib"
- ./configure ${myconf}
+ ./configure ${myconf} || die "configure failed"
sed -e "s:^CFLAGS =.*$:CFLAGS=${CFLAGS_SAVE}:" \
-e "s:^FFLAGS =.*$:FFLAGS=${CFLAGS_SAVE}:" \
-e "s:^CXXFLAGS =.*$:CXXFLAGS=${CXXFLAGS_SAVE}:" \
lib/LocalMakefile > lib/LocalMakefile.foo
mv lib/LocalMakefile.foo lib/LocalMakefile
- emake
+ emake || die "emake failed"
}
src_install() {
@@ -38,5 +38,5 @@ src_install() {
> lib/LocalMakefile.foo
mv lib/LocalMakefile.foo lib/LocalMakefile
use doc && doman ${WORKDIR}/${PN}-man-${PV}/man3/*
- make install install_devel install_inc
+ make install install_devel install_inc || die "install failed"
}
diff --git a/app-sci/mpqc/mpqc-2.2.2.ebuild b/app-sci/mpqc/mpqc-2.2.2.ebuild
index 92519fd97a97..1579e10632f5 100644
--- a/app-sci/mpqc/mpqc-2.2.2.ebuild
+++ b/app-sci/mpqc/mpqc-2.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/mpqc/mpqc-2.2.2.ebuild,v 1.6 2004/09/21 10:09:22 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/mpqc/mpqc-2.2.2.ebuild,v 1.7 2004/10/02 17:04:38 spyderous Exp $
DESCRIPTION="The Massively Parallel Quantum Chemistry Program"
HOMEPAGE="http://www.mpqc.org/"
@@ -24,13 +24,13 @@ src_compile() {
myconf="${myconf} --prefix=/usr"
use X && myconf="${myconf} --x-includes=/usr/X11R6/include \
--x-libraries=/usr/X11R6/lib"
- ./configure ${myconf}
+ ./configure ${myconf} || die "configure failed"
sed -e "s:^CFLAGS =.*$:CFLAGS=${CFLAGS_SAVE}:" \
-e "s:^FFLAGS =.*$:FFLAGS=${CFLAGS_SAVE}:" \
-e "s:^CXXFLAGS =.*$:CXXFLAGS=${CXXFLAGS_SAVE}:" \
lib/LocalMakefile > lib/LocalMakefile.foo
mv lib/LocalMakefile.foo lib/LocalMakefile
- emake
+ emake || die "emake failed"
}
src_install() {
@@ -38,5 +38,5 @@ src_install() {
> lib/LocalMakefile.foo
mv lib/LocalMakefile.foo lib/LocalMakefile
use doc && doman ${WORKDIR}/${PN}-man-${PV}/man3/*
- make install install_devel install_inc
+ make install install_devel install_inc || die "install failed"
}