summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2003-09-27 02:13:14 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2003-09-27 02:13:14 +0000
commitb692562459313929e2bc63e1d63ae81197043413 (patch)
tree46effbeebd2789b70fe942d8e3b2d73636f2a6a2
parentinitial import (diff)
downloadhistorical-b692562459313929e2bc63e1d63ae81197043413.tar.gz
historical-b692562459313929e2bc63e1d63ae81197043413.tar.bz2
historical-b692562459313929e2bc63e1d63ae81197043413.zip
initial import
-rw-r--r--net-dns/mydns/Manifest6
-rw-r--r--net-dns/mydns/files/digest-mydns-0.10.01
-rw-r--r--net-dns/mydns/files/mydns.rc634
-rw-r--r--net-dns/mydns/metadata.xml8
-rw-r--r--net-dns/mydns/mydns-0.10.0.ebuild72
5 files changed, 119 insertions, 2 deletions
diff --git a/net-dns/mydns/Manifest b/net-dns/mydns/Manifest
index 29f99dd6e231..472bc7c6960f 100644
--- a/net-dns/mydns/Manifest
+++ b/net-dns/mydns/Manifest
@@ -1,3 +1,5 @@
-MD5 50229ac3e8d82b30315ce448271208ea mydns-0.10.0.ebuild 1787
+MD5 9e5dafe6b14c4b044a66920be69c1d5d mydns-0.10.0.ebuild 2007
+MD5 c50346bf0fb8b39c521dca42b145f6ee metadata.xml 230
+MD5 047be10a136103e91aa048b0996cef5a ChangeLog 345
MD5 610f498bbd7c9fdabdcd42e5694530e3 files/digest-mydns-0.10.0 65
-MD5 ac2ecd262598a412e9e245432ecf5ebf files/mydns.rc6 740
+MD5 bae8bbd8f268a4da83a5cc5df25d3d1d files/mydns.rc6 751
diff --git a/net-dns/mydns/files/digest-mydns-0.10.0 b/net-dns/mydns/files/digest-mydns-0.10.0
new file mode 100644
index 000000000000..f62e79309a61
--- /dev/null
+++ b/net-dns/mydns/files/digest-mydns-0.10.0
@@ -0,0 +1 @@
+MD5 4791990d1017fa85461dcc9fa31089f7 mydns-0.10.0.tar.bz2 567102
diff --git a/net-dns/mydns/files/mydns.rc6 b/net-dns/mydns/files/mydns.rc6
new file mode 100644
index 000000000000..8b41a2de43d7
--- /dev/null
+++ b/net-dns/mydns/files/mydns.rc6
@@ -0,0 +1,34 @@
+#!/sbin/runscript
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-dns/mydns/files/mydns.rc6,v 1.1 2003/09/27 02:13:11 matsuu Exp $
+
+depend() {
+ use mysql postgres
+}
+
+checkconfig() {
+ if [ ! -f /etc/mydns.conf ] ; then
+ eerror "No /etc/mydns.conf file exists!"
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+ ebegin "Starting mydnsd"
+ sleep 2
+ /usr/sbin/mydns -b >/dev/null 2>&1 &
+ eend $?
+}
+
+stop () {
+ ebegin "Stopping mydnsd"
+ PIDFILE=`cat /etc/mydns.conf | grep pidfile | awk '{ print $3 }'`
+ if [ $PIDFILE == "" ]; then
+ PIDFILE=/var/run/mydns.pid
+ fi
+ start-stop-daemon --stop --quiet \
+ --pidfile=${PIDFILE}
+ eend $?
+}
diff --git a/net-dns/mydns/metadata.xml b/net-dns/mydns/metadata.xml
new file mode 100644
index 000000000000..b35df34ade84
--- /dev/null
+++ b/net-dns/mydns/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>matsuu@gentoo.org</email>
+ <name>MATSUU Takuto</name>
+</maintainer>
+</pkgmetadata>
diff --git a/net-dns/mydns/mydns-0.10.0.ebuild b/net-dns/mydns/mydns-0.10.0.ebuild
new file mode 100644
index 000000000000..ed471fe4ac1d
--- /dev/null
+++ b/net-dns/mydns/mydns-0.10.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/mydns/mydns-0.10.0.ebuild,v 1.1 2003/09/27 02:13:11 matsuu Exp $
+
+DESCRIPTION="A DNS-Server which gets its data from mysql-databases"
+HOMEPAGE="http://mydns.bboy.net/"
+SRC_URI="http://mydns.bboy.net/download/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="nls static debug mysql postgres ssl zlib"
+
+RDEPEND="virtual/glibc
+ mysql? ( dev-db/mysql )
+ postgres? ( dev-db/postgresql )
+ openssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ sys-devel/bison"
+
+src_compile() {
+ if [ ! "`use mysql`" -a ! "`use postgres`" ] ; then
+ eerror "MyDNS needs either MySQL or PostgreSQL."
+ eerror "Please set USE=\"mysql\" or USE=\"postgres\", and try again."
+ die
+ fi
+
+ econf \
+ `use_enable nls` \
+ `use_enable debug` \
+ `use_enable static static-build` \
+ `use_with postgres pgsql` \
+ `use_with mysql` \
+ `use_with ssl openssl` \
+ `use_with zlib` || die
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc ABOUT-NLS AUTHORS BUGS ChangeLog INSTALL NEWS README TODO
+ use mysql && dodoc QUICKSTART.mysql
+ use postgres && dodoc QUICKSTART.postgres
+
+ exeinto /etc/init.d; newexe ${FILESDIR}/mydns.rc6 mydns || die
+}
+
+pkg_postinst() {
+ einfo
+ einfo "You should now run these commands:"
+ einfo
+ einfo "# /usr/sbin/mydns --dump-config > /etc/mydns.conf"
+ einfo "# chmod 0600 /etc/mydns.conf"
+ if [ "`use mysql`" ] ; then
+ einfo "# mysqladmin -u <username> -p create mydns"
+ einfo "# /usr/sbin/mydns --create-tables | mysql -u <user> -p mydns"
+ einfo
+ einfo "to create the tables in the MySQL-Database."
+ einfo "For more info see QUICKSTART.mysql."
+ elif [ "`use postgres`" ] ; then
+ einfo "# createdb mydns"
+ einfo "# /usr/sbin/mydns --create-tables | psql mydns"
+ einfo
+ einfo "to create the tables in the PostgreSQL-Database."
+ einfo "For more info see QUICKSTART.postgres."
+ fi
+ einfo
+
+}