summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2006-09-03 17:00:40 +0000
committerRoy Marples <uberlord@gentoo.org>2006-09-03 17:00:40 +0000
commitb448e15528107af45ccd9726a7b9683bba9ddcc9 (patch)
tree889a1bde42fcba395374b700aadd2832efbbed42
parentStable on x86. (diff)
downloadhistorical-b448e15528107af45ccd9726a7b9683bba9ddcc9.tar.gz
historical-b448e15528107af45ccd9726a7b9683bba9ddcc9.tar.bz2
historical-b448e15528107af45ccd9726a7b9683bba9ddcc9.zip
New version of Eternal Lands
Package-Manager: portage-2.1.1_rc1-r2
-rw-r--r--games-rpg/eternal-lands-data/ChangeLog8
-rw-r--r--games-rpg/eternal-lands-data/eternal-lands-data-1.3.2.ebuild64
-rw-r--r--games-rpg/eternal-lands-data/files/digest-eternal-lands-data-1.3.26
-rw-r--r--games-rpg/eternal-lands/ChangeLog8
-rw-r--r--games-rpg/eternal-lands/eternal-lands-1.3.2.ebuild137
-rw-r--r--games-rpg/eternal-lands/files/digest-eternal-lands-1.3.26
-rw-r--r--games-rpg/eternal-lands/files/eternal-lands-1.3.2-shader.patch14
7 files changed, 241 insertions, 2 deletions
diff --git a/games-rpg/eternal-lands-data/ChangeLog b/games-rpg/eternal-lands-data/ChangeLog
index 311ef3f2ccb1..9d2bf98db790 100644
--- a/games-rpg/eternal-lands-data/ChangeLog
+++ b/games-rpg/eternal-lands-data/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-rpg/eternal-lands-data
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/eternal-lands-data/ChangeLog,v 1.6 2006/07/04 22:43:21 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/eternal-lands-data/ChangeLog,v 1.7 2006/09/03 17:00:40 uberlord Exp $
+
+*eternal-lands-data-1.3.2 (03 Sep 2006)
+
+ 03 Sep 2006; Roy Marples <uberlord@gentoo.org>
+ +eternal-lands-data-1.3.2.ebuild:
+ Version bump, #146023 thanks to Daniel Nilsson.
*eternal-lands-data-1.3.0 (04 Jul 2006)
diff --git a/games-rpg/eternal-lands-data/eternal-lands-data-1.3.2.ebuild b/games-rpg/eternal-lands-data/eternal-lands-data-1.3.2.ebuild
new file mode 100644
index 000000000000..3456cb0739a5
--- /dev/null
+++ b/games-rpg/eternal-lands-data/eternal-lands-data-1.3.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/eternal-lands-data/eternal-lands-data-1.3.2.ebuild,v 1.1 2006/09/03 17:00:40 uberlord Exp $
+
+inherit games
+
+MUSIC_DATE="20060803"
+
+MY_PV="${PV//_/}"
+MY_PV="${MY_PV//./}"
+MY_PN="${PN%*-data}"
+DESCRIPTION="An online MMORPG written in C and SDL"
+HOMEPAGE="http://www.eternal-lands.com"
+SRC_URI="http://www.other-life.com/el/el_${MY_PV}_linux_full.zip
+ music? ( mirror://gentoo/el_music_full-${MUSIC_DATE}.zip )"
+# WARNING: The music file is held at
+# http://www.eternal-lands.com/page/music.php
+# We only mirror it so that it is versioned by the date we mirrored it
+# AND prefixed with el_ so as not cause any conflicts. Maybe oneday they will
+# version their music, maybe not.
+
+LICENSE="eternal_lands"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="music"
+
+DEPEND="app-arch/unzip
+ sys-apps/findutils"
+
+src_unpack() {
+ cd "${WORKDIR}"
+ unpack ${A}
+
+ # Remove CVS entries
+ find . -type d -name CVS -exec rm -rf {} \; 2>/dev/null
+
+ # Move our music files to the correct directory
+ use music && mv *.ogg *.pll music
+}
+
+src_install() {
+ cd "${WORKDIR}"
+
+ # These are provided by eternal-lands ebuild
+ rm license.txt
+
+ insopts -m 0660
+ insinto "${GAMES_DATADIR}/${MY_PN}"
+ doins -r 2dobjects 3dobjects actor_defs animations maps meshes music \
+ particles skeletons sound textures tiles languages \
+ *.lst 3dobjects.txt *.xml \
+ || die "doins failed"
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ # Ensure that the files are writable by the game group for auto
+ # updating.
+ chmod -R g+rw "${ROOT}/${GAMES_DATADIR}/${MY_PN}"
+
+ # Make sure new files stay in games group
+ find "${ROOT}/${GAMES_DATADIR}/${MY_PN}" -type d -exec chmod g+sx {} \;
+}
diff --git a/games-rpg/eternal-lands-data/files/digest-eternal-lands-data-1.3.2 b/games-rpg/eternal-lands-data/files/digest-eternal-lands-data-1.3.2
new file mode 100644
index 000000000000..e37fb9480403
--- /dev/null
+++ b/games-rpg/eternal-lands-data/files/digest-eternal-lands-data-1.3.2
@@ -0,0 +1,6 @@
+MD5 b51cc823c6ad68c061892712ff032116 el_132_linux_full.zip 41850856
+RMD160 939a4df7b9a1afcb32ebfd28da374eaa64318372 el_132_linux_full.zip 41850856
+SHA256 06eea5d27b0bc47243de4e760f6a5dcdbc3f991cc84f6452f8709065ddf53d36 el_132_linux_full.zip 41850856
+MD5 95220e0df0be0eb4f2b9646cc5d6b7e5 el_music_full-20060803.zip 65511882
+RMD160 63955f223a8472c9956a5b6912dec7db924f32ee el_music_full-20060803.zip 65511882
+SHA256 1ea4de25081034ac684aaebf127ab6ca8524ba5367532863d84d63837dd631ec el_music_full-20060803.zip 65511882
diff --git a/games-rpg/eternal-lands/ChangeLog b/games-rpg/eternal-lands/ChangeLog
index ffdbe24419a2..0b99c02258b8 100644
--- a/games-rpg/eternal-lands/ChangeLog
+++ b/games-rpg/eternal-lands/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-rpg/eternal-lands
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/eternal-lands/ChangeLog,v 1.24 2006/07/23 00:57:02 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/eternal-lands/ChangeLog,v 1.25 2006/09/03 17:00:40 uberlord Exp $
+
+*eternal-lands-1.3.2 (03 Sep 2006)
+
+ 03 Sep 2006; Roy Marples <uberlord@gentoo.org>
+ +files/eternal-lands-1.3.2-shader.patch, +eternal-lands-1.3.2.ebuild:
+ Version bump, #146023 thanks to Daniel Nilsson.
*eternal-lands-1.3.0-r2 (23 Jul 2006)
diff --git a/games-rpg/eternal-lands/eternal-lands-1.3.2.ebuild b/games-rpg/eternal-lands/eternal-lands-1.3.2.ebuild
new file mode 100644
index 000000000000..43f7fa93f2e6
--- /dev/null
+++ b/games-rpg/eternal-lands/eternal-lands-1.3.2.ebuild
@@ -0,0 +1,137 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/eternal-lands/eternal-lands-1.3.2.ebuild,v 1.1 2006/09/03 17:00:40 uberlord Exp $
+
+inherit eutils flag-o-matic games
+
+MY_PV="${PV//_/}"
+MY_PV="${MY_PV//./}"
+S="${WORKDIR}/elc"
+DESCRIPTION="An online MMORPG written in C and SDL"
+HOMEPAGE="http://www.eternal-lands.com"
+SRC_URI="mirror://gentoo/elc_${MY_PV}.tar.bz2
+ mirror://gentoo/eternal-lands.png"
+
+# NOTE: Sometimes you'll have to roll your own elc tarball from their CVS
+# tree as they don't always release one.
+# If they do then use this in SRC_URI instead
+# ftp://ftp.berlios.de/pub/elc/elc_${MY_PV}.tgz
+
+LICENSE="eternal_lands"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc"
+
+RDEPEND="
+ || ( (
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libXext )
+ virtual/x11 )
+ virtual/opengl
+ >=media-libs/libsdl-1.2.5
+ >=media-libs/sdl-net-1.2.5
+ ~media-libs/openal-0.0.8
+ media-libs/freealut
+ media-libs/libvorbis
+ >=dev-libs/libxml2-2.6.7
+ || ( =media-libs/cal3d-0.10.0 =media-libs/cal3d-0.11.0 )
+ >=media-libs/libpng-1.2.8
+ ~games-rpg/${PN}-data-${PV}"
+
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ sys-apps/findutils
+ doc? ( >=app-doc/doxygen-1.3.8
+ >=media-gfx/graphviz-1.10 )"
+
+src_unpack() {
+ OPTIONS="OPTIONS=-DDATA_DIR="\\\\\"${GAMES_DATADIR}/${PN}/\\\\\"""
+ S_CLIENT="${WORKDIR}/elc"
+ BROWSER="konqueror"
+
+ unpack ${A}
+ cd "${S}"
+
+ # Remove CVS entries
+ find . -type d -name CVS -exec rm -rf {} \; 2>/dev/null
+
+ # Create updated files with correct perms and allow dir creation
+ epatch "${FILESDIR}/${PN}-1.3.0-update-createdir.patch"
+
+ # Clean compile with all OpenAL versions
+ epatch "${FILESDIR}/${PN}-1.3.0-openal.patch"
+
+ # Allow shaders to actually work
+ epatch "${FILESDIR}/${P}-shader.patch"
+
+ # Build for amd64
+ use amd64 && OPTIONS="${OPTIONS} -DX86_64"
+
+ # Use these experimental options - I like them :)
+ OPTIONS="${OPTIONS} -DCUSTOM_LOOK -DNEW_WEATHER"
+
+ # Requires a patch to use correct dir
+ OPTIONS="${OPTIONS} -DUSE_SHADER"
+
+ # Add debugging options
+ if use debug ; then
+ OPTIONS="${OPTIONS} -DMEMORY_DEBUG"
+ append-flags -ggdb
+ fi
+
+ sed \
+ -e "s@CFLAGS=\$(PLATFORM) \$(CWARN) -O -ggdb -pipe@CFLAGS=${CFLAGS} @g"\
+ -e "s@CXXFLAGS=\$(PLATFORM) \$(CXXWARN) -O -ggdb -pipe@CXXFLAGS=${CXXFLAGS} @g"\
+ -e "s@OPTIONS=@${OPTIONS} @g" \
+ -e 's/lopenal/lopenal -l alut/' \
+ Makefile.linux > Makefile \
+ || die "sed failed"
+ sed -i \
+ -e 's/#browser/browser/g' \
+ -e "s/browser = mozilla/#browser = ${BROWSER}/g" \
+ -e "s@#data_dir = /usr/local/games/el/@#data_dir = ${GAMES_DATADIR}/${PN}/@g" \
+ el.ini || die "sed failed"
+
+ # Framebuffer support is way buggy - remove it
+ sed -i -e '/OPTIONS=/ s/-DUSE_FRAMEBUFFER//' Makefile || die "sed failed"
+}
+
+src_compile() {
+ emake || die "emake failed"
+ if use doc; then
+ emake docs || die "Failed to create documentation, try with USE=-doc"
+ mv ./docs/html/ ../client || die "Failed to move documentation directory"
+ fi
+}
+
+src_install() {
+ newgamesbin el.x86.linux.bin el || die "newgamesbin failed"
+ doicon "${DISTDIR}/eternal-lands.png"
+ make_desktop_entry el "Eternal Lands"
+
+ insopts -m 0660
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins *.ini *.txt commands.lst shader || die "doins failed"
+
+ if use doc ; then
+ dohtml -r client/*
+ fi
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ einfo "Auto Update is now enabled in Eternal Lands"
+ ewarn "If an update occurs then the client will suddenly exit"
+ einfo "Updates only happen when the game first loads"
+ einfo "Please don't report this behaviour as a bug"
+
+ # Ensure that the files are writable by the game group for auto
+ # updating.
+ chmod -R g+rw "${ROOT}/${GAMES_DATADIR}/${PN}"
+
+ # Make sure new files stay in games group
+ find "${ROOT}/${GAMES_DATADIR}/${PN}" -type d -exec chmod g+sx {} \;
+}
diff --git a/games-rpg/eternal-lands/files/digest-eternal-lands-1.3.2 b/games-rpg/eternal-lands/files/digest-eternal-lands-1.3.2
new file mode 100644
index 000000000000..de4826610abb
--- /dev/null
+++ b/games-rpg/eternal-lands/files/digest-eternal-lands-1.3.2
@@ -0,0 +1,6 @@
+MD5 39f027d682186b11382c8b6e5acfd2a0 elc_132.tar.bz2 837127
+RMD160 07ddc2c87054ec80139b76b16502b8308b286c4b elc_132.tar.bz2 837127
+SHA256 10f65992de9fe938ef93e2056dfd8dea9d351b48410fdda1f2bf2913af829982 elc_132.tar.bz2 837127
+MD5 059df8128b11b19a76b54e9907072f00 eternal-lands.png 9955
+RMD160 2f9c8acd96214577cf8b8027f0d20fb1fe7574ff eternal-lands.png 9955
+SHA256 dd7d45cd9948fe7875ebd0bfcd1925d9b34e7606a223faf61d37a6dd2cd433fb eternal-lands.png 9955
diff --git a/games-rpg/eternal-lands/files/eternal-lands-1.3.2-shader.patch b/games-rpg/eternal-lands/files/eternal-lands-1.3.2-shader.patch
new file mode 100644
index 000000000000..f24088cf6070
--- /dev/null
+++ b/games-rpg/eternal-lands/files/eternal-lands-1.3.2-shader.patch
@@ -0,0 +1,14 @@
+diff -u elc.orig/shader.c elc/shader.c
+--- elc.orig/shader.c 2005-09-28 09:12:58.000000000 +0100
++++ elc/shader.c 2006-09-03 11:54:12.140740264 +0100
+@@ -56,8 +56,8 @@
+ VertexShaderObject = ELglCreateShaderObjectARB(GL_VERTEX_SHADER_ARB);
+ FragmentShaderObject = ELglCreateShaderObjectARB(GL_FRAGMENT_SHADER_ARB);
+
+- load_shader(VertexShaderObject, "/home/daniel/Develop/el-cvs/elc/shader/normal_mapping_vs.gls");
+- load_shader(FragmentShaderObject, "/home/daniel/Develop/el-cvs/elc/shader/normal_mapping_fs.gls");
++ load_shader(VertexShaderObject, "shader/normal_mapping_vs.gls");
++ load_shader(FragmentShaderObject, "shader/normal_mapping_fs.gls");
+
+ ELglCompileShaderARB(VertexShaderObject);
+ ELglCompileShaderARB(FragmentShaderObject);