summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2004-05-02 13:13:34 +0000
committerJon Hood <squinky86@gentoo.org>2004-05-02 13:13:34 +0000
commitb432f288794486b2a0b9b36817a7d69ca57a27f0 (patch)
tree240b59584fd5aa46b15c09ff0fb0f4524a348bfc
parentmissing dep for io-stringy added (diff)
downloadhistorical-b432f288794486b2a0b9b36817a7d69ca57a27f0.tar.gz
historical-b432f288794486b2a0b9b36817a7d69ca57a27f0.tar.bz2
historical-b432f288794486b2a0b9b36817a7d69ca57a27f0.zip
add crypto support, closes #49670
-rw-r--r--net-p2p/Circle/ChangeLog5
-rw-r--r--net-p2p/Circle/Circle-0.39-r1.ebuild46
-rw-r--r--net-p2p/Circle/Manifest4
-rw-r--r--net-p2p/Circle/files/digest-Circle-0.39-r11
4 files changed, 54 insertions, 2 deletions
diff --git a/net-p2p/Circle/ChangeLog b/net-p2p/Circle/ChangeLog
index 116efde3ab89..b74c934e29b2 100644
--- a/net-p2p/Circle/ChangeLog
+++ b/net-p2p/Circle/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-p2p/Circle
# Copyright 1999-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/Circle/ChangeLog,v 1.2 2004/04/14 09:10:38 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/Circle/ChangeLog,v 1.3 2004/05/02 13:13:34 squinky86 Exp $
+
+ 02 May 2004; Jon Hood <squinky86@gentoo.org> Circle-0.39.ebuild:
+ add crypto support, closes #49670
14 Apr 2004; David Holm <dholm@gentoo.org> Circle-0.39.ebuild:
Added to ~ppc.
diff --git a/net-p2p/Circle/Circle-0.39-r1.ebuild b/net-p2p/Circle/Circle-0.39-r1.ebuild
new file mode 100644
index 000000000000..08979da1d495
--- /dev/null
+++ b/net-p2p/Circle/Circle-0.39-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/Circle/Circle-0.39-r1.ebuild,v 1.1 2004/05/02 13:13:34 squinky86 Exp $
+
+inherit python
+
+DESCRIPTION="The Circle messaging and file sharing system"
+HOMEPAGE="http://thecircle.org.au/"
+SRC_URI="http://thecircle.org.au/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE="oggvorbis gnome"
+
+DEPEND="virtual/python
+ >=dev-python/pygtk-1.99.14
+ >=gtk+-2
+ oggvorbis? ( dev-python/pyogg
+ dev-python/pyvorbis )
+ gnome? ( dev-python/gnome-python )"
+
+src_compile() {
+ einfo "Nothing to compile."
+}
+
+src_install() {
+ python_version
+ exeinto /usr/bin/
+ doexe circle
+ exeinto /usr/lib/apt/methods/
+ doexe cftp chttp
+ insinto /usr/lib/python${PYVER}/site-packages/circlelib/
+ doins circlelib/*.py*
+ doins circlelib/*.xpm
+ insinto /usr/lib/python${PYVER}/site-packages/circlelib/crypto/
+ doins circlelib/crypto/*
+ insinto /usr/share/pixmaps/
+ doins circle-icon.png
+ if [ `use gnome` ] ; then
+ insinto /usr/share/gnome/apps/Internet/
+ doins circle.desktop
+ fi
+ dohtml circlelib/*.html
+ dodoc NEWS PKG-INFO README
+}
diff --git a/net-p2p/Circle/Manifest b/net-p2p/Circle/Manifest
index 11cb221fd6e4..ce7cecd56c0a 100644
--- a/net-p2p/Circle/Manifest
+++ b/net-p2p/Circle/Manifest
@@ -1,4 +1,6 @@
-MD5 64faf54409c5ff6009f8572ed5acae83 ChangeLog 478
MD5 ced09043623f44a00856c8c4834cde72 Circle-0.39.ebuild 1075
+MD5 2e09287b731dd6fc2198462615bf6ad6 Circle-0.39-r1.ebuild 1173
+MD5 05a00bfc6f07198954624f86ddc84d49 ChangeLog 586
MD5 8abcb326775f027b2e13f23344036e34 metadata.xml 224
MD5 ba1dc7ed119049827966f37f58172fe3 files/digest-Circle-0.39 63
+MD5 ba1dc7ed119049827966f37f58172fe3 files/digest-Circle-0.39-r1 63
diff --git a/net-p2p/Circle/files/digest-Circle-0.39-r1 b/net-p2p/Circle/files/digest-Circle-0.39-r1
new file mode 100644
index 000000000000..ff31ea05f9b7
--- /dev/null
+++ b/net-p2p/Circle/files/digest-Circle-0.39-r1
@@ -0,0 +1 @@
+MD5 e2879eb59e801c5a01f0c33192d440e3 Circle-0.39.tar.gz 372862