summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2004-11-10 07:37:34 +0000
committerDoug Goldstein <cardoe@gentoo.org>2004-11-10 07:37:34 +0000
commitb23e18dffe300ce683703d77a6d4ed5f8ec61bda (patch)
tree62303272b97f7e23589165d1ed066ffd33b6cdb1
parentdeleted, cause conflicts with pam (diff)
downloadhistorical-b23e18dffe300ce683703d77a6d4ed5f8ec61bda.tar.gz
historical-b23e18dffe300ce683703d77a6d4ed5f8ec61bda.tar.bz2
historical-b23e18dffe300ce683703d77a6d4ed5f8ec61bda.zip
revision bump, remove troubled version
-rw-r--r--dev-tcltk/expect/ChangeLog10
-rw-r--r--dev-tcltk/expect/expect-5.42.1.ebuild85
-rw-r--r--dev-tcltk/expect/files/digest-expect-5.42.11
3 files changed, 95 insertions, 1 deletions
diff --git a/dev-tcltk/expect/ChangeLog b/dev-tcltk/expect/ChangeLog
index 4a7610939150..748c5cb64c83 100644
--- a/dev-tcltk/expect/ChangeLog
+++ b/dev-tcltk/expect/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-tcltk/expect
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/ChangeLog,v 1.27 2004/11/07 09:36:58 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/ChangeLog,v 1.28 2004/11/10 07:37:34 cardoe Exp $
+
+*expect-5.42.1 (10 Nov 2004)
+
+ 10 Nov 2004; Doug Goldstein <cardoe@gentoo.org> -expect-5.40.0-r2.ebuild,
+ +expect-5.42.1.ebuild:
+ -revision bump to 5.42.1
+ -delete 5.40.1-r2 since it caused conflicts with pam
+ -correct bad digest/fix repoman stuff
07 Nov 2004; Joshua Kinard <kumba@gentoo.org> expect-5.37.1-r2.ebuild:
Marked stable on mips.
diff --git a/dev-tcltk/expect/expect-5.42.1.ebuild b/dev-tcltk/expect/expect-5.42.1.ebuild
new file mode 100644
index 000000000000..31425cf1a1b9
--- /dev/null
+++ b/dev-tcltk/expect/expect-5.42.1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/expect-5.42.1.ebuild,v 1.1 2004/11/10 07:37:34 cardoe Exp $
+
+inherit gnuconfig
+
+DESCRIPTION="tool for automating interactive applications"
+HOMEPAGE="http://expect.nist.gov/"
+SRC_URI="http://expect.nist.gov/src/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="X doc"
+
+DEPEND=">=dev-lang/tcl-8.2
+ X? ( >=dev-lang/tk-8.2 )"
+
+NON_MICRO_V=${P%.[0-9]}
+S=${WORKDIR}/${NON_MICRO_V}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i 's#/usr/local/bin#/usr/bin#' expect.man
+ sed -i 's#/usr/local/bin#/usr/bin#' expectk.man
+ #stops any example scripts being installed by default
+ sed -i \
+ -e '/^install:/s/install-libraries //' \
+ -e 's/^SCRIPTS_MANPAGES = /_&/' Makefile.in
+ gnuconfig_update
+}
+
+src_compile() {
+ local myconf
+ local tclv
+ local tkv
+ # Find the version of tcl/tk that has headers installed.
+ # This will be the most recently merged, not necessarily the highest
+ # version number.
+ tclv=$(grep TCL_VER /usr/include/tcl.h | sed 's/^.*"\(.*\)".*/\1/')
+ #tkv isn't really needed, included for symmetry and the future
+ #tkv=$(grep TK_VER /usr/include/tk.h | sed 's/^.*"\(.*\)".*/\1/')
+
+ #configure needs to find the files tclConfig.sh and tclInt.h
+ myconf="--with-tcl=/usr/lib --with-tclinclude=/usr/lib/tcl${tclv}/include/generic"
+
+ if use X; then
+ #--with-x is enabled by default
+ #configure needs to find the file tkConfig.sh and tk.h
+ #tk.h is in /usr/lib so don't need to explicitly set --with-tkinclude
+ myconf="$myconf --with-tk=/usr/lib"
+ else
+ #configure knows that tk depends on X so just disable X
+ myconf="$myconf --without-x"
+ fi
+
+ econf $myconf --enable-shared || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ make install INSTALL_ROOT=${D} || die "make install failed"
+
+ dodoc ChangeLog FAQ HISTORY NEWS README
+
+ local static_lib="lib${NON_MICRO_V/-/}.a"
+ rm ${D}/usr/lib/${NON_MICRO_V/-/}/${static_lib}
+
+ #install examples if 'doc' is set
+ if use doc; then
+ docinto examples
+ local scripts=$(make -qp | \
+ sed -e 's/^SCRIPTS = //' -et -ed | head -n1)
+ exeinto /usr/share/doc/${PF}/examples
+ doexe ${scripts}
+ local scripts_manpages=$(make -qp | \
+ sed -e 's/^_SCRIPTS_MANPAGES = //' -et -ed | head -n1)
+ for m in ${scripts_manpages}; do
+ dodoc example/${m}.man
+ done
+ dodoc example/README
+ fi
+
+}
diff --git a/dev-tcltk/expect/files/digest-expect-5.42.1 b/dev-tcltk/expect/files/digest-expect-5.42.1
new file mode 100644
index 000000000000..283afd216fdd
--- /dev/null
+++ b/dev-tcltk/expect/files/digest-expect-5.42.1
@@ -0,0 +1 @@
+MD5 fea346fac6aaf74b0851f2441f478571 expect-5.42.1.tar.gz 524882