summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2010-04-29 09:31:02 +0000
committerPeter Volkov <pva@gentoo.org>2010-04-29 09:31:02 +0000
commita97a3245528bac55e8bcc8cc6d53c52e5e57bea4 (patch)
treedeb994b28834b4e35357ed5150413a6e3e2b0011
parentAdd XTABLES_ADDONS description (discussed in -dev on 18.01.2010). (diff)
downloadhistorical-a97a3245528bac55e8bcc8cc6d53c52e5e57bea4.tar.gz
historical-a97a3245528bac55e8bcc8cc6d53c52e5e57bea4.tar.bz2
historical-a97a3245528bac55e8bcc8cc6d53c52e5e57bea4.zip
Initial import, ebuild by me. Fixes bug #250407, thank Nathan McSween for report and others who tested this package.
Package-Manager: portage-2.1.8.3/cvs/Linux x86_64
-rw-r--r--net-firewall/xtables-addons/ChangeLog11
-rw-r--r--net-firewall/xtables-addons/Manifest4
-rw-r--r--net-firewall/xtables-addons/metadata.xml18
-rw-r--r--net-firewall/xtables-addons/xtables-addons-1.25.ebuild137
4 files changed, 170 insertions, 0 deletions
diff --git a/net-firewall/xtables-addons/ChangeLog b/net-firewall/xtables-addons/ChangeLog
new file mode 100644
index 000000000000..d58221b30d69
--- /dev/null
+++ b/net-firewall/xtables-addons/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for net-firewall/xtables-addons
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/xtables-addons/ChangeLog,v 1.1 2010/04/29 09:31:02 pva Exp $
+
+*xtables-addons-1.25 (29 Apr 2010)
+
+ 29 Apr 2010; Peter Volkov <pva@gentoo.org> +xtables-addons-1.25.ebuild,
+ +metadata.xml:
+ Initial import, ebuild by me. Fixes bug #250407, thank Nathan McSween for
+ report and others who tested this package.
+
diff --git a/net-firewall/xtables-addons/Manifest b/net-firewall/xtables-addons/Manifest
new file mode 100644
index 000000000000..d6de07f7ade7
--- /dev/null
+++ b/net-firewall/xtables-addons/Manifest
@@ -0,0 +1,4 @@
+DIST xtables-addons-1.25.tar.bz2 366332 RMD160 6abcf7d353c34729430cf783210a3f83fc361c99 SHA1 f39143144dcdddf337d57bdd46f8909e434b2675 SHA256 341aaec8204c8cc0351c35532708d852be1e96d5f1586617539e1c57577c8939
+EBUILD xtables-addons-1.25.ebuild 3995 RMD160 cefd9fedb5af2479e71b81fd26b0aa0e11ebd2a2 SHA1 77c79f5eaddf82dd6bf7511d9772f152d1657e29 SHA256 3d2244bfaf338e14a6ee187553a3f09376e84ec75f94dd23033ea88bdebbc098
+MISC ChangeLog 473 RMD160 099e61726f89d874115048e8d1a1695fbad18c45 SHA1 0255516f0b8994d3d7db170cb89a04afd4158aa4 SHA256 054a9f2626fd0c188a99fb1820e929b333320062db351cc9d13595c8c1ddf663
+MISC metadata.xml 683 RMD160 27b60860ee7f57c4345693fcd3be8d338d23bacd SHA1 1f3aac7a15cedd8261c4f62ffa90876cc76c6507 SHA256 64cb53d9fda3166dcaa6fe5c1656bb0cf1a89701ae3c451f68f4d365e1e872ad
diff --git a/net-firewall/xtables-addons/metadata.xml b/net-firewall/xtables-addons/metadata.xml
new file mode 100644
index 000000000000..1fe6ec70cbee
--- /dev/null
+++ b/net-firewall/xtables-addons/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>pva@gentoo.org</email>
+ <name>Peter Volkov</name>
+</maintainer>
+<longdescription>
+Xtables-addons is the successor to patch-o-matic(-ng). Likewise, it contains
+extensions that were not, or are not yet, accepted in the main kernel/iptables
+packages.
+
+Xtables-addons is different from patch-o-matic in that you do not have to patch
+or recompile the kernel, sometimes recompiling iptables is also not needed. But
+please see the INSTALL file for the minimum requirements of this package.
+</longdescription>
+</pkgmetadata>
diff --git a/net-firewall/xtables-addons/xtables-addons-1.25.ebuild b/net-firewall/xtables-addons/xtables-addons-1.25.ebuild
new file mode 100644
index 000000000000..9e27e4dc16dd
--- /dev/null
+++ b/net-firewall/xtables-addons/xtables-addons-1.25.ebuild
@@ -0,0 +1,137 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/xtables-addons/xtables-addons-1.25.ebuild,v 1.1 2010/04/29 09:31:02 pva Exp $
+
+EAPI="2"
+
+inherit eutils linux-mod
+
+DESCRIPTION="extensions not yet accepted in the main kernel/iptables (patch-o-matic(-ng) successor)"
+HOMEPAGE="http://xtables-addons.sourceforge.net/"
+SRC_URI="mirror://sourceforge/xtables-addons/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="modules"
+
+MODULES="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark echo dhcpmac delude chaos account"
+
+for mod in ${MODULES}; do
+ IUSE="${IUSE} xtables_addons_${mod}"
+done
+
+RDEPEND="virtual/modutils
+ >=net-firewall/iptables-1.4.3
+ >virtual/linux-sources-2.6.22
+ xtables_addons_ipset? ( !net-firewall/ipset )"
+
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ if use modules; then
+ get_version
+ check_modules_supported
+ # CONFIG_IP_NF_CONNTRACK{,_MARK} doesn't exist in >virtual/linux-sources-2.6.22
+ CONFIG_CHECK="NF_CONNTRACK NF_CONNTRACK_MARK"
+ linux-mod_pkg_setup
+
+ if ! linux_chkconfig_present IPV6; then
+ SKIP_IPV6_MODULES="ip6table_rawpost"
+ fi
+ fi
+}
+
+# Helper for maintainer: cheks if all possible MODULES are listed.
+XA_qa_check() {
+ local all_modules
+ all_modules=$(sed -n '/^build_/{s/build_\(.*\)=.*/\L\1/;G;s/\n/ /;s/ $//;h}; ${x;p}' "${S}/mconfig")
+ if [[ ${all_modules} != ${MODULES} ]]; then
+ ewarn "QA: Modules in mconfig differ from \$MODULES in ebuild."
+ ewarn "Please, update MODULES in ebuild."
+ ewarn "'${all_modules}'"
+ fi
+}
+
+# Is there any use flag set?
+XA_has_something_to_build() {
+ local mod
+ for mod in ${MODULES}; do
+ use xtables_addons_${mod} && return
+ done
+
+ eerror "All modules are disabled. What do you want me to build?"
+ eerror "Please, set XTABLES_ADDONS to any combination of"
+ eerror "${MODULES}"
+ die "All modules are disabled."
+}
+
+# Parse Kbuid files and generates list of sources
+XA_get_module_name() {
+ [[ $# != 1 ]] && die "XA_get_sources_for_mod: needs exactly one argument."
+ local mod objdir build_mod sources_list
+ mod=${1}
+ objdir=${S}/extensions
+ build_mod=$(sed -n "s/\(build_${mod}\)=.*/\1/Ip" "${S}/mconfig")
+ sources_list=$(sed -n "/^obj-[$][{]${build_mod}[}]/\
+ {s:obj-[^+]\+ [+]=[[:space:]]*::;s:[.]o::g;p}" \
+ "${objdir}/Kbuild")
+
+ if [[ -d ${S}/extensions/${sources_list} ]]; then
+ objdir=${S}/extensions/${sources_list}
+ sources_list=$(sed -n "/^obj-m/\
+ {s:obj-[^+]\+ [+]=[[:space:]]*::;s:[.]o::g;p}" \
+ "${objdir}/Kbuild")
+ fi
+ for mod_src in ${sources_list}; do
+ has ${mod_src} ${SKIP_IPV6_MODULES} || \
+ echo " ${mod_src}(xtables_addons:${S}/extensions:${objdir})"
+ done
+}
+
+src_prepare() {
+ XA_qa_check
+ XA_has_something_to_build
+
+ local mod module_name
+ if use modules; then
+ MODULE_NAMES="compat_xtables(xtables_addons:${S}/extensions:)"
+ fi
+ for mod in ${MODULES}; do
+ if use xtables_addons_${mod}; then
+ sed "s/\(build_${mod}=\).*/\1m/I" -i mconfig || die
+ if use modules; then
+ for module_name in $(XA_get_module_name ${mod}); do
+ MODULE_NAMES+=" ${module_name}"
+ done
+ fi
+ else
+ sed "s/\(build_${mod}=\).*/\1n/I" -i mconfig || die
+ fi
+ done
+
+ sed -e 's/depmod -a/true/' -i Makefile.{in,am} || die
+ sed -e '/^all-local:/{s: modules::}' \
+ -e '/^install-exec-local:/{s: modules_install::}' \
+ -i extensions/Makefile.{in,am} || die
+}
+
+src_configure() {
+ unset ARCH # .. or it'll look for /arch/amd64/Makefile in linux sources
+ export KBUILD_EXTMOD=${S} # Avoid build in /usr/src/linux #250407
+ econf --prefix=/ \
+ --libexecdir=/lib/ \
+ --with-kbuild="${KV_DIR}"
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" CC="$(tc-getCC)" || die
+ use modules && BUILD_TARGETS="modules" linux-mod_src_compile
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ use modules && linux-mod_src_install
+ dodoc README doc/* || die
+ find "${D}" -type f -name '*.la' -exec rm -rf '{}' '+'
+}