summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-08-18 04:26:28 +0000
committerMike Frysinger <vapier@gentoo.org>2005-08-18 04:26:28 +0000
commita4e1d1c7b3ff97e9b5d75ced5ceea70f0476fe87 (patch)
treedf961fa010159da86d729aa771088000b3df30b5
parentStablized 1.0.5 and added testing keyword to 1.9.13-r1 for SPARC. (diff)
downloadhistorical-a4e1d1c7b3ff97e9b5d75ced5ceea70f0476fe87.tar.gz
historical-a4e1d1c7b3ff97e9b5d75ced5ceea70f0476fe87.tar.bz2
historical-a4e1d1c7b3ff97e9b5d75ced5ceea70f0476fe87.zip
Version bump #93488 by Yuri Vasilevski.
Package-Manager: portage-2.0.51.22-r2
-rw-r--r--app-emulation/vm-arm/ChangeLog7
-rw-r--r--app-emulation/vm-arm/Manifest14
-rw-r--r--app-emulation/vm-arm/files/digest-vm-arm-1.0.21
-rw-r--r--app-emulation/vm-arm/vm-arm-1.0.2.ebuild54
4 files changed, 74 insertions, 2 deletions
diff --git a/app-emulation/vm-arm/ChangeLog b/app-emulation/vm-arm/ChangeLog
index 651777fb59ea..045cd1f9213b 100644
--- a/app-emulation/vm-arm/ChangeLog
+++ b/app-emulation/vm-arm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/vm-arm
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vm-arm/ChangeLog,v 1.1 2005/05/25 04:27:35 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vm-arm/ChangeLog,v 1.2 2005/08/18 04:26:28 vapier Exp $
+
+*vm-arm-1.0.2 (18 Aug 2005)
+
+ 18 Aug 2005; Mike Frysinger <vapier@gentoo.org> +vm-arm-1.0.2.ebuild:
+ Version bump #93488 by Yuri Vasilevski.
*vm-arm-1.0.1 (25 May 2005)
diff --git a/app-emulation/vm-arm/Manifest b/app-emulation/vm-arm/Manifest
index 86c95d61cc40..403afda165f5 100644
--- a/app-emulation/vm-arm/Manifest
+++ b/app-emulation/vm-arm/Manifest
@@ -1,4 +1,16 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 c60e6bc950c02ef18bd30fe4acd0b04c vm-arm-1.0.1.ebuild 1521
MD5 48834ccc5ffa5b7734f8cac702fcd38a metadata.xml 156
-MD5 296501e5bca3c0be5d402a30fd665ebb ChangeLog 357
+MD5 b07790d505e14328653bad5051a61360 vm-arm-1.0.2.ebuild 1527
+MD5 77b958a5995af13fd5d3361b9d6e6c93 ChangeLog 501
+MD5 6b1b0646c2ab6a711d2cc263e7e0af47 files/digest-vm-arm-1.0.2 81
MD5 37ea286f6d3fc98b3eae3bfd80d2f092 files/digest-vm-arm-1.0.1 80
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2 (GNU/Linux)
+
+iD8DBQFDBA4YgIKl8Uu19MoRAvisAJ9YkT3AinhU/VeNZBDXZt2ZyQe0/QCeIdrg
+8ZPEb/AcYQ5ltW2LKUjdf3E=
+=lk5b
+-----END PGP SIGNATURE-----
diff --git a/app-emulation/vm-arm/files/digest-vm-arm-1.0.2 b/app-emulation/vm-arm/files/digest-vm-arm-1.0.2
new file mode 100644
index 000000000000..761497563254
--- /dev/null
+++ b/app-emulation/vm-arm/files/digest-vm-arm-1.0.2
@@ -0,0 +1 @@
+MD5 c1cc91a9546b12cf4a0cd8fb481b39db vm-arm-se-1.0.2-70.suse9_2.i386.rpm 2611396
diff --git a/app-emulation/vm-arm/vm-arm-1.0.2.ebuild b/app-emulation/vm-arm/vm-arm-1.0.2.ebuild
new file mode 100644
index 000000000000..a52f765e8000
--- /dev/null
+++ b/app-emulation/vm-arm/vm-arm-1.0.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vm-arm/vm-arm-1.0.2.ebuild,v 1.1 2005/08/18 04:26:28 vapier Exp $
+
+inherit eutils rpm
+
+# - Debian version is very old
+# - Redhat/Fedora ones link against funky ssl
+# - SuSe or MDK rpm's are the only ones that will really work
+RPM_VER="70.suse9_2"
+DESCRIPTION="highly optimized and accurate simulation of the ARM architecture"
+HOMEPAGE="http://www.virtera.com/"
+SRC_URI="vm-arm-se-${PV}-${RPM_VER}.i386.rpm"
+
+LICENSE="VIRTERA"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+RESTRICT="fetch nostrip"
+
+DEPEND="=dev-libs/openssl-0.9.7*
+ =x11-libs/wxGTK-2.4*"
+
+S=${WORKDIR}
+
+pkg_setup() {
+ if ! built_with_use x11-libs/wxGTK wxgtk1 ; then
+ eerror "Please emerge x11-libs/wxGTK-2.4 with wxgtk1 in USE flags."
+ die "GTK1 support in 11-libs/wxGTK-2.4 needed to run ${P}."
+ fi
+}
+
+pkg_nofetch() {
+ einfo "You need to perform the following steps to install this package:"
+ einfo " - Sign up at ${HOMEPAGE}"
+ einfo " - Check your email and visit the download location"
+ einfo " - Download ${A} and place it in ${DISTDIR}"
+ einfo " - emerge this package"
+ einfo " - Put your license in ~/.virtera/"
+}
+
+src_install() {
+ mv opt "${D}"/ || die
+ dodir /opt/bin
+ cd "${D}"
+ for x in opt/virtera/vm-arm-se-${PV}/bin/i686/* ; do
+ dosym /${x} /opt/bin/${x##*/}
+ done
+ find "${D}" -type d -exec chmod a+rx {} \;
+}
+
+pkg_postinst() {
+ einfo "Please remember to put your license in ~/.virtera/"
+}