summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Brinkmann <luckyduck@gentoo.org>2005-05-21 16:50:17 +0000
committerJan Brinkmann <luckyduck@gentoo.org>2005-05-21 16:50:17 +0000
commita03e77b2c4c92586df12a2d0112341ee873d6973 (patch)
tree42f19328d5ecab163bbba2640ace7d44efd18ba6
parent~amd64 (diff)
downloadhistorical-a03e77b2c4c92586df12a2d0112341ee873d6973.tar.gz
historical-a03e77b2c4c92586df12a2d0112341ee873d6973.tar.bz2
historical-a03e77b2c4c92586df12a2d0112341ee873d6973.zip
new revision, ebuild cleanup. also introduces support for cairo, controlled by the respective useflag. thanks to Robert Schuster <theBohemian@gmx.net>. fixes #93278.
Package-Manager: portage-2.0.51.22-r1
-rw-r--r--dev-java/gnu-classpath/ChangeLog10
-rw-r--r--dev-java/gnu-classpath/Manifest10
-rw-r--r--dev-java/gnu-classpath/files/digest-gnu-classpath-0.15-r11
-rw-r--r--dev-java/gnu-classpath/gnu-classpath-0.15-r1.ebuild56
4 files changed, 72 insertions, 5 deletions
diff --git a/dev-java/gnu-classpath/ChangeLog b/dev-java/gnu-classpath/ChangeLog
index adfee8b784d6..20fc373b8a2c 100644
--- a/dev-java/gnu-classpath/ChangeLog
+++ b/dev-java/gnu-classpath/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-java/gnu-classpath
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/gnu-classpath/ChangeLog,v 1.30 2005/05/12 15:41:56 luckyduck Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/gnu-classpath/ChangeLog,v 1.31 2005/05/21 16:50:17 luckyduck Exp $
+
+*gnu-classpath-0.15-r1 (21 May 2005)
+
+ 21 May 2005; Jan Brinkmann <luckyduck@gentoo.org>
+ +gnu-classpath-0.15-r1.ebuild:
+ new revision, ebuild cleanup. also introduces support for cairo, controlled
+ by the respective useflag. thanks to Robert Schuster <theBohemian@gmx.net>.
+ fixes #93278.
*gnu-classpath-0.15 (12 May 2005)
diff --git a/dev-java/gnu-classpath/Manifest b/dev-java/gnu-classpath/Manifest
index c1061dbe4cb0..8175de1871aa 100644
--- a/dev-java/gnu-classpath/Manifest
+++ b/dev-java/gnu-classpath/Manifest
@@ -1,18 +1,20 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
+MD5 13fb5597ef24b6b3c85d32659a8fc7bc gnu-classpath-0.15-r1.ebuild 1664
MD5 a54bef82be228fcad143d0f549eaa6aa gnu-classpath-0.13.ebuild 1279
MD5 9275d3f3eaf2c62c635e4aacf4d0e834 gnu-classpath-0.15.ebuild 1282
MD5 1b1e24effad7122902de9ccd4f395d90 gnu-classpath-0.14.ebuild 1282
-MD5 080809b047542bcb9e86962dd1fa98a9 ChangeLog 4058
+MD5 5cffdcee6b74bb973fdb522631b65950 ChangeLog 4354
MD5 a6ec7d7724fbd068ffb39b5be56134ed metadata.xml 157
+MD5 2690159fdd3e679de05cd6daed73f4da files/digest-gnu-classpath-0.15-r1 67
MD5 44f281c7cf47c19fe1359a1ebda60db5 files/digest-gnu-classpath-0.13 67
MD5 9b2c43cfbb9e8d325407a9ddd2068a5d files/digest-gnu-classpath-0.14 67
MD5 2690159fdd3e679de05cd6daed73f4da files/digest-gnu-classpath-0.15 67
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.0 (GNU/Linux)
-iD8DBQFCg3lY06ebR+OMO78RAvt8AJ9KbjaiFp54vx3Ak03rhEqSs0GwYwCgkxAF
-ItH3C122pKcv0aaKP89Pidc=
-=2mer
+iD8DBQFCj2bo06ebR+OMO78RAi6uAKCNyiOPs9BmE2jVbOXdbWM455oA7QCfQnGh
+wPBIDYP2TJoyZEwLpgPPDBo=
+=7vHT
-----END PGP SIGNATURE-----
diff --git a/dev-java/gnu-classpath/files/digest-gnu-classpath-0.15-r1 b/dev-java/gnu-classpath/files/digest-gnu-classpath-0.15-r1
new file mode 100644
index 000000000000..8b1e07082e87
--- /dev/null
+++ b/dev-java/gnu-classpath/files/digest-gnu-classpath-0.15-r1
@@ -0,0 +1 @@
+MD5 036c23aec7cb53a43b7b9dc63a92fbbe classpath-0.15.tar.gz 5564571
diff --git a/dev-java/gnu-classpath/gnu-classpath-0.15-r1.ebuild b/dev-java/gnu-classpath/gnu-classpath-0.15-r1.ebuild
new file mode 100644
index 000000000000..04dc0acf7cd7
--- /dev/null
+++ b/dev-java/gnu-classpath/gnu-classpath-0.15-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/gnu-classpath/gnu-classpath-0.15-r1.ebuild,v 1.1 2005/05/21 16:50:17 luckyduck Exp $
+
+DESCRIPTION="Free core class libraries for use with virtual machines and compilers for the Java programming language"
+SRC_URI="ftp://ftp.gnu.org/gnu/classpath/classpath-${PV}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/classpath"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc ~amd64"
+IUSE="cairo jikes gtk xml2"
+
+DEPEND="app-arch/zip
+ dev-java/jikes"
+RDEPEND="cairo? ( >=x11-libs/cairo-0.3 )
+ gtk? (
+ media-libs/gdk-pixbuf
+ >=x11-libs/gtk+-2
+ >=media-libs/libart_lgpl-2.1
+ )
+ xml2? (
+ >=dev-libs/libxml2-2.6.8
+ >=dev-libs/libxslt-1.1.11
+ )"
+
+S=${WORKDIR}/classpath-${PV}
+
+src_compile() {
+ # Note: This is written in a way to easily support GCJ and other compilers
+ # at a later point. Currently Gentoo uses mainly GCJ 3.3 (from the
+ # corresponding GCC) which cannot compile GNU Classpath correctly.
+ # Another possibility would be ECJ (from Eclipse) which is not yet in
+ # portage.
+ local compiler="--with-jikes"
+
+ econf \
+ ${compiler} \
+ $(use_enable cairo gtk-cairo) \
+ $(use_enable gtk gtk-peer) \
+ $(use_enable xml2 xmlj) \
+ --enable-jni \
+ || die "configure failed"
+
+ emake || die "make failed"
+}
+
+src_install () {
+ einstall || die "make install failed"
+
+ if use cairo; then
+ einfo "GNU Classpath was compiled with preliminary cairo support."
+ einfo "To use that functionality set the system property"
+ einfo "gnu.java.awt.peer.gtk.Graphics to Graphics2D at runtime."
+ fi
+}