summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-03-29 00:13:57 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-03-29 00:13:57 +0000
commit9c6051ac1c8d5bfc1442d9e66bdc2acc5c0cbe1a (patch)
tree7d05138e3b9e91a0458ff7569e83a9f7c55d6f74
parentcleaned up ebuild (diff)
downloadhistorical-9c6051ac1c8d5bfc1442d9e66bdc2acc5c0cbe1a.tar.gz
historical-9c6051ac1c8d5bfc1442d9e66bdc2acc5c0cbe1a.tar.bz2
historical-9c6051ac1c8d5bfc1442d9e66bdc2acc5c0cbe1a.zip
cleaned up ebuild
-rw-r--r--app-office/dia/dia-0.88.1-r1.ebuild26
-rw-r--r--app-office/gaby/gaby-2.0.2-r1.ebuild18
-rw-r--r--app-office/gnumeric/gnumeric-1.0.5.ebuild6
-rw-r--r--app-office/mrproject/mrproject-0.5.1.ebuild41
4 files changed, 45 insertions, 46 deletions
diff --git a/app-office/dia/dia-0.88.1-r1.ebuild b/app-office/dia/dia-0.88.1-r1.ebuild
index c02ebfa621c1..1c595102c242 100644
--- a/app-office/dia/dia-0.88.1-r1.ebuild
+++ b/app-office/dia/dia-0.88.1-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-office/dia/dia-0.88.1-r1.ebuild,v 1.3 2002/03/08 05:29:51 agenkin Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/dia/dia-0.88.1-r1.ebuild,v 1.4 2002/03/29 00:09:51 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Diagram Creation Program"
@@ -9,9 +9,9 @@ SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${P}.tar.gz"
HOMEPAGE="http://www.gnome.org/gnome-office/dia.shtml"
RDEPEND=">=dev-libs/libxml-1.8.15
- >=media-libs/gdk-pixbuf-0.16.0-r4
- >=dev-libs/popt-1.5
- bonobo? ( >=gnome-base/bonobo-1.0.9-r1 )"
+ >=media-libs/gdk-pixbuf-0.16.0-r4
+ >=dev-libs/popt-1.5
+ bonobo? ( >=gnome-base/bonobo-1.0.9-r1 )"
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )"
@@ -21,20 +21,20 @@ src_compile() {
local myconf
if [ "`use gnome`" ] ; then
- myconf="--enable-gnome"
+ myconf="--enable-gnome"
fi
if [ "`use bonobo`" ]; then
- myconf="--enable-gnome --enable-bonobo"
- fi
+ myconf="--enable-gnome --enable-bonobo"
+ fi
-# if [ "`use python`" ] ; then
-# myconf="$myconf --with-python"
-# fi
+# if [ "`use python`" ] ; then
+# myconf="${myconf} --with-python"
+# fi
if [ -z "`use nls`" ] ; then
- myconf="$myconf --disable-nls"
- fi
+ myconf="${myconf} --disable-nls"
+ fi
./configure --host=${CHOST} \
--prefix=/usr \
diff --git a/app-office/gaby/gaby-2.0.2-r1.ebuild b/app-office/gaby/gaby-2.0.2-r1.ebuild
index d4d115c6a97c..5c82f4e323d0 100644
--- a/app-office/gaby/gaby-2.0.2-r1.ebuild
+++ b/app-office/gaby/gaby-2.0.2-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Craig Joly <joly@ee.ualberta.ca>
-# $Header: /var/cvsroot/gentoo-x86/app-office/gaby/gaby-2.0.2-r1.ebuild,v 1.1 2001/10/06 12:36:36 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/gaby/gaby-2.0.2-r1.ebuild,v 1.2 2002/03/29 00:11:42 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="A small personal databases manager for Linux"
@@ -36,7 +36,7 @@ src_compile() {
if [ -z "`use nls`" ]
then
- myopts="$myopts --disable-nls"
+ myopts="${myopts} --disable-nls"
fi
cp ${FILESDIR}/Makefile.in intl/Makefile.in
@@ -45,21 +45,24 @@ src_compile() {
sed -e "7293 c\ if test -f /usr/include/pygtk/pygtk.h; then" \
< configure.orig > configure
- try ./configure --host=${CHOST} ${myopts} --prefix=/usr
+ ./configure \
+ --host=${CHOST} \
+ ${myopts} \
+ --prefix=/usr || die
cd src
cp Makefile Makefile.orig
sed -e "s:install-exec-local::" \
- -e "s:^\::gentoo change\::" Makefile.orig > Makefile
+ -e "s:^\::gentoo change\::" Makefile.orig > Makefile
cd ..
- try emake
+ emake || die
}
src_install () {
- try make DESTDIR=${D} install
+ make DESTDIR=${D} install || die
dosym gaby ${prefix}/bin/gbc
dosym gaby ${prefix}/bin/gcd
@@ -75,4 +78,3 @@ src_install () {
doins gnome-gaby-builder.png gnome-gaby.png
}
-
diff --git a/app-office/gnumeric/gnumeric-1.0.5.ebuild b/app-office/gnumeric/gnumeric-1.0.5.ebuild
index 0897a9a3b79d..4b60d39d81ca 100644
--- a/app-office/gnumeric/gnumeric-1.0.5.ebuild
+++ b/app-office/gnumeric/gnumeric-1.0.5.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: Martin Schlemmer <azarah@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/gnumeric-1.0.5.ebuild,v 1.1 2002/03/17 22:21:44 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/gnumeric-1.0.5.ebuild,v 1.2 2002/03/29 00:12:43 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Gnumeric, the GNOME Spreadsheet"
@@ -100,8 +100,8 @@ src_compile() {
src_install() {
make prefix=${D}/usr \
- sysconfdir=${D}/etc \
- install || die
+ sysconfdir=${D}/etc \
+ install || die
dodoc AUTHORS COPYING *ChangeLog HACKING NEWS README TODO
}
diff --git a/app-office/mrproject/mrproject-0.5.1.ebuild b/app-office/mrproject/mrproject-0.5.1.ebuild
index 13660023aff8..6621c08dd14d 100644
--- a/app-office/mrproject/mrproject-0.5.1.ebuild
+++ b/app-office/mrproject/mrproject-0.5.1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Mikael Hallendal <micke@hallendal.net>
-# $Header: /var/cvsroot/gentoo-x86/app-office/mrproject/mrproject-0.5.1.ebuild,v 1.1 2002/01/23 17:46:30 hallski Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/mrproject/mrproject-0.5.1.ebuild,v 1.2 2002/03/29 00:13:57 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Project management application for GNOME"
@@ -9,15 +9,15 @@ SRC_URI="ftp://ftp.codefactory.se/pub/software/mrproject/source/${P}.tar.gz"
HOMEPAGE="http://mrproject.codefactory.se/"
RDEPEND=">=media-libs/gdk-pixbuf-0.11.0-r1
- >=gnome-base/ORBit-0.5.10-r1
- >=gnome-extra/gal-0.18.1
- >=gnome-base/bonobo-1.0.17
- >=gnome-base/libglade-0.17-r1
- >=dev-libs/libxml-1.8.15
- >=gnome-base/gconf-1.0.7
- >=gnome-base/gnome-vfs-1.0.3
- >=gnome-base/oaf-0.6.6-r1
- >=gnome-base/gnome-print-0.34"
+ >=gnome-base/ORBit-0.5.10-r1
+ >=gnome-extra/gal-0.18.1
+ >=gnome-base/bonobo-1.0.17
+ >=gnome-base/libglade-0.17-r1
+ >=dev-libs/libxml-1.8.15
+ >=gnome-base/gconf-1.0.7
+ >=gnome-base/gnome-vfs-1.0.3
+ >=gnome-base/oaf-0.6.6-r1
+ >=gnome-base/gnome-print-0.34"
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )
@@ -31,23 +31,20 @@ src_compile() {
fi
./configure --host=${CHOST} \
- --prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var/lib \
- --disable-more-warnings \
- --without-python $myconf || die
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --disable-more-warnings \
+ --without-python $myconf || die
emake || die
}
src_install () {
make prefix=${D}/usr \
- sysconfdir=${D}/etc \
- localstatedir=${D}/var/lib \
- install || die
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/lib \
+ install || die
dodoc AUTHORS COPYING ChangeLog README NEWS TODO
}
-
-
-