summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-09-14 04:16:04 +0000
committerTim Harder <radhermit@gentoo.org>2012-09-14 04:16:04 +0000
commit91fe802db596ebbf27911a7914b76bc12bc4230e (patch)
tree55994fbb2bc3b1f2a26f014bb19ad6d9858e685d
parentRemove old. (diff)
downloadhistorical-91fe802db596ebbf27911a7914b76bc12bc4230e.tar.gz
historical-91fe802db596ebbf27911a7914b76bc12bc4230e.tar.bz2
historical-91fe802db596ebbf27911a7914b76bc12bc4230e.zip
Version bump.
Package-Manager: portage-2.2.0_alpha128/cvs/Linux x86_64
-rw-r--r--dev-embedded/msp430-binutils/ChangeLog8
-rw-r--r--dev-embedded/msp430-binutils/msp430-binutils-2.22_p20120911.ebuild25
-rw-r--r--dev-embedded/msp430-gcc/ChangeLog8
-rw-r--r--dev-embedded/msp430-gcc/msp430-gcc-4.7.0_p20120911.ebuild28
4 files changed, 67 insertions, 2 deletions
diff --git a/dev-embedded/msp430-binutils/ChangeLog b/dev-embedded/msp430-binutils/ChangeLog
index 5d62c5a6059e..b5ef950c2eab 100644
--- a/dev-embedded/msp430-binutils/ChangeLog
+++ b/dev-embedded/msp430-binutils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-embedded/msp430-binutils
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/msp430-binutils/ChangeLog,v 1.12 2012/09/02 20:38:19 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/msp430-binutils/ChangeLog,v 1.13 2012/09/14 04:12:31 radhermit Exp $
+
+*msp430-binutils-2.22_p20120911 (14 Sep 2012)
+
+ 14 Sep 2012; Tim Harder <radhermit@gentoo.org>
+ +msp430-binutils-2.22_p20120911.ebuild:
+ Version bump.
02 Sep 2012; Tim Harder <radhermit@gentoo.org>
msp430-binutils-2.22_p20120716.ebuild:
diff --git a/dev-embedded/msp430-binutils/msp430-binutils-2.22_p20120911.ebuild b/dev-embedded/msp430-binutils/msp430-binutils-2.22_p20120911.ebuild
new file mode 100644
index 000000000000..a68f65ce0368
--- /dev/null
+++ b/dev-embedded/msp430-binutils/msp430-binutils-2.22_p20120911.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/msp430-binutils/msp430-binutils-2.22_p20120911.ebuild,v 1.1 2012/09/14 04:12:31 radhermit Exp $
+
+PATCHVER="1.5"
+
+BINUTILS_VER=${PV%_p*}
+
+inherit toolchain-binutils
+
+DESCRIPTION="Tools necessary to build programs for MSP430 microcontrollers"
+SRC_URI+=" http://dev.gentoo.org/~radhermit/dist/${P}.patch.bz2"
+
+KEYWORDS="~amd64 ~x86"
+
+# needed to fix bug #381633
+RDEPEND=">=sys-devel/binutils-config-3-r2"
+
+pkg_setup() {
+ is_cross || die "Only cross-compile builds are supported"
+}
+
+PATCHES=(
+ "${WORKDIR}"/${P}.patch
+)
diff --git a/dev-embedded/msp430-gcc/ChangeLog b/dev-embedded/msp430-gcc/ChangeLog
index c0eaa589f568..cae263de2c66 100644
--- a/dev-embedded/msp430-gcc/ChangeLog
+++ b/dev-embedded/msp430-gcc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-embedded/msp430-gcc
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/msp430-gcc/ChangeLog,v 1.12 2012/08/30 18:24:51 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/msp430-gcc/ChangeLog,v 1.13 2012/09/14 04:16:04 radhermit Exp $
+
+*msp430-gcc-4.7.0_p20120911 (14 Sep 2012)
+
+ 14 Sep 2012; Tim Harder <radhermit@gentoo.org>
+ +msp430-gcc-4.7.0_p20120911.ebuild:
+ Version bump.
*msp430-gcc-4.7.0_p20120716 (30 Aug 2012)
diff --git a/dev-embedded/msp430-gcc/msp430-gcc-4.7.0_p20120911.ebuild b/dev-embedded/msp430-gcc/msp430-gcc-4.7.0_p20120911.ebuild
new file mode 100644
index 000000000000..fdb216c76291
--- /dev/null
+++ b/dev-embedded/msp430-gcc/msp430-gcc-4.7.0_p20120911.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/msp430-gcc/msp430-gcc-4.7.0_p20120911.ebuild,v 1.1 2012/09/14 04:16:04 radhermit Exp $
+
+EAPI="4"
+
+PATCH_VER="1.1"
+BRANCH_UPDATE=""
+
+inherit toolchain
+
+DESCRIPTION="The GNU Compiler Collection for MSP430 microcontrollers"
+LICENSE="GPL-3 LGPL-3 || ( GPL-3 libgcc libstdc++ gcc-runtime-library-exception-3.1 ) FDL-1.2"
+KEYWORDS=""
+SRC_URI="${SRC_URI} http://dev.gentoo.org/~radhermit/dist/${P}.patch.bz2"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ elibc_glibc? ( >=sys-libs/glibc-2.8 )
+ ${CATEGORY}/msp430-binutils"
+
+pkg_pretend() {
+ is_crosscompile || die "Only cross-compile builds are supported"
+}
+
+src_prepare() {
+ epatch "${DISTDIR}"/${P}.patch.bz2
+}