summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEldad Zack <eldad@gentoo.org>2004-08-13 16:36:05 +0000
committerEldad Zack <eldad@gentoo.org>2004-08-13 16:36:05 +0000
commit91859f21d734861d90e5834dbd83ce9bd51bbc81 (patch)
tree5078ba582cc932e8c63f3e16b56613b59a754db4
parentcleaning up (diff)
downloadhistorical-91859f21d734861d90e5834dbd83ce9bd51bbc81.tar.gz
historical-91859f21d734861d90e5834dbd83ce9bd51bbc81.tar.bz2
historical-91859f21d734861d90e5834dbd83ce9bd51bbc81.zip
Re-fix -ssl issue
-rw-r--r--net-analyzer/ettercap/ChangeLog5
-rw-r--r--net-analyzer/ettercap/Manifest14
-rw-r--r--net-analyzer/ettercap/ettercap-0.7.0.ebuild13
3 files changed, 26 insertions, 6 deletions
diff --git a/net-analyzer/ettercap/ChangeLog b/net-analyzer/ettercap/ChangeLog
index e366b774bf5a..675de6b8785f 100644
--- a/net-analyzer/ettercap/ChangeLog
+++ b/net-analyzer/ettercap/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-analyzer/ettercap
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ettercap/ChangeLog,v 1.35 2004/08/05 23:33:43 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ettercap/ChangeLog,v 1.36 2004/08/13 16:36:05 eldad Exp $
+
+ 13 Aug 2004; Eldad Zack <eldad@gentoo.org> ettercap-0.7.0.ebuild:
+ Re-fix -ssl issue
05 Aug 2004; Jon Hood <squinky86@gentoo.org> ettercap-0.7.0.ebuild:
Stable on x86. Include fix from Alberto <alor@antifork.org>, #59003.
diff --git a/net-analyzer/ettercap/Manifest b/net-analyzer/ettercap/Manifest
index d07fc5521ac5..1b16fc1e0d00 100644
--- a/net-analyzer/ettercap/Manifest
+++ b/net-analyzer/ettercap/Manifest
@@ -1,6 +1,16 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 d893e54934c2a1c8270bbf037efb8895 ettercap-0.6.11.ebuild 1740
-MD5 489a2e40bc84a91670d848d327d89089 ChangeLog 3904
-MD5 880772dbb1175327fe7534d0a5f45ccc ettercap-0.7.0.ebuild 1539
+MD5 678600528883b9a446b91c8f517347f8 ChangeLog 3989
+MD5 c74b1338147cdfe8c58f66fac019ea34 ettercap-0.7.0.ebuild 1637
MD5 61da3c68a3ae57136cdc2a17fbaedfaf metadata.xml 223
MD5 6dc46b78f823aea675d64411673851a2 files/digest-ettercap-0.7.0 70
MD5 0a3618a8adc8c1c2764bb531dbf68810 files/digest-ettercap-0.6.11 66
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.2.4 (GNU/Linux)
+
+iD8DBQFBHO6/T+MN7JbqCpMRAiX2AJ4zuiYcMsXSsk7tE+X21Wg5/Lhv0wCggvrm
+7QrWezYDaWMqsQ9JAslY3YQ=
+=k3v2
+-----END PGP SIGNATURE-----
diff --git a/net-analyzer/ettercap/ettercap-0.7.0.ebuild b/net-analyzer/ettercap/ettercap-0.7.0.ebuild
index a4ee081b57b7..ce37aacfcf6d 100644
--- a/net-analyzer/ettercap/ettercap-0.7.0.ebuild
+++ b/net-analyzer/ettercap/ettercap-0.7.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ettercap/ettercap-0.7.0.ebuild,v 1.3 2004/08/05 23:33:43 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ettercap/ettercap-0.7.0.ebuild,v 1.4 2004/08/13 16:36:05 eldad Exp $
# the actual version is "NG-0.7.0" but I suppose portage people will not be
@@ -41,10 +41,17 @@ src_unpack() {
}
src_compile() {
- econf \
+ local myconf
+
+ if use ssl; then
+ myconf="${myconf} --with-openssl=/usr"
+ else
+ myconf="${myconf} --without-openssl"
+ fi
+
+ econf ${myconf} \
`use_enable gtk gtk` \
`use_enable debug debug` \
- `use_with ssl openssl=/usr` \
`use_with ncurses ncurses` \
|| die "econf failed"