summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-08-01 20:22:45 +0000
committerMike Frysinger <vapier@gentoo.org>2003-08-01 20:22:45 +0000
commit8b769b0467dfe3d431ced59d62210e401a28b207 (patch)
tree62b1daffc87c4ecdec70f6849b731189d8cc45b0
parentquick fix #25240 (diff)
downloadhistorical-8b769b0467dfe3d431ced59d62210e401a28b207.tar.gz
historical-8b769b0467dfe3d431ced59d62210e401a28b207.tar.bz2
historical-8b769b0467dfe3d431ced59d62210e401a28b207.zip
$DEBUG -> use debug
-rw-r--r--app-emulation/nwwine/nwwine-20020703.ebuild24
-rw-r--r--app-emulation/nwwine/nwwine-20030618.ebuild27
2 files changed, 24 insertions, 27 deletions
diff --git a/app-emulation/nwwine/nwwine-20020703.ebuild b/app-emulation/nwwine/nwwine-20020703.ebuild
index 377ce92ce00d..a6fda53d3cfb 100644
--- a/app-emulation/nwwine/nwwine-20020703.ebuild
+++ b/app-emulation/nwwine/nwwine-20020703.ebuild
@@ -1,15 +1,15 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/nwwine/nwwine-20020703.ebuild,v 1.4 2003/06/29 20:06:54 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/nwwine/nwwine-20020703.ebuild,v 1.5 2003/08/01 20:22:45 vapier Exp $
DESCRIPTION="A special version of wine for the Never Winter Nights toolkit"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
HOMEPAGE="http://www.winehq.com/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 -ppc -sparc"
-IUSE="nas arts cups opengl alsa tcltk"
+IUSE="nas arts cups opengl alsa tcltk debug"
DEPEND="sys-devel/gcc
sys-devel/flex
@@ -26,21 +26,20 @@ DEPEND="sys-devel/gcc
opengl? ( virtual/opengl )"
src_compile() {
- cd ${S}
- local myconf
-
- use opengl && myconf="--enable-opengl" || myconf="--disable-opengl"
- [ -z $DEBUG ] && myconf="$myconf --disable-trace --disable-debug" || myconf="$myconf --enable-trace --enable-debug"
# there's no configure flag for cups, arts, alsa and nas, it's supposed to be autodetected
# use the default setting in ./configure over the /etc/make.conf setting
unset CFLAGS CXXFLAGS
- ./configure --prefix=/usr/lib/${PN} \
+ ./configure \
+ --prefix=/usr/lib/${PN} \
--sysconfdir=/etc/${PN} \
--host=${CHOST} \
--enable-curses \
- ${myconf} || die "configure failed"
+ `use_enable opengl` \
+ `use_enable debug trace` \
+ `use_enable debug` \
+ || die "configure failed"
sed -i -e 's:wine.pm:include/wine.pm:' ${S}/programs/winetest/Makefile || \
die "sed programs/winetest/Makefile failed"
@@ -50,11 +49,10 @@ src_compile() {
cd programs && emake || die
}
-src_install () {
+src_install() {
local WINEMAKEOPTS="prefix=${D}/usr/lib/${PN}"
### Install wine to ${D}
- cd ${S}
make ${WINEMAKEOPTS} install || die
cd ${S}/programs
make ${WINEMAKEOPTS} install || die
diff --git a/app-emulation/nwwine/nwwine-20030618.ebuild b/app-emulation/nwwine/nwwine-20030618.ebuild
index 5394c66558b6..3d47cbca70dd 100644
--- a/app-emulation/nwwine/nwwine-20030618.ebuild
+++ b/app-emulation/nwwine/nwwine-20030618.ebuild
@@ -1,20 +1,18 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/nwwine/nwwine-20030618.ebuild,v 1.1 2003/06/28 11:18:37 coronalvr Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/nwwine/nwwine-20030618.ebuild,v 1.2 2003/08/01 20:22:45 vapier Exp $
DESCRIPTION="A special version of wine for the Never Winter Nights toolkit"
+HOMEPAGE="http://www.winehq.com/ http://republika.pl/nwnlinux/"
SRC_URI="mirror://gentoo/${P}-misc.tar.bz2
ftp://128.173.184.249/Linux/nwwine/nwwine-based-on-${PV}.tar.gz
mirror://gentoo/${P}-fake_windows.tar.bz2
mirror://gentoo/wine-nvidia-fix.patch.gz"
-HOMEPAGE="http://www.winehq.com/ http://republika.pl/nwnlinux/"
-
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="~x86 -ppc -sparc"
-IUSE="nas arts cups opengl alsa tcltk"
-S=${WORKDIR}/nwwine-based-on-${PV}
+IUSE="nas arts cups opengl alsa tcltk debug"
DEPEND="sys-devel/gcc
sys-devel/flex
@@ -30,6 +28,8 @@ DEPEND="sys-devel/gcc
cups? ( net-print/cups )
opengl? ( virtual/opengl )"
+S=${WORKDIR}/nwwine-based-on-${PV}
+
src_compile() {
cd ${S}/dlls/opengl32
epatch ${WORKDIR}/wine-nvidia-fix.patch
@@ -38,32 +38,31 @@ src_compile() {
#fix the nwwine wrapper
mv nwwine.sh nwwine.old
sed -e "s:wine:/usr/lib/nwwine/bin/wine:" nwwine.old > nwwine.sh
-
- local myconf
- use opengl && myconf="--enable-opengl" || myconf="--disable-opengl"
- [ -z $DEBUG ] && myconf="$myconf --disable-trace --disable-debug" || myconf="$myconf --enable-trace --enable-debug"
# there's no configure flag for cups, arts, alsa and nas, it's supposed to be autodetected
# use the default setting in ./configure over the /etc/make.conf setting
unset CFLAGS CXXFLAGS
- ./configure --prefix=/usr/lib/${PN} \
+ ./configure \
+ --prefix=/usr/lib/${PN} \
--sysconfdir=/etc/${PN} \
--host=${CHOST} \
--enable-curses \
- ${myconf} || die "configure failed"
+ `use_enable opengl` \
+ `use_enable debug trace` \
+ `use_enable debug` \
+ || die "configure failed"
# No parallel make
make depend all || die "make depend all failed"
cd programs && emake || die
}
-src_install () {
+src_install() {
local WINEMAKEOPTS="prefix=${D}/usr/lib/${PN}"
### Install wine to ${D}
- cd ${S}
make ${WINEMAKEOPTS} install || die
cd ${S}/programs
make ${WINEMAKEOPTS} install || die