summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Buchholz <rbu@gentoo.org>2008-03-12 15:00:36 +0000
committerRobert Buchholz <rbu@gentoo.org>2008-03-12 15:00:36 +0000
commit84d02c9a7448b1f8722be21038330e263dd122a2 (patch)
treeaaee65ec9fff3c15db9e48f163db2368f55e3d61
parentVersion bump, thanks to alpiturchi (bug #210346). Hard depend 0.6.1-r1 -> ~ka... (diff)
downloadhistorical-84d02c9a7448b1f8722be21038330e263dd122a2.tar.gz
historical-84d02c9a7448b1f8722be21038330e263dd122a2.tar.bz2
historical-84d02c9a7448b1f8722be21038330e263dd122a2.zip
Version bump, thanks to alpiturchi (bug #210344). Hard depend 0.2.1 -> ~kaa-base-0.1.3
Package-Manager: portage-2.1.4.4
-rw-r--r--dev-python/kaa-imlib2/ChangeLog11
-rw-r--r--dev-python/kaa-imlib2/kaa-imlib2-0.2.1.ebuild6
-rw-r--r--dev-python/kaa-imlib2/kaa-imlib2-0.2.3.ebuild30
3 files changed, 42 insertions, 5 deletions
diff --git a/dev-python/kaa-imlib2/ChangeLog b/dev-python/kaa-imlib2/ChangeLog
index 257b7b17355b..0003e98b7f56 100644
--- a/dev-python/kaa-imlib2/ChangeLog
+++ b/dev-python/kaa-imlib2/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/kaa-imlib2
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/kaa-imlib2/ChangeLog,v 1.5 2007/10/06 20:14:57 dertobi123 Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/kaa-imlib2/ChangeLog,v 1.6 2008/03/12 15:00:36 rbu Exp $
+
+*kaa-imlib2-0.2.3 (12 Mar 2008)
+
+ 12 Mar 2008; Robert Buchholz <rbu@gentoo.org> kaa-imlib2-0.2.1.ebuild,
+ +kaa-imlib2-0.2.3.ebuild:
+ Version bump, thanks to alpiturchi (bug #210344). Hard depend 0.2.1 ->
+ ~kaa-base-0.1.3
06 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
kaa-imlib2-0.2.1.ebuild:
diff --git a/dev-python/kaa-imlib2/kaa-imlib2-0.2.1.ebuild b/dev-python/kaa-imlib2/kaa-imlib2-0.2.1.ebuild
index 7e271566ec2a..ef1e33398448 100644
--- a/dev-python/kaa-imlib2/kaa-imlib2-0.2.1.ebuild
+++ b/dev-python/kaa-imlib2/kaa-imlib2-0.2.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/kaa-imlib2/kaa-imlib2-0.2.1.ebuild,v 1.5 2007/10/06 20:14:57 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/kaa-imlib2/kaa-imlib2-0.2.1.ebuild,v 1.6 2008/03/12 15:00:36 rbu Exp $
inherit python eutils distutils
@@ -13,7 +13,7 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE=""
-DEPEND=">=dev-python/kaa-base-0.1.3
+DEPEND="~dev-python/kaa-base-0.1.3
dev-libs/libxml2
media-libs/imlib2"
RDEPEND="${DEPEND}"
diff --git a/dev-python/kaa-imlib2/kaa-imlib2-0.2.3.ebuild b/dev-python/kaa-imlib2/kaa-imlib2-0.2.3.ebuild
new file mode 100644
index 000000000000..9d320b86d70b
--- /dev/null
+++ b/dev-python/kaa-imlib2/kaa-imlib2-0.2.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/kaa-imlib2/kaa-imlib2-0.2.3.ebuild,v 1.1 2008/03/12 15:00:36 rbu Exp $
+
+inherit python eutils distutils
+
+DESCRIPTION="Imlib2 wrapper for Python."
+HOMEPAGE="http://freevo.sourceforge.net/kaa/"
+SRC_URI="mirror://sourceforge/freevo/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=dev-python/kaa-base-0.3.0
+ dev-libs/libxml2
+ media-libs/imlib2"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if ! built_with_use dev-libs/libxml2 python; then
+ eerror "dev-libs/libxml2 must be built with the 'python' USE flag"
+ die "Recompile dev-libs/libxml2 with the 'python' USE flag enabled"
+ fi
+ if ! built_with_use media-libs/imlib2 png; then
+ eerror "media-libs/imlib2 must be built with the 'png' USE flag"
+ die "Recompile media-libs/imlib2 with the 'png' USE flag enabled"
+ fi
+}