summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-05-29 21:29:34 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-05-29 21:29:34 +0000
commit70afd9286e8ffc96b8ae50faa1175f440a47f4c7 (patch)
tree473c6f07d1c1b0b22b60aca554a05f2371d53ca9
parentnew version. many nive new features, fex it is now a frontend for dvd ripping... (diff)
downloadhistorical-70afd9286e8ffc96b8ae50faa1175f440a47f4c7.tar.gz
historical-70afd9286e8ffc96b8ae50faa1175f440a47f4c7.tar.bz2
historical-70afd9286e8ffc96b8ae50faa1175f440a47f4c7.zip
New release
-rw-r--r--net-mail/mutt/ChangeLog8
-rw-r--r--net-mail/mutt/files/digest-mutt-1.41
-rw-r--r--net-mail/mutt/mutt-1.4.ebuild46
3 files changed, 54 insertions, 1 deletions
diff --git a/net-mail/mutt/ChangeLog b/net-mail/mutt/ChangeLog
index a386088ec584..5c7a95d9754c 100644
--- a/net-mail/mutt/ChangeLog
+++ b/net-mail/mutt/ChangeLog
@@ -1,7 +1,13 @@
# ChangeLog for net-mail/mutt
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mutt/ChangeLog,v 1.3 2002/04/26 00:11:56 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mutt/ChangeLog,v 1.4 2002/05/29 21:29:34 rphillips Exp $
+*mutt-1.4 (29 May 2002)
+
+ 29 Apr 2002; Ryan Phillips <rphillips@gentoo.org> mutt-1.4.ebuild :
+
+ new version
+
*mutt-1.3.28-r1 (25 Apr 2002)
25 Apr 2002; Ryan Phillips <rphillips@gentoo.org> mutt-1.3.28-r1.ebuild :
diff --git a/net-mail/mutt/files/digest-mutt-1.4 b/net-mail/mutt/files/digest-mutt-1.4
new file mode 100644
index 000000000000..177f7deab9a7
--- /dev/null
+++ b/net-mail/mutt/files/digest-mutt-1.4
@@ -0,0 +1 @@
+MD5 a67bcdf1a1cd53d61ccd3ebf3993ba59 mutt-1.4i.tar.gz 2554158
diff --git a/net-mail/mutt/mutt-1.4.ebuild b/net-mail/mutt/mutt-1.4.ebuild
new file mode 100644
index 000000000000..778ae9d1c898
--- /dev/null
+++ b/net-mail/mutt/mutt-1.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Server Team <server@gentoo.org>
+# Maintainers: Daniel Robbins <drobbins@gentoo.org>, Aron Griffis <agriffis@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mutt/mutt-1.4.ebuild,v 1.1 2002/05/29 21:29:34 rphillips Exp $
+
+S=$WORKDIR/$P
+DESCRIPTION="a small but very powerful text-based mail client"
+SRC_URI="ftp://ftp.mutt.org/pub/mutt/mutt-${PV}i.tar.gz"
+HOMEPAGE="http://www.mutt.org"
+
+DEPEND="virtual/glibc
+ nls? ( sys-devel/gettext )
+ >=sys-libs/ncurses-5.2
+ slang? ( >=sys-libs/slang-1.4.2 )
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
+
+src_compile() {
+ local myconf
+ use nls && myconf="--enable-nls" \
+ || myconf="--disable-nls"
+ use ssl && myconf="$myconf --with-ssl" \
+ || myconf="$myconf --without-ssl"
+ # --without-slang doesn't work;
+ # specify --with-curses if you don't want slang
+ # (26 Sep 2001 agriffis)
+ use slang && myconf="$myconf --with-slang" \
+ || myconf="$myconf --with-curses"
+ ./configure --host=$CHOST \
+ --prefix=/usr --sysconfdir=/etc/mutt \
+ --mandir=/usr/share/man --with-docdir=/usr/share/doc/mutt-$PVR \
+ --with-regex --enable-pop --enable-imap --enable-nfs-fix \
+ --disable-fcntl --enable-flock --enable-external-dotlock \
+ --with-homespool=Maildir $myconf
+ assert "./configure failed (myconf=$myconf)"
+ cp doc/Makefile doc/Makefile.orig
+ sed 's/README.UPGRADE//' doc/Makefile.orig > doc/Makefile
+ make || die "make failed (myconf=$myconf)"
+}
+
+src_install () {
+ make DESTDIR=$D install || die
+ find $D/usr/share/doc -type f |grep -v html | xargs gzip
+ insinto /etc/mutt
+ doins $FILESDIR/Muttrc
+}