summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2009-06-18 15:40:05 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2009-06-18 15:40:05 +0000
commit6f833102ba759e2477e30b213dd386441d19393e (patch)
treeee0c5e9b8aec96c7cd551a298c54bc2b92070b21
parentApply gcc-4.4 patch. bug 273007 (diff)
downloadhistorical-6f833102ba759e2477e30b213dd386441d19393e.tar.gz
historical-6f833102ba759e2477e30b213dd386441d19393e.tar.bz2
historical-6f833102ba759e2477e30b213dd386441d19393e.zip
Version bumped.
Package-Manager: portage-2.1.6.13/cvs/Linux x86_64
-rw-r--r--app-i18n/ibus-anthy/ChangeLog8
-rw-r--r--app-i18n/ibus-anthy/ibus-anthy-1.2.0.20090617.ebuild55
-rw-r--r--app-i18n/ibus-hangul/ChangeLog8
-rw-r--r--app-i18n/ibus-hangul/ibus-hangul-1.1.0.20090328.ebuild9
-rw-r--r--app-i18n/ibus-hangul/ibus-hangul-1.2.0.20090617.ebuild46
-rw-r--r--app-i18n/ibus-m17n/ChangeLog8
-rw-r--r--app-i18n/ibus-m17n/ibus-m17n-1.2.0.20090617.ebuild40
-rw-r--r--app-i18n/ibus-pinyin/ChangeLog8
-rw-r--r--app-i18n/ibus-pinyin/ibus-pinyin-1.2.0.20090617.ebuild57
-rw-r--r--app-i18n/ibus-table/ChangeLog8
-rw-r--r--app-i18n/ibus-table/ibus-table-1.1.0.20090615.ebuild47
-rw-r--r--app-i18n/ibus/ChangeLog8
-rw-r--r--app-i18n/ibus/ibus-1.2.0.20090617.ebuild104
13 files changed, 399 insertions, 7 deletions
diff --git a/app-i18n/ibus-anthy/ChangeLog b/app-i18n/ibus-anthy/ChangeLog
index 05203f6048db..500ab64c297f 100644
--- a/app-i18n/ibus-anthy/ChangeLog
+++ b/app-i18n/ibus-anthy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/ibus-anthy
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-anthy/ChangeLog,v 1.9 2009/06/04 16:22:21 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-anthy/ChangeLog,v 1.10 2009/06/18 15:38:45 matsuu Exp $
+
+*ibus-anthy-1.2.0.20090617 (18 Jun 2009)
+
+ 18 Jun 2009; MATSUU Takuto <matsuu@gentoo.org>
+ +ibus-anthy-1.2.0.20090617.ebuild:
+ Version bumped.
*ibus-anthy-1.1.0.20090603 (04 Jun 2009)
diff --git a/app-i18n/ibus-anthy/ibus-anthy-1.2.0.20090617.ebuild b/app-i18n/ibus-anthy/ibus-anthy-1.2.0.20090617.ebuild
new file mode 100644
index 000000000000..46930f6c8dc7
--- /dev/null
+++ b/app-i18n/ibus-anthy/ibus-anthy-1.2.0.20090617.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-anthy/ibus-anthy-1.2.0.20090617.ebuild,v 1.1 2009/06/18 15:38:45 matsuu Exp $
+
+inherit eutils python
+
+DESCRIPTION="Japanese input method Anthy IMEngine for IBus Framework"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND=">=app-i18n/ibus-1.1.0
+ app-i18n/anthy
+ >=dev-lang/python-2.5
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-lang/swig
+ dev-util/pkgconfig
+ nls? ( >=sys-devel/gettext-0.16.1 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ mv py-compile py-compile.orig || die
+ ln -s "$(type -P true)" py-compile || die
+}
+
+src_compile() {
+ econf $(use_enable nls) || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ ewarn "This package is very experimental, please report your bugs to"
+ ewarn "http://ibus.googlecode.com/issues/list"
+ elog
+ elog "You should run ibus-setup and enable IM Engines you want to use!"
+ elog
+
+ python_mod_optimize /usr/share/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}
+}
diff --git a/app-i18n/ibus-hangul/ChangeLog b/app-i18n/ibus-hangul/ChangeLog
index 608fe270dfb2..12d032475339 100644
--- a/app-i18n/ibus-hangul/ChangeLog
+++ b/app-i18n/ibus-hangul/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/ibus-hangul
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-hangul/ChangeLog,v 1.6 2009/03/30 16:03:37 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-hangul/ChangeLog,v 1.7 2009/06/18 15:40:05 matsuu Exp $
+
+*ibus-hangul-1.2.0.20090617 (18 Jun 2009)
+
+ 18 Jun 2009; MATSUU Takuto <matsuu@gentoo.org>
+ ibus-hangul-1.1.0.20090328.ebuild, +ibus-hangul-1.2.0.20090617.ebuild:
+ Version bumped.
*ibus-hangul-1.1.0.20090328 (30 Mar 2009)
diff --git a/app-i18n/ibus-hangul/ibus-hangul-1.1.0.20090328.ebuild b/app-i18n/ibus-hangul/ibus-hangul-1.1.0.20090328.ebuild
index a191d45949df..86ea326759bc 100644
--- a/app-i18n/ibus-hangul/ibus-hangul-1.1.0.20090328.ebuild
+++ b/app-i18n/ibus-hangul/ibus-hangul-1.1.0.20090328.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-hangul/ibus-hangul-1.1.0.20090328.ebuild,v 1.1 2009/03/30 16:03:37 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-hangul/ibus-hangul-1.1.0.20090328.ebuild,v 1.2 2009/06/18 15:40:05 matsuu Exp $
DESCRIPTION="The Hangul engine for IBus input platform"
HOMEPAGE="http://code.google.com/p/ibus/"
@@ -19,6 +19,13 @@ DEPEND="${RDEPEND}
dev-util/pkgconfig
nls? ( >=sys-devel/gettext-0.16.1 )"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ mv py-compile py-compile.orig || die
+ ln -s "$(type -P true)" py-compile || die
+}
+
src_compile() {
econf $(use_enable nls) || die
emake || die
diff --git a/app-i18n/ibus-hangul/ibus-hangul-1.2.0.20090617.ebuild b/app-i18n/ibus-hangul/ibus-hangul-1.2.0.20090617.ebuild
new file mode 100644
index 000000000000..860e19266c1f
--- /dev/null
+++ b/app-i18n/ibus-hangul/ibus-hangul-1.2.0.20090617.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-hangul/ibus-hangul-1.2.0.20090617.ebuild,v 1.1 2009/06/18 15:40:05 matsuu Exp $
+
+DESCRIPTION="The Hangul engine for IBus input platform"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND=">=dev-lang/python-2.5
+ >=app-i18n/ibus-1.2
+ >=app-i18n/libhangul-0.0.9
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( >=sys-devel/gettext-0.16.1 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ mv py-compile py-compile.orig || die
+ ln -s "$(type -P true)" py-compile || die
+}
+
+src_compile() {
+ econf $(use_enable nls) || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ ewarn "This package is very experimental, please report your bugs to"
+ ewarn "http://ibus.googlecode.com/issues/list"
+ elog
+ elog "You should run ibus-setup and enable IM Engines you want to use!"
+ elog
+}
diff --git a/app-i18n/ibus-m17n/ChangeLog b/app-i18n/ibus-m17n/ChangeLog
index ee7d19f2c2ba..53214715daf6 100644
--- a/app-i18n/ibus-m17n/ChangeLog
+++ b/app-i18n/ibus-m17n/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/ibus-m17n
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-m17n/ChangeLog,v 1.6 2009/03/31 14:57:39 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-m17n/ChangeLog,v 1.7 2009/06/18 15:40:00 matsuu Exp $
+
+*ibus-m17n-1.2.0.20090617 (18 Jun 2009)
+
+ 18 Jun 2009; MATSUU Takuto <matsuu@gentoo.org>
+ +ibus-m17n-1.2.0.20090617.ebuild:
+ Version bumped.
31 Mar 2009; MATSUU Takuto <matsuu@gentoo.org>
-ibus-m17n-0.1.1.20081013.ebuild, -ibus-m17n-1.1.0.20090205.ebuild:
diff --git a/app-i18n/ibus-m17n/ibus-m17n-1.2.0.20090617.ebuild b/app-i18n/ibus-m17n/ibus-m17n-1.2.0.20090617.ebuild
new file mode 100644
index 000000000000..84f62f2c9a1d
--- /dev/null
+++ b/app-i18n/ibus-m17n/ibus-m17n-1.2.0.20090617.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-m17n/ibus-m17n-1.2.0.20090617.ebuild,v 1.1 2009/06/18 15:40:00 matsuu Exp $
+
+DESCRIPTION="The M17N engine IMEngine for IBus Framework"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND=">=app-i18n/ibus-1.2
+ dev-libs/m17n-lib
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-db/m17n-db
+ dev-db/m17n-contrib
+ >=sys-devel/gettext-0.16.1"
+
+src_compile() {
+ econf $(use_enable nls) || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ ewarn "This package is very experimental, please report your bugs to"
+ ewarn "http://ibus.googlecode.com/issues/list"
+ elog
+ elog "You should run ibus-setup and enable IM Engines you want to use!"
+ elog
+}
diff --git a/app-i18n/ibus-pinyin/ChangeLog b/app-i18n/ibus-pinyin/ChangeLog
index 72e31d827ad6..8561572701c1 100644
--- a/app-i18n/ibus-pinyin/ChangeLog
+++ b/app-i18n/ibus-pinyin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/ibus-pinyin
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-pinyin/ChangeLog,v 1.8 2009/06/12 13:36:57 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-pinyin/ChangeLog,v 1.9 2009/06/18 15:38:56 matsuu Exp $
+
+*ibus-pinyin-1.2.0.20090617 (18 Jun 2009)
+
+ 18 Jun 2009; MATSUU Takuto <matsuu@gentoo.org>
+ +ibus-pinyin-1.2.0.20090617.ebuild:
+ Version bumped.
*ibus-pinyin-1.1.0.20090612 (12 Jun 2009)
diff --git a/app-i18n/ibus-pinyin/ibus-pinyin-1.2.0.20090617.ebuild b/app-i18n/ibus-pinyin/ibus-pinyin-1.2.0.20090617.ebuild
new file mode 100644
index 000000000000..333da0620d83
--- /dev/null
+++ b/app-i18n/ibus-pinyin/ibus-pinyin-1.2.0.20090617.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-pinyin/ibus-pinyin-1.2.0.20090617.ebuild,v 1.1 2009/06/18 15:38:56 matsuu Exp $
+
+EAPI="2"
+inherit eutils python
+
+PYDB_TAR="pinyin-database-0.1.10.6.tar.bz2"
+DESCRIPTION="Chinese PinYin IMEngine for IBus Framework"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz
+ http://ibus.googlecode.com/files/${PYDB_TAR}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND=">=app-i18n/ibus-1.1.0
+ >=dev-lang/python-2.5[sqlite]
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( >=sys-devel/gettext-0.16.1 )"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd "${S}"
+ mv py-compile py-compile.orig || die
+ ln -s "$(type -P true)" py-compile || die
+ cp "${DISTDIR}/${PYDB_TAR}" "${S}"/engine
+}
+
+src_compile() {
+ econf $(use_enable nls) || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ ewarn "This package is very experimental, please report your bugs to"
+ ewarn "http://ibus.googlecode.com/issues/list"
+ elog
+ elog "You should run ibus-setup and enable IM Engines you want to use!"
+ elog
+
+ python_mod_optimize /usr/share/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}
+}
diff --git a/app-i18n/ibus-table/ChangeLog b/app-i18n/ibus-table/ChangeLog
index 6d503956bbb9..f6ee63d23f72 100644
--- a/app-i18n/ibus-table/ChangeLog
+++ b/app-i18n/ibus-table/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/ibus-table
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-table/ChangeLog,v 1.14 2009/06/09 16:26:24 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-table/ChangeLog,v 1.15 2009/06/18 15:38:25 matsuu Exp $
+
+*ibus-table-1.1.0.20090615 (18 Jun 2009)
+
+ 18 Jun 2009; MATSUU Takuto <matsuu@gentoo.org>
+ +ibus-table-1.1.0.20090615.ebuild:
+ Version bumped.
*ibus-table-1.1.0.20090609 (09 Jun 2009)
diff --git a/app-i18n/ibus-table/ibus-table-1.1.0.20090615.ebuild b/app-i18n/ibus-table/ibus-table-1.1.0.20090615.ebuild
new file mode 100644
index 000000000000..c6d5c410d967
--- /dev/null
+++ b/app-i18n/ibus-table/ibus-table-1.1.0.20090615.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-table/ibus-table-1.1.0.20090615.ebuild,v 1.1 2009/06/18 15:38:25 matsuu Exp $
+
+EAPI="2"
+inherit eutils python
+
+DESCRIPTION="The Table Engine for IBus Framework"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="minimal nls"
+
+RDEPEND=">=app-i18n/ibus-1.1
+ >=dev-lang/python-2.5[sqlite]
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.16.1 )
+ dev-util/pkgconfig"
+
+src_prepare() {
+ mv py-compile py-compile.orig || die
+ ln -s "$(type -P true)" py-compile || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable !minimal additional) \
+ $(use_enable nls) || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/${PN}/engine
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}/engine
+}
diff --git a/app-i18n/ibus/ChangeLog b/app-i18n/ibus/ChangeLog
index 255d94bf6d61..d79dc33d0b76 100644
--- a/app-i18n/ibus/ChangeLog
+++ b/app-i18n/ibus/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/ibus
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus/ChangeLog,v 1.31 2009/06/12 13:28:13 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus/ChangeLog,v 1.32 2009/06/18 15:38:42 matsuu Exp $
+
+*ibus-1.2.0.20090617 (18 Jun 2009)
+
+ 18 Jun 2009; MATSUU Takuto <matsuu@gentoo.org>
+ +ibus-1.2.0.20090617.ebuild:
+ Version bumped.
*ibus-1.1.0.20090612 (12 Jun 2009)
diff --git a/app-i18n/ibus/ibus-1.2.0.20090617.ebuild b/app-i18n/ibus/ibus-1.2.0.20090617.ebuild
new file mode 100644
index 000000000000..39e482d5f44f
--- /dev/null
+++ b/app-i18n/ibus/ibus-1.2.0.20090617.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus/ibus-1.2.0.20090617.ebuild,v 1.1 2009/06/18 15:38:42 matsuu Exp $
+
+EAPI="1"
+inherit autotools eutils multilib python
+
+DESCRIPTION="Intelligent Input Bus for Linux / Unix OS"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+#IUSE="doc nls qt4"
+IUSE="doc nls"
+
+RDEPEND=">=dev-libs/glib-2.18
+ >=x11-libs/gtk+-2
+ >=gnome-base/gconf-2.12
+ >=gnome-base/librsvg-2
+ sys-apps/dbus
+ app-text/iso-codes
+ x11-libs/libX11
+ >=dev-lang/python-2.5
+ >=dev-python/pygobject-2.14
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1.9 )
+ nls? ( >=sys-devel/gettext-0.16.1 )"
+RDEPEND="${RDEPEND}
+ dev-python/pygtk
+ >=dev-python/dbus-python-0.83
+ dev-python/pyxdg"
+# qt4? (
+# >=x11-libs/qt-core-4.4:4
+# >=x11-libs/qt-dbus-4.4:4
+# )
+
+pkg_setup() {
+ # An arch specific config directory is used on multilib systems
+ has_multilib_profile && GTK2_CONFDIR="/etc/gtk-2.0/${CHOST}"
+ GTK2_CONFDIR=${GTK2_CONFDIR:=/etc/gtk-2.0/}
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ mv py-compile py-compile.orig || die
+ ln -s "$(type -P true)" py-compile || die
+ sed -i -e '/QMAKE/s/$/ "CONFIG+=nostrip"/' client/qt4/Makefile.am || die
+ eautomake
+}
+
+src_compile() {
+ # qt4-immodule won't work
+ # http://code.google.com/p/ibus/issues/detail?id=341
+ econf \
+ $(use_enable doc gtk-doc) \
+ $(use_enable nls) || die
+# $(use_enable qt4 qt4-immodule)
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ local qt_im_module="xim"
+# use qt4 && qt_im_module="ibus"
+
+ elog "To use ibus, you should:"
+ elog "1. Get input engines from sunrise overlay."
+ elog " Run \"emerge -s ibus-\" in your favorite terminal"
+ elog " for a list of packages we already have."
+ elog
+ elog "2. Setup ibus:"
+ elog
+ elog " $ ibus-setup"
+ elog
+ elog "3. Set the following in your user startup scripts"
+ elog " such as .xinitrc, .xsession or .xprofile:"
+ elog
+ elog " export XMODIFIERS=\"@im=ibus\""
+ elog " export GTK_IM_MODULE=\"ibus\""
+ elog " export QT_IM_MODULE=\"${qt_im_module}\""
+ elog " ibus-daemon -d -x"
+
+ [ "${ROOT}" = "/" -a -x /usr/bin/gtk-query-immodules-2.0 ] && \
+ gtk-query-immodules-2.0 > "${ROOT}/${GTK2_CONFDIR}/gtk.immodules"
+
+ python_mod_optimize /usr/share/${PN}
+}
+
+pkg_postrm() {
+ [ "${ROOT}" = "/" -a -x /usr/bin/gtk-query-immodules-2.0 ] && \
+ gtk-query-immodules-2.0 > "${ROOT}/${GTK2_CONFDIR}/gtk.immodules"
+
+ python_mod_cleanup /usr/share/${PN}
+}