summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2003-06-21 18:14:33 +0000
committerDaniel Robbins <drobbins@gentoo.org>2003-06-21 18:14:33 +0000
commit6c976a02c651c2102e2f4059bed61d7be3ec652c (patch)
treec618768738dbab874f3eeb22615415258398b49b
parentnew amd64 headers (diff)
downloadhistorical-6c976a02c651c2102e2f4059bed61d7be3ec652c.tar.gz
historical-6c976a02c651c2102e2f4059bed61d7be3ec652c.tar.bz2
historical-6c976a02c651c2102e2f4059bed61d7be3ec652c.zip
new amd64 headers
-rw-r--r--sys-kernel/linux-headers/Manifest4
-rw-r--r--sys-kernel/linux-headers/files/digest-linux-headers-2.4.211
-rw-r--r--sys-kernel/linux-headers/linux-headers-2.4.21.ebuild153
3 files changed, 156 insertions, 2 deletions
diff --git a/sys-kernel/linux-headers/Manifest b/sys-kernel/linux-headers/Manifest
index ce0be3127ded..e80737d762b9 100644
--- a/sys-kernel/linux-headers/Manifest
+++ b/sys-kernel/linux-headers/Manifest
@@ -1,4 +1,4 @@
-MD5 1bb794c13b01d619cd3d9c397c930a41 ChangeLog 2531
+MD5 ee4b696f4ba3872dbbc13f316be25782 ChangeLog 2533
MD5 a559566f91b30eccec2cec9f9d3120eb linux-headers-2.2.20.ebuild 3943
MD5 ba008f48909eb09fb6cdba42ffa55430 linux-headers-2.2.21_pre3.ebuild 4124
MD5 845f89ee1827badcc8f1cb0045a60776 linux-headers-2.4.16-r1.ebuild 5114
@@ -12,7 +12,7 @@ MD5 8f1baec5ce1d97a32bb55d888e3b07ec linux-headers-2.4.18-r2.ebuild 4578
MD5 9df0b49be2ce38b93f4ca529c496278d linux-headers-2.4.18.ebuild 3194
MD5 08fb348248d692e4d79c63f0a6dcf240 linux-headers-2.4.19-r1.ebuild 4812
MD5 274b57c7836c4f7687ebd3f4389e3870 linux-headers-2.4.19.ebuild 4648
-MD5 5c9ea6e519442373b55c7227778c846d linux-headers-2.4.21.ebuild 4865
+MD5 082276984baa599752f73a7da7de5423 linux-headers-2.4.21.ebuild 4861
MD5 07aeae7e5036a3ec3e06d29fd68e9cce files/digest-linux-headers-2.2.20 216
MD5 167e790d7861e0ed3a31577b31a92968 files/digest-linux-headers-2.2.21_pre3 281
MD5 ac116e74551067f3bd3a2a3c85ba0b0b files/digest-linux-headers-2.4.16 281
diff --git a/sys-kernel/linux-headers/files/digest-linux-headers-2.4.21 b/sys-kernel/linux-headers/files/digest-linux-headers-2.4.21
new file mode 100644
index 000000000000..4cf91697ea68
--- /dev/null
+++ b/sys-kernel/linux-headers/files/digest-linux-headers-2.4.21
@@ -0,0 +1 @@
+MD5 f51e12efa18bb828cf57d9d4a81b2fb1 linux-2.4.21.tar.bz2 28533733
diff --git a/sys-kernel/linux-headers/linux-headers-2.4.21.ebuild b/sys-kernel/linux-headers/linux-headers-2.4.21.ebuild
new file mode 100644
index 000000000000..4558106b4de0
--- /dev/null
+++ b/sys-kernel/linux-headers/linux-headers-2.4.21.ebuild
@@ -0,0 +1,153 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-2.4.21.ebuild,v 1.1 2003/06/21 18:14:12 drobbins Exp $
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+#we use this next variable to avoid duplicating stuff on cvs
+GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files
+SPARCFILEDIR=${PORTDIR}/sys-kernel/sparc-sources/files
+OKV=2.4.21
+KV=2.4.21
+S=${WORKDIR}/linux-${KV}
+
+#These are *stock* 2.4.21 headers, for niceness.
+
+DESCRIPTION="Full sources for the Gentoo Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2"
+PROVIDE="virtual/kernel virtual/os-headers"
+HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/"
+LICENSE="GPL-2"
+SLOT="${KV}"
+KEYWORDS="-* amd64"
+
+if [ "$ARCH" = "amd64" ]
+then
+ KERNEL_ARCH="x86_64"
+else
+ KERNEL_ARCH=`echo $ARCH |\
+ sed -e s/[i]*.86/i386/ -e s/sun4u/sparc64/ -e s/arm.*/arm/ -e s/sa110/arm/`
+ if [ -z "$KERNEL_ARCH" ]
+ then
+ KERNEL_ARCH=`uname -m |\
+ sed -e s/[i]*.86/i386/ -e s/sun4u/sparc64/ -e s/arm.*/arm/ -e s/sa110/arm/`
+ fi
+ [ $KERNEL_ARCH="sparc" -a "$PROFILE_ARCH" = "sparc64" ] && KERNEL_ARCH="sparc64"
+fi
+
+if [ $PN = "linux-sources" ] && [ -z "`use build`" ]
+then
+ #console-tools is needed to solve the loadkeys fiasco; binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
+ DEPEND=">=sys-devel/binutils-2.11.90.0.31"
+ RDEPEND =">=sys-libs/ncurses-5.2 dev-lang/perl virtual/modutils sys-devel/make ? sys-devel/egcs64-sparc"
+fi
+
+[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack linux-${OKV}.tar.bz2
+ #the main source dir for linux-2.4.19 (and higher?) has the version attached
+ if [ $OKV != $KV ]; then
+ mv linux-${OKV} linux-${KV} || die "moving kernel"
+ fi
+ cd ${S}
+
+ #sometimes we have icky kernel symbols; this seems to get rid of them
+ make mrproper || die "making proper"
+
+ #this file is required for other things to build properly, so we autogenerate it
+ make include/linux/version.h || die "making headers"
+
+ #fix silly permissions in tarball
+ cd ${WORKDIR}
+ chown -R 0.0 *
+ chmod -R a+r-w+X,u+w *
+
+ # Gentoo Linux uses /boot, so fix 'make install' to work properly
+ cd ${S}
+ mv Makefile Makefile.orig
+ sed -e 's:#export\tINSTALL_PATH:export\tINSTALL_PATH:' \
+ Makefile.orig >Makefile || die "sed makefile" # test, remove me if Makefile ok
+ rm Makefile.orig
+}
+
+src_compile() {
+ if [ "$PN" = "linux-headers" ]
+ then
+ yes "" | make oldconfig
+ echo "Ignore any errors from the yes command above."
+ fi
+}
+
+src_install() {
+ if [ "$PN" = "linux-sources" ]
+ then
+ dodir /usr/src
+ echo ">>> Copying sources..."
+ mv ${WORKDIR}/* ${D}/usr/src
+ else
+ #linux-headers
+ dodir /usr/include/linux
+ cp -ax ${S}/include/linux/* ${D}/usr/include/linux
+ rm -rf ${D}/usr/include/linux/modules
+ dodir /usr/include/asm
+ if [ `expr $KERNEL_ARCH ":" "sparc"` -eq 5 ]
+ then
+ dodir /usr/include/asm-{sparc,sparc64}
+ if [ "$KERNEL_ARCH" = "sparc64" ]
+ then
+ cp -ax ${S}/include/asm-sparc64/* ${D}/usr/include/asm-sparc64
+ if [ ! -r ${D}/usr/include/asm-sparc64/asm_offsets.h ]
+ then
+ cp ${SPARCFILEDIR}/${OKV}/sparc64-asm_offsets.h \
+ ${D}/usr/include/asm-sparc64/asm_offsets.h
+ fi
+ fi
+
+ cp -ax ${S}/include/asm-sparc/* ${D}/usr/include/asm-sparc
+ if [ ! -r ${D}/usr/include/asm-sparc/asm_offsets.h ]
+ then
+ cp ${SPARCFILEDIR}/${OKV}/sparc-asm_offsets.h \
+ ${D}/usr/include/asm-sparc/asm_offsets.h
+ fi
+ ${SPARCFILEDIR}/generate-asm-sparc ${D}/usr/include
+
+ else
+ cp -ax ${S}/include/asm-${KERNEL_ARCH}/* ${D}/usr/include/asm
+ fi
+ fi
+}
+
+pkg_preinst() {
+ if [ "$PN" = "linux-headers" ]
+ then
+ [ -L ${ROOT}usr/include/linux ] && rm ${ROOT}usr/include/linux
+ [ -L ${ROOT}usr/include/asm ] && rm ${ROOT}usr/include/asm
+ [ -L ${ROOT}usr/include/asm-sparc ] && rm ${ROOT}usr/include/asm-sparc
+ [ -L ${ROOT}usr/include/asm- ] && rm ${ROOT}usr/include/asm-
+ [ -L ${ROOT}usr/include/asm-${KERNEL_ARCH} ] && rm ${ROOT}usr/include/asm-${KERNEL_ARCH}
+ true
+ fi
+}
+
+pkg_postinst() {
+ [ "$PN" = "linux-headers" ] && return
+ cd ${ROOT}usr/src/linux-${KV}
+ make mrproper
+ if [ -e "${ROOT}usr/src/linux/.config" ]
+ then
+ cp "${ROOT}usr/src/linux/.config" .config
+ #we only make dep when upgrading to a new kernel (with existing config)
+ #The default setting will be selected.
+ yes "" | make oldconfig
+ echo "Ignore any errors from the yes command above."
+ make dep
+ else
+ cp "${ROOT}usr/src/linux-${KV}/arch/${KERNEL_ARCH}/defconfig" .config \
+ || cp "${ROOT}usr/src/linux-${KV}/arch/i386/defconfig" .config
+ fi
+ #remove /usr/src/linux symlink
+ rm -f ${ROOT}/usr/src/linux
+ #set up a new one
+ ln -sf linux-${KV} ${ROOT}/usr/src/linux
+}