summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-06-02 07:18:35 +0000
committerHans de Graaff <graaff@gentoo.org>2011-06-02 07:18:35 +0000
commit6257d8fbf9e66215c985268a97cf035f062f85a2 (patch)
treefc49cc155074e480ad1d9e4cb243325f3187e3af
parentRemove old versions. (diff)
downloadhistorical-6257d8fbf9e66215c985268a97cf035f062f85a2.tar.gz
historical-6257d8fbf9e66215c985268a97cf035f062f85a2.tar.bz2
historical-6257d8fbf9e66215c985268a97cf035f062f85a2.zip
Version bump.
Package-Manager: portage-2.1.9.42/cvs/Linux x86_64
-rw-r--r--dev-ruby/gettext_i18n_rails/ChangeLog8
-rw-r--r--dev-ruby/gettext_i18n_rails/gettext_i18n_rails-0.2.20.ebuild32
-rw-r--r--dev-ruby/gherkin/ChangeLog7
-rw-r--r--dev-ruby/gherkin/gherkin-2.3.10.ebuild70
4 files changed, 115 insertions, 2 deletions
diff --git a/dev-ruby/gettext_i18n_rails/ChangeLog b/dev-ruby/gettext_i18n_rails/ChangeLog
index ddf68f0c274c..b5d1cef7932b 100644
--- a/dev-ruby/gettext_i18n_rails/ChangeLog
+++ b/dev-ruby/gettext_i18n_rails/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/gettext_i18n_rails
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gettext_i18n_rails/ChangeLog,v 1.1 2011/05/11 05:32:18 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gettext_i18n_rails/ChangeLog,v 1.2 2011/06/02 07:14:21 graaff Exp $
+
+*gettext_i18n_rails-0.2.20 (02 Jun 2011)
+
+ 02 Jun 2011; Hans de Graaff <graaff@gentoo.org>
+ +gettext_i18n_rails-0.2.20.ebuild:
+ Version bump.
*gettext_i18n_rails-0.2.19 (11 May 2011)
diff --git a/dev-ruby/gettext_i18n_rails/gettext_i18n_rails-0.2.20.ebuild b/dev-ruby/gettext_i18n_rails/gettext_i18n_rails-0.2.20.ebuild
new file mode 100644
index 000000000000..ef000c6defca
--- /dev/null
+++ b/dev-ruby/gettext_i18n_rails/gettext_i18n_rails-0.2.20.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gettext_i18n_rails/gettext_i18n_rails-0.2.20.ebuild,v 1.1 2011/06/02 07:14:21 graaff Exp $
+
+EAPI="4"
+
+# jruby support requires sqlite3 support for jruby.
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="Readme.md"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+
+RUBY_FAKEGEM_EXTRAINSTALL="init.rb VERSION"
+
+inherit ruby-fakegem
+
+DESCRIPTION="FastGettext / Rails integration."
+HOMEPAGE="https://github.com/grosser/gettext_i18n_rails"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/rspec:2 dev-ruby/activerecord )"
+ruby_add_rdepend "dev-ruby/fast_gettext"
+
+all_ruby_prepare() {
+ rm Gemfile Gemfile.lock || die
+}
diff --git a/dev-ruby/gherkin/ChangeLog b/dev-ruby/gherkin/ChangeLog
index c31ac5c31fc3..12bf48c01851 100644
--- a/dev-ruby/gherkin/ChangeLog
+++ b/dev-ruby/gherkin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/gherkin
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gherkin/ChangeLog,v 1.20 2011/05/29 07:01:05 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gherkin/ChangeLog,v 1.21 2011/06/02 07:18:35 graaff Exp $
+
+*gherkin-2.3.10 (02 Jun 2011)
+
+ 02 Jun 2011; Hans de Graaff <graaff@gentoo.org> +gherkin-2.3.10.ebuild:
+ Version bump.
*gherkin-2.3.9 (29 May 2011)
diff --git a/dev-ruby/gherkin/gherkin-2.3.10.ebuild b/dev-ruby/gherkin/gherkin-2.3.10.ebuild
new file mode 100644
index 000000000000..c642a6ea08f6
--- /dev/null
+++ b/dev-ruby/gherkin/gherkin-2.3.10.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gherkin/gherkin-2.3.10.ebuild,v 1.1 2011/06/02 07:18:35 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC="-Ilib -rgherkin/version -f tasks/rdoc.rake rdoc"
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Fast Gherkin lexer and parser based on Ragel."
+HOMEPAGE="http://wiki.github.com/aslakhellesoy/cucumber/gherkin"
+LICENSE="MIT"
+SRC_URI="https://github.com/cucumber/gherkin/tarball/v${PV} -> ${P}.tgz"
+
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE="doc test"
+
+DEPEND="${DEPEND} dev-util/ragel"
+RDEPEND="${RDEPEND}"
+
+S="${WORKDIR}/cucumber-gherkin-*"
+
+ruby_add_bdepend "
+ dev-ruby/rake-compiler
+ test? (
+ >=dev-ruby/awesome_print-0.4.0
+ >=dev-ruby/builder-2.1.2
+ >=dev-util/cucumber-0.10.0
+ >=dev-ruby/rspec-2.6.0
+ >=dev-ruby/term-ansicolor-1.0.5
+ )"
+
+ruby_add_rdepend ">=dev-ruby/json-1.4.6"
+
+all_ruby_prepare() {
+ # Remove Bundler-related things.
+ sed -i -e '/[Bb]undler/d' Rakefile spec/spec_helper.rb features/support/env.rb || die
+ rm Gemfile || die
+
+ # Don't use compile dependencies to avoid building again for specs.
+ sed -i -e '/:compile/d' Rakefile
+
+ # Remove feature that depends on direct access to the cucumber
+ # source. We could probably set this up by downloading the source
+ # and unpacking it, but skipping this now in the interest of time.
+ rm features/pretty_formatter.feature || die
+
+ # We need to remove this tasks during bootstrapping since it tries
+ # to load cucumber already but we can be sure it isn't installed
+ # yet.
+ if ! use test ; then
+ rm tasks/cucumber.rake || die "Unable to remove cucumber tasks."
+ fi
+}
+
+each_ruby_compile() {
+ ${RUBY} -I lib -S rake -rrake/clean -f tasks/compile.rake compile || die
+}
+
+each_ruby_test() {
+ ${RUBY} -S rake spec || die "Specs failed"
+ CUCUMBER_HOME="${HOME}" ${RUBY} -S rake cucumber || die "Cucumber features failed"
+}