summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabriele Giorgetti <stroke@gentoo.org>2002-07-13 16:12:21 +0000
committerGabriele Giorgetti <stroke@gentoo.org>2002-07-13 16:12:21 +0000
commit559b3a5cd7c2cb1745e0a08da68c0af2d366b56f (patch)
treeb9b732b119f67d037dd27ab0c76521e06bad3457
parentUnmasking WindowMaker build which doesn't require gnustep-env (diff)
downloadhistorical-559b3a5cd7c2cb1745e0a08da68c0af2d366b56f.tar.gz
historical-559b3a5cd7c2cb1745e0a08da68c0af2d366b56f.tar.bz2
historical-559b3a5cd7c2cb1745e0a08da68c0af2d366b56f.zip
New package, a Gnome2 applet
-rw-r--r--net-analyzer/netspeed_applet/ChangeLog9
-rw-r--r--net-analyzer/netspeed_applet/files/digest-netspeed_applet-0.21
-rw-r--r--net-analyzer/netspeed_applet/netspeed_applet-0.2.ebuild41
3 files changed, 51 insertions, 0 deletions
diff --git a/net-analyzer/netspeed_applet/ChangeLog b/net-analyzer/netspeed_applet/ChangeLog
new file mode 100644
index 000000000000..02b4d606bb2d
--- /dev/null
+++ b/net-analyzer/netspeed_applet/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for net-analyzer/netspeed_applet
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netspeed_applet/ChangeLog,v 1.1 2002/07/13 16:12:21 stroke Exp $
+
+*netspeed_applet-0.2 (13 Jul 2002)
+
+ 13 Jul 2002; Gabriele Giorgetti <stroke@gentoo.org> netspeed_applet-0.2.ebuild:
+
+ Initial CVS import.
diff --git a/net-analyzer/netspeed_applet/files/digest-netspeed_applet-0.2 b/net-analyzer/netspeed_applet/files/digest-netspeed_applet-0.2
new file mode 100644
index 000000000000..b8ae8bfc277a
--- /dev/null
+++ b/net-analyzer/netspeed_applet/files/digest-netspeed_applet-0.2
@@ -0,0 +1 @@
+MD5 3be69a7e50783e82ef540d2e77effbbc netspeed_applet-0.2.tar.gz 181967
diff --git a/net-analyzer/netspeed_applet/netspeed_applet-0.2.ebuild b/net-analyzer/netspeed_applet/netspeed_applet-0.2.ebuild
new file mode 100644
index 000000000000..d1dfe7a56702
--- /dev/null
+++ b/net-analyzer/netspeed_applet/netspeed_applet-0.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netspeed_applet/netspeed_applet-0.2.ebuild,v 1.1 2002/07/13 16:12:21 stroke Exp $
+
+DESCRIPTION="Applet showing network traffic for GNOME 2"
+HOMEPAGE="http://mfcn.ilo.de/netspeed_applet/"
+SRC_URI="http://mfcn.ilo.de/netspeed_applet/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND=">=x11-libs/gtk+-2.0.5
+ >=gnome-base/libgnome-2.0.1
+ >=gnome-base/libgnomeui-2.0.1
+ >=gnome-base/libgtop-2.0.0-r1
+ >=gnome-base/gnome-applets-2.0.0-r1"
+
+RDEPEND="${DEPEND}
+ >=dev-util/intltool-0.22"
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+
+ emake || die
+
+}
+
+src_install () {
+
+ dodir /usr/share/pixmaps
+ make DESTDIR=${D} install || die
+ dodoc README NEWS ChangeLog COPYING AUTHORS INSTALL
+
+}