summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-11-07 17:34:55 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-11-07 17:34:55 +0000
commit47c65a1f58069624d1b753fc959e3200a7690b93 (patch)
treed9275995f08d35742c607d31584cac726bcd3d12
parentFix to pyxml, add dep pypam, fixes Bug 367735, patch by Arfrever, repair to ... (diff)
downloadhistorical-47c65a1f58069624d1b753fc959e3200a7690b93.tar.gz
historical-47c65a1f58069624d1b753fc959e3200a7690b93.tar.bz2
historical-47c65a1f58069624d1b753fc959e3200a7690b93.zip
adding of tc-getLD, prepared by Ian Delaney aka idella4
Package-Manager: portage-2.2.0_alpha72/cvs/Linux x86_64
-rw-r--r--app-emulation/xen/ChangeLog6
-rw-r--r--app-emulation/xen/xen-4.1.1-r2.ebuild14
-rw-r--r--app-emulation/xen/xen-4.1.2.ebuild10
3 files changed, 17 insertions, 13 deletions
diff --git a/app-emulation/xen/ChangeLog b/app-emulation/xen/ChangeLog
index 55dd41e978b8..4977f2f6319b 100644
--- a/app-emulation/xen/ChangeLog
+++ b/app-emulation/xen/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/xen
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/ChangeLog,v 1.91 2011/11/01 10:14:55 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/ChangeLog,v 1.92 2011/11/07 17:34:55 alexxy Exp $
+
+ 07 Nov 2011; Alexey Shvetsov <alexxy@gentoo.org> xen-4.1.1-r2.ebuild,
+ xen-4.1.2.ebuild:
+ adding of tc-getLD, prepared by Ian Delaney aka idella4
01 Nov 2011; Tony Vroon <chainsaw@gentoo.org> xen-4.1.1-r2.ebuild:
Marked stable on AMD64 based on arch testing by Elijah "Armageddon" El
diff --git a/app-emulation/xen/xen-4.1.1-r2.ebuild b/app-emulation/xen/xen-4.1.1-r2.ebuild
index 3fbd39e086dc..448764292071 100644
--- a/app-emulation/xen/xen-4.1.1-r2.ebuild
+++ b/app-emulation/xen/xen-4.1.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/xen-4.1.1-r2.ebuild,v 1.4 2011/11/01 10:14:55 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/xen-4.1.1-r2.ebuild,v 1.5 2011/11/07 17:34:55 alexxy Exp $
EAPI="4"
@@ -71,14 +71,14 @@ src_prepare() {
-e 's/CFLAGS\(.*\)=\(.*\)-fomit-frame-pointer\(.*\)/CFLAGS\1=\2\3/' \
-e 's/CFLAGS\(.*\)=\(.*\)-g3*\s\(.*\)/CFLAGS\1=\2 \3/' \
-e 's/CFLAGS\(.*\)=\(.*\)-O2\(.*\)/CFLAGS\1=\2\3/' \
- -i {} \;
+ -i {} \; || die "failed to set custom-cflags"
fi
# remove -Werror for gcc-4.6's sake
find ${S} -name 'Makefile*' -o -name '*.mk' -o -name 'common.make' | \
- xargs sed -i 's/ *-Werror */ /'
- # not strictly necessary to fix this
- sed -i 's/, "-Werror"//' ${S}/tools/python/setup.py
+ xargs sed -i 's/ *-Werror */ /' || die "failed to remove -Werror"
+ # not strictly necessary to fix this
+ sed -i 's/, "-Werror"//' ${S}/tools/python/setup.py || die "failed to remove -Werror on setup.py"
# Add sccurity fix bug #379241
epatch "${FILESDIR}/${P}-iommu_sec_fix.patch"
@@ -98,7 +98,7 @@ src_configure() {
src_compile() {
# Send raw LDFLAGS so that --as-needed works
- emake CC="$(tc-getCC)" LDFLAGS="$(raw-ldflags)" -C xen ${myopt} || die "compile failed"
+ emake CC="$(tc-getCC)" LDFLAGS="$(raw-ldflags)" LD="$(tc-getLD)" -C xen ${myopt}
}
src_install() {
@@ -106,7 +106,7 @@ src_install() {
use debug && myopt="${myopt} debug=y"
use pae && myopt="${myopt} pae=y"
- emake LDFLAGS="$(raw-ldflags)" DESTDIR="${D}" -C xen ${myopt} install || die "install failed"
+ emake LDFLAGS="$(raw-ldflags)" DESTDIR="${D}" -C xen ${myopt} install
}
pkg_postinst() {
diff --git a/app-emulation/xen/xen-4.1.2.ebuild b/app-emulation/xen/xen-4.1.2.ebuild
index 3232699ec364..3bd3903cd9ad 100644
--- a/app-emulation/xen/xen-4.1.2.ebuild
+++ b/app-emulation/xen/xen-4.1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/xen-4.1.2.ebuild,v 1.1 2011/10/25 18:43:54 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/xen-4.1.2.ebuild,v 1.2 2011/11/07 17:34:55 alexxy Exp $
EAPI="4"
@@ -73,14 +73,14 @@ src_prepare() {
-e 's/CFLAGS\(.*\)=\(.*\)-fomit-frame-pointer\(.*\)/CFLAGS\1=\2\3/' \
-e 's/CFLAGS\(.*\)=\(.*\)-g3*\s\(.*\)/CFLAGS\1=\2 \3/' \
-e 's/CFLAGS\(.*\)=\(.*\)-O2\(.*\)/CFLAGS\1=\2\3/' \
- -i {} \;
+ -i {} \; || die "failed to re-set custom-cflags"
fi
# remove -Werror for gcc-4.6's sake
find "${S}" -name 'Makefile*' -o -name '*.mk' -o -name 'common.make' | \
xargs sed -i 's/ *-Werror */ /'
# not strictly necessary to fix this
- sed -i 's/, "-Werror"//' "${S}/tools/python/setup.py"
+ sed -i 's/, "-Werror"//' "${S}/tools/python/setup.py" || die "failed to re-set setup.py"
}
src_configure() {
@@ -97,7 +97,7 @@ src_configure() {
src_compile() {
# Send raw LDFLAGS so that --as-needed works
- emake CC="$(tc-getCC)" LDFLAGS="$(raw-ldflags)" -C xen ${myopt} || die "compile failed"
+ emake CC="$(tc-getCC)" LDFLAGS="$(raw-ldflags)" LD="$(tc-getLD)" -C xen ${myopt}
}
src_install() {
@@ -105,7 +105,7 @@ src_install() {
use debug && myopt="${myopt} debug=y"
use pae && myopt="${myopt} pae=y"
- emake LDFLAGS="$(raw-ldflags)" DESTDIR="${D}" -C xen ${myopt} install || die "install failed"
+ emake LDFLAGS="$(raw-ldflags)" DESTDIR="${ED}" -C xen ${myopt} install
}
pkg_postinst() {