summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthieu Sozeau <mattam@gentoo.org>2006-09-14 16:23:22 +0000
committerMatthieu Sozeau <mattam@gentoo.org>2006-09-14 16:23:22 +0000
commit47513b75b90596fb07b314d02498d6aa532668d5 (patch)
tree4864da46c877aaca138fed87ba5d8db9ab0cf7f8
parentVersion bump (fixes bug #141319 (diff)
downloadhistorical-47513b75b90596fb07b314d02498d6aa532668d5.tar.gz
historical-47513b75b90596fb07b314d02498d6aa532668d5.tar.bz2
historical-47513b75b90596fb07b314d02498d6aa532668d5.zip
Error commiting ebuild file
-rw-r--r--dev-ml/extlib/extlib-1.5.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-ml/extlib/extlib-1.5.ebuild b/dev-ml/extlib/extlib-1.5.ebuild
new file mode 100644
index 000000000000..438158d3e451
--- /dev/null
+++ b/dev-ml/extlib/extlib-1.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/extlib/extlib-1.5.ebuild,v 1.1 2006/09/14 16:23:22 mattam Exp $
+
+inherit findlib
+inherit eutils
+
+DESCRIPTION="Standard library extensions for O'Caml"
+HOMEPAGE="http://ocaml-lib.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ocaml-lib/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+DEPEND=">=dev-lang/ocaml-3.07"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~ppc-macos ~amd64"
+IUSE="doc"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-ExtList.remove.patch
+}
+
+src_compile() {
+ sed -i -e "s/IOO//" Makefile
+ make all opt
+
+ if use doc; then
+ make doc
+ fi
+}
+
+src_install () {
+ findlib_src_install
+
+ # install documentation
+ dodoc README.txt
+
+ if use doc; then
+ dohtml doc/*
+ fi
+}