summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTodd Berman <tberman@gentoo.org>2003-05-23 15:32:12 +0000
committerTodd Berman <tberman@gentoo.org>2003-05-23 15:32:12 +0000
commit425c72e1083f80cc50aeccb905e7c536d0a806e0 (patch)
tree769eeea6ccd11de87f781fd532d88d8bc653b15d
parentMoved, Closed bug #12702 (diff)
downloadhistorical-425c72e1083f80cc50aeccb905e7c536d0a806e0.tar.gz
historical-425c72e1083f80cc50aeccb905e7c536d0a806e0.tar.bz2
historical-425c72e1083f80cc50aeccb905e7c536d0a806e0.zip
Moved, Closed bug #12702
-rw-r--r--app-editors/jext/Manifest4
-rw-r--r--app-editors/jext/files/digest-jext-3.2_pre32
-rw-r--r--app-editors/jext/files/jext-gentoo.sh50
-rw-r--r--app-editors/jext/jext-3.2_pre3.ebuild39
4 files changed, 93 insertions, 2 deletions
diff --git a/app-editors/jext/Manifest b/app-editors/jext/Manifest
index 4452617c7d61..8ea9e641e61f 100644
--- a/app-editors/jext/Manifest
+++ b/app-editors/jext/Manifest
@@ -1,4 +1,4 @@
-MD5 c7de5f28bedf2eaad7c7047d684bce71 jext-3.2_pre3.ebuild 1077
-MD5 7c5b72c82c7ac71d39a97bad7c83e217 ChangeLog 395
+MD5 39846ff7a18d2f11c1ba6f6357ce9292 jext-3.2_pre3.ebuild 1178
+MD5 a5563c1c7007caa8205aba9ae81801a5 ChangeLog 485
MD5 1ab9c7aca4170a47e7b447839183fe32 files/digest-jext-3.2_pre3 138
MD5 ba19c214a7e8f8ccb21f74bc3b3b1626 files/jext-gentoo.sh 1351
diff --git a/app-editors/jext/files/digest-jext-3.2_pre3 b/app-editors/jext/files/digest-jext-3.2_pre3
new file mode 100644
index 000000000000..9f060a85e4b0
--- /dev/null
+++ b/app-editors/jext/files/digest-jext-3.2_pre3
@@ -0,0 +1,2 @@
+MD5 7de789ffe602f37b6b978439b3b048d1 jext-3.2pre3.tar.gz 2555439
+MD5 57c1482cda431e5d5d7338ddc6ca5724 jext-sources-3.2pre3.tar.gz 1004576
diff --git a/app-editors/jext/files/jext-gentoo.sh b/app-editors/jext/files/jext-gentoo.sh
new file mode 100644
index 000000000000..bac53dfb37a4
--- /dev/null
+++ b/app-editors/jext/files/jext-gentoo.sh
@@ -0,0 +1,50 @@
+#! /bin/sh
+#
+# This script launch the Jext the Java text editor.
+# It checks for a $HOME/.jext directory and eventually creates it.
+# Next it checks for a $HOME/.jext/variables file which define the JEXT_HOME JAVA_CMD and JAVA_OPT variables.
+# If this file doesn't exist the script creates it by asking the options to the user.
+
+
+# Sharpshooter 23/02/2002
+# Modified by Todd Berman <tberman@gentoo.org> 23/05/2003
+
+# Help
+
+if [ "$1" = "--help" ]
+then
+ echo "This script launch Jext the Java text editor."
+ echo "Usage : $0 [files]"
+ exit 0
+fi
+
+
+
+# Check for the user's ~/.jext directory.
+if ! [ -d ~/.jext ]
+then
+ echo "It seems you don't have a .jext directory in your home dir."
+ echo "I create it."
+ echo
+ mkdir -p ~/.jext/xinsert
+
+fi
+
+
+
+# Check for the $HOME/.jext/variables file.
+if ! [ -f ~/.jext/variables ]
+then
+ echo "JEXT_HOME="/usr/share/jext/lib > ~/.jext/variables
+ echo "JAVA_CMD="`java-config --java` >>~/.jext/variables
+fi
+
+
+# Extract the contents of the ~/.jext/variables file.
+JEXT_HOME=`grep JEXT_HOME ~/.jext/variables | cut -f2 -d=`
+JAVA_CMD=`grep JAVA_CMD ~/.jext/variables | cut -f2 -d=`
+JAVA_OPT=`grep JAVA_OPT ~/.jext/variables | cut -f2 -d=`
+
+
+# Launch JEXT
+exec "$JAVA_CMD" $JAVA_OPTS -Dpython=`java-config --classpath=jython` -classpath "`java-config --classpath=jython`:`java-config --classpath=jext`" org.jext.Jext "$@"
diff --git a/app-editors/jext/jext-3.2_pre3.ebuild b/app-editors/jext/jext-3.2_pre3.ebuild
new file mode 100644
index 000000000000..e6575b58bd89
--- /dev/null
+++ b/app-editors/jext/jext-3.2_pre3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jext/jext-3.2_pre3.ebuild,v 1.1 2003/05/23 15:32:06 tberman Exp $
+
+inherit java-pkg
+
+IUSE="doc"
+
+DESCRIPTION="A cool and fully featured editor in Java"
+HOMEPAGE="http://www.jext.org/"
+MY_PV="3.2pre3"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-${MY_PV}.tar.gz
+ mirror://sourceforge/${PN}/${PN}-sources-${MY_PV}.tar.gz"
+LICENSE="GPL-2 | JPython"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc"
+
+DEPEND=">=virtual/jdk-1.3
+ >=dev-java/ant-1.4.1
+ dev-java/jython"
+RDEPEND=">=virtual/jre-1.3"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+src_compile() {
+ cd ${WORKDIR}/jext-sources-3.2pre3/src
+ sed -e s:'<property name="classpath" value="" />':"<property name='classpath' value='`java-config --classpath=jython`' />": build.xml > tmp.xml
+ mv tmp.xml build.xml
+ ant jar javadocs -quiet > /dev/null || die
+}
+
+src_install () {
+ java-pkg_dojar ${WORKDIR}/jext-sources-3.2pre3/lib/*.jar
+ exeinto /usr/bin
+ newexe ${FILESDIR}/jext-gentoo.sh jext
+ if [ -n "`use doc`" ]; then
+ dohtml -A .css .gif .jpg -r ${WORKDIR}/jext-sources-3.2pre3/docs/api
+ fi
+}