summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2008-02-04 08:30:59 +0000
committerBenedikt Boehm <hollow@gentoo.org>2008-02-04 08:30:59 +0000
commit2a1c5723f7d5db9cf3c9fa67ba6d36493b09c3ac (patch)
tree698c96fe3a7cd960507507b088a737888455fa6f
parentfixed QA issues and added additional tools via use flag (diff)
downloadhistorical-2a1c5723f7d5db9cf3c9fa67ba6d36493b09c3ac.tar.gz
historical-2a1c5723f7d5db9cf3c9fa67ba6d36493b09c3ac.tar.bz2
historical-2a1c5723f7d5db9cf3c9fa67ba6d36493b09c3ac.zip
merge from webapps overlay wrt #208584
Package-Manager: portage-2.1.4
-rw-r--r--www-apps/mod_survey/ChangeLog11
-rw-r--r--www-apps/mod_survey/mod_survey-3.2.4.ebuild92
-rw-r--r--www-apps/moregroupware/ChangeLog12
-rw-r--r--www-apps/moregroupware/moregroupware-0.7.2.ebuild22
-rw-r--r--www-apps/moregroupware/moregroupware-0.7.4.ebuild22
-rw-r--r--www-apps/phpwiki/ChangeLog12
-rw-r--r--www-apps/phpwiki/phpwiki-1.3.14.ebuild41
7 files changed, 129 insertions, 83 deletions
diff --git a/www-apps/mod_survey/ChangeLog b/www-apps/mod_survey/ChangeLog
index ae970bf2c18d..a361f3b12b80 100644
--- a/www-apps/mod_survey/ChangeLog
+++ b/www-apps/mod_survey/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-apps/mod_survey
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/mod_survey/ChangeLog,v 1.3 2007/07/29 17:30:56 phreak Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mod_survey/ChangeLog,v 1.4 2008/02/04 08:24:04 hollow Exp $
+
+ 04 Feb 2008; Benedikt Böhm <hollow@gentoo.org> mod_survey-3.2.4.ebuild:
+ merge from webapps overlay wrt #208584
+
+ 02 Feb 2008; Jakub Moc <jakub@gentoo.org> mod_survey-3.2.4.ebuild:
+ Nuke unneeded apache dependency already implied by mod_perl for Bug 208584.
+ Fix LINGUAS handling, fix dosed, fix quoting, ebuild clean-up.
29 Jul 2007; Christian Heim <phreak@gentoo.org> mod_survey-3.2.4.ebuild:
Fixing the DEPEND/RDEPEND for the move of net-www/apache to
diff --git a/www-apps/mod_survey/mod_survey-3.2.4.ebuild b/www-apps/mod_survey/mod_survey-3.2.4.ebuild
index 86ff9b4592ce..490c690ea658 100644
--- a/www-apps/mod_survey/mod_survey-3.2.4.ebuild
+++ b/www-apps/mod_survey/mod_survey-3.2.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/mod_survey/mod_survey-3.2.4.ebuild,v 1.3 2007/07/29 17:30:56 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mod_survey/mod_survey-3.2.4.ebuild,v 1.4 2008/02/04 08:24:04 hollow Exp $
inherit webapp
@@ -10,53 +10,65 @@ SLOT="0"
DESCRIPTION="XML-defined web questionnaires as a plug-in module using Apache."
HOMEPAGE="http://www.modsurvey.org"
KEYWORDS="~amd64 ~ppc ~x86"
-
IUSE="doc mysql nls postgres"
+
+# Note: sw is invalid LINGUAS value, it should be sv instead.
+# commented out since I have zero interested in sed-ing the code
+# for this screw-up.
+LANGS="en de fr it" # sv
+for i in ${LANGS} ; do
+ IUSE="${IUSE} linguas_${i}"
+done
+
MY_PN=${PN/_/}
MY_PV=${PV/_/-}
S=${WORKDIR}/${PN}
SRC_URI="http://www.modsurvey.org/download/tarballs/${MY_PN}-${MY_PV}.tgz
-doc? ( http://www.modsurvey.org/download/tarballs/${MY_PN}-docs-${MY_PV}.tgz )"
+ doc? ( http://www.modsurvey.org/download/tarballs/${MY_PN}-docs-${MY_PV}.tgz )"
DEPEND=">=dev-lang/perl-5.6.1"
RDEPEND="${DEPEND}
- >=www-servers/apache-2 >=www-apache/mod_perl-1.99
+ >=www-apache/mod_perl-1.99
postgres? ( >=dev-perl/DBI-1.38 dev-perl/DBD-Pg )
mysql? ( >=dev-perl/DBI-1.38 dev-perl/DBD-mysql )
>=virtual/perl-CGI-3.0.0"
LICENSE="GPL-2"
pkg_setup() {
- webapp_pkg_setup
-
- # stolen from app-admin/webalizer
- # USE=nls has no real meaning if LINGUAS isn't set
- if use nls && [[ -z "${LINGUAS}" ]] ; then
- ewarn "you must set LINGUAS in /etc/make.conf"
- ewarn "if you want to USE=nls"
- die "please either set LINGUAS or do not use nls"
+ # unfortunatly, this program only allows for one lang, so only the first
+ # supported entry in LINGUAS is used
+ if use nls ; then
+ for i in ${LINGUAS} ; do
+ if has linguas_${i} ${IUSE} ; then
+ if use linguas_${i} ; then
+ locallang="${i}"
+ ewarn "Due to the limitations of this package, it will be built"
+ ewarn "only with ${i} LINGUAS support. If this is not what"
+ ewarn "you intended, please place the language you desire"
+ ewarn "as _first_ in the list of LINGUAS in /etc/make.conf"
+ ewarn
+ break
+ fi
+ else
+ einfo "LINGUAS=${i} is not supported by ${P}"
+ shift
+ fi
+ done
fi
+ if [[ -z ${locallang} ]] ; then
+ use nls && ewarn "None of ${LINGUAS} supported, sorry. Will use English."
+ locallang="en"
+ fi
+ webapp_pkg_setup
}
src_unpack() {
unpack ${A}
cd "${S}"
rm -f docs/LICENSE.txt
+ sed "s|\$lang = \"en\"|\$lang = \"${locallang}\"|" -i installer.pl
sed -i "s|/usr/local/mod_survey/|${D}/usr/lib/mod_survey/|g" installer.pl
use doc && unpack ${MY_PN}-docs-${PV}.tgz
-
- # unfortunatly, this program only allows for one lang, so only the first
- # entry in LINGUAS is used
- if use nls ; then
- local locallang
- if ! grep -q ${LINGUAS:0:2} ${FILESDIR}/language-list.txt ; then
- ewarn "Language ${LINGUAS:0:2} is not supported, using English"
- else
- elog "Using language ${LINGUAS:0:2}"
- locallang="$(grep ^${LINGUAS:0:2} ${FILESDIR}/language-list.txt)"
- sed "s|\$lang = \"en\"|\$lang = \"${locallang}\"|" -i installer.pl
- fi
- fi
}
src_install() {
@@ -69,28 +81,16 @@ src_install() {
dodoc README.txt docs/*
perl installer.pl < /dev/null > /dev/null 2>&1
- dosed /usr/lib/mod_survey/survey.conf
- sed -i "s|/usr/lib/mod_survey/data/|/var/lib/mod_survey/data/|" ${D}/usr/lib/mod_survey/survey.conf
- mv ${D}/usr/lib/mod_survey/survey.conf ${D}/${MY_HOSTROOTDIR}/${PN}
+ dosed "s|/usr/lib/mod_survey/data/|/var/lib/mod_survey/data/|" /usr/lib/mod_survey/survey.conf
+
+ mv "${D}"/usr/lib/mod_survey/survey.conf "${D}"/${MY_HOSTROOTDIR}/${PN}
+ rm -rf "${D}"/usr/lib/mod_survey/webroot "${D}"/usr/lib/mod_survey/data
- rm -rf ${D}/usr/lib/mod_survey/webroot ${D}/usr/lib/mod_survey/data
- cp -R webroot/* ${D}/${MY_HTDOCSDIR}
+ cp -R webroot/* "${D}"/${MY_HTDOCSDIR}
- webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
- webapp_hook_script ${FILESDIR}/reconfig
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_hook_script "${FILESDIR}"/reconfig
webapp_src_install
- fowners apache:apache /var/lib/mod_survey/data
-}
-pkg_postinst(){
- if [[ ${#LINGUAS} -gt 2 ]] && use nls ; then
- ewarn
- ewarn "You have more than one language in LINGUAS"
- ewarn "Due to the limitations of this package, it was built"
- ewarn "only with ${LINGUAS:0:2} support. If this is not what"
- ewarn "you intended, please place the language you desire"
- ewarn "_first_ in the list of LINGUAS in /etc/make.conf"
- ewarn
- fi
- webapp_pkg_postinst
+ fowners apache:apache /var/lib/mod_survey/data
}
diff --git a/www-apps/moregroupware/ChangeLog b/www-apps/moregroupware/ChangeLog
index 682a47ea4cc3..66e814989801 100644
--- a/www-apps/moregroupware/ChangeLog
+++ b/www-apps/moregroupware/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for www-apps/moregroupware
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/moregroupware/ChangeLog,v 1.11 2007/07/29 17:31:44 phreak Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/moregroupware/ChangeLog,v 1.12 2008/02/04 08:27:50 hollow Exp $
+
+ 04 Feb 2008; Benedikt Böhm <hollow@gentoo.org>
+ moregroupware-0.7.2.ebuild, moregroupware-0.7.4.ebuild:
+ merge from webapps overlay wrt #208584
+
+ 02 Feb 2008; Jakub Moc <jakub@gentoo.org>
+ moregroupware-0.7.4.ebuild:
+ Remove apache dependency wrt Bug 208584, fix quoting.
29 Jul 2007; Christian Heim <phreak@gentoo.org>
moregroupware-0.7.2.ebuild, moregroupware-0.7.4.ebuild:
diff --git a/www-apps/moregroupware/moregroupware-0.7.2.ebuild b/www-apps/moregroupware/moregroupware-0.7.2.ebuild
index 8175fcc0834e..89764d8c0e0e 100644
--- a/www-apps/moregroupware/moregroupware-0.7.2.ebuild
+++ b/www-apps/moregroupware/moregroupware-0.7.2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/moregroupware/moregroupware-0.7.2.ebuild,v 1.8 2007/07/29 17:31:44 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/moregroupware/moregroupware-0.7.2.ebuild,v 1.9 2008/02/04 08:27:50 hollow Exp $
-inherit webapp
+inherit webapp depend.php
S=${WORKDIR}/${PN}
@@ -14,8 +14,14 @@ LICENSE="X11 GPL-2"
KEYWORDS="~x86 ppc"
IUSE=""
-RDEPEND="virtual/php
- www-servers/apache"
+RDEPEND="virtual/httpd-cgi"
+
+need_php
+
+pkg_setup() {
+ require_php_sapi_from apache2 cgi
+ webapp_pkg_setup
+}
src_install() {
webapp_src_preinst
@@ -24,10 +30,10 @@ src_install() {
dodoc docs/*
rm -rf docs
- cp -R . ${D}/${MY_HTDOCSDIR}
+ cp -R . "${D}"/${MY_HTDOCSDIR}
- webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
- webapp_hook_script ${FILESDIR}/reconfig
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_hook_script "${FILESDIR}"/reconfig
webapp_src_install
}
diff --git a/www-apps/moregroupware/moregroupware-0.7.4.ebuild b/www-apps/moregroupware/moregroupware-0.7.4.ebuild
index 5b53d668bf8b..85b90a5a9238 100644
--- a/www-apps/moregroupware/moregroupware-0.7.4.ebuild
+++ b/www-apps/moregroupware/moregroupware-0.7.4.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/moregroupware/moregroupware-0.7.4.ebuild,v 1.4 2007/07/29 17:31:44 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/moregroupware/moregroupware-0.7.4.ebuild,v 1.5 2008/02/04 08:27:50 hollow Exp $
-inherit webapp
+inherit webapp depend.php
S=${WORKDIR}/${PN}
@@ -14,18 +14,24 @@ LICENSE="X11 GPL-2"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
-RDEPEND="virtual/php
- www-servers/apache"
+RDEPEND="virtual/httpd-cgi"
+
+need_php
+
+pkg_setup() {
+ require_php_sapi_from apache2 cgi
+ webapp_pkg_setup
+}
src_install() {
webapp_src_preinst
dodoc ChangeLog INSTALL docs/NEWS* docs/TODO
- cp -R . ${D}/${MY_HTDOCSDIR}
+ cp -R . "${D}"/${MY_HTDOCSDIR}
- webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
- webapp_hook_script ${FILESDIR}/reconfig
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_hook_script "${FILESDIR}"/reconfig
webapp_src_install
}
diff --git a/www-apps/phpwiki/ChangeLog b/www-apps/phpwiki/ChangeLog
index c04ad97f3f73..cfdd610a414c 100644
--- a/www-apps/phpwiki/ChangeLog
+++ b/www-apps/phpwiki/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for www-apps/phpwiki
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/phpwiki/ChangeLog,v 1.23 2007/08/30 14:25:50 wrobel Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/phpwiki/ChangeLog,v 1.24 2008/02/04 08:30:59 hollow Exp $
+
+ 04 Feb 2008; Benedikt Böhm <hollow@gentoo.org> phpwiki-1.3.14.ebuild:
+ merge from webapps overlay wrt #208584
+
+ 02 Feb 2008; Jakub Moc <jakub@gentoo.org> phpwiki-1.3.14.ebuild:
+ Remove apache dependency wrt Bug 208584. Move php checks to pkg_setup where
+ they belong, and fix them up. Add use flags for databases. Fix quoting,
+ clean up the ebuild.
30 Aug 2007; <wrobel@gentoo.org> -files/phpwiki-1.3.10-xmlrpc.patch,
metadata.xml, -phpwiki-1.3.10-r3.ebuild, -phpwiki-1.3.13_rc1.ebuild:
diff --git a/www-apps/phpwiki/phpwiki-1.3.14.ebuild b/www-apps/phpwiki/phpwiki-1.3.14.ebuild
index 55710cffcc66..1aaa893148e4 100644
--- a/www-apps/phpwiki/phpwiki-1.3.14.ebuild
+++ b/www-apps/phpwiki/phpwiki-1.3.14.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/phpwiki/phpwiki-1.3.14.ebuild,v 1.2 2007/08/14 18:13:04 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/phpwiki/phpwiki-1.3.14.ebuild,v 1.3 2008/02/04 08:30:59 hollow Exp $
inherit webapp depend.php
@@ -10,33 +10,44 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
KEYWORDS="~amd64 ppc ~sparc ~x86"
-IUSE=""
-
-RDEPEND="virtual/php
- www-servers/apache"
+IUSE="msql mysql postgres"
+
+RDEPEND="virtual/httpd-cgi"
+need_php
+
+pkg_setup() {
+ local flags="pcre"
+ for f in msql mysql postgres ; do
+ use ${f} && flags="${flags} ${f}"
+ done
+ if ! PHPCHECKNODIE="yes" require_php_with_use ${flags} || \
+ ! PHPCHECKNODIE="yes" require_php_with_any_use apache2 cgi ; then
+ die "Re-install ${PHP_PKG} with ${flags} and at least one of apache2 or cgi."
+ fi
+ webapp_pkg_setup
+}
src_unpack() {
- require_php_with_use pcre
-
unpack ${A}
- cd ${S}
+ cd "${S}"
rm -f Makefile LICENSE
}
src_install() {
webapp_src_preinst
- cp -pPR * ${D}/${MY_HTDOCSDIR}
- rm -rf ${D}/${MY_HTDOCSDIR}/{doc,schemas,README,INSTALL,TODO,UPGRADING}
+ cp -pPR * "${D}/${MY_HTDOCSDIR}"
+ rm -rf "${D}/${MY_HTDOCSDIR}"/{doc,schemas,README,INSTALL,TODO,UPGRADING}
dodoc README INSTALL TODO UPGRADING doc/* schemas/*
# Create config file from distribution default, and fix up invalid defaults
- cd ${D}/${MY_HTDOCSDIR}/config
- sed "s:;DEBUG = 1:DEBUG = 0:" config-dist.ini > config.ini
+ dosed "s:;DEBUG = 1:DEBUG = 0:" "${MY_HTDOCSDIR}"/config/config-dist.ini
+ cd "${D}"/${MY_HTDOCSDIR}/config
+ cp config-dist.ini config.ini
- webapp_postinst_txt en ${FILESDIR}/postinstall-1.3-en.txt
- webapp_configfile ${MY_HTDOCSDIR}/config/config.ini
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-1.3-en.txt
+ webapp_configfile "${MY_HTDOCSDIR}"/config/config.ini
webapp_src_install
}