summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Weiler <pylon@gentoo.org>2003-07-10 09:47:26 +0000
committerLars Weiler <pylon@gentoo.org>2003-07-10 09:47:26 +0000
commit233b5f021de1422bb4dcbb4058231a0bd5f2e9c2 (patch)
tree048d1a66fcb6cbb51b48c27f7480bd4ba7f63acb
parentversion bump (diff)
downloadhistorical-233b5f021de1422bb4dcbb4058231a0bd5f2e9c2.tar.gz
historical-233b5f021de1422bb4dcbb4058231a0bd5f2e9c2.tar.bz2
historical-233b5f021de1422bb4dcbb4058231a0bd5f2e9c2.zip
version bump
-rw-r--r--app-emulation/mol/Manifest4
-rw-r--r--app-emulation/mol/files/digest-mol-0.9.69_pre31
-rw-r--r--app-emulation/mol/metadata.xml9
-rw-r--r--app-emulation/mol/mol-0.9.69_pre3.ebuild68
4 files changed, 80 insertions, 2 deletions
diff --git a/app-emulation/mol/Manifest b/app-emulation/mol/Manifest
index bc5ab3a969f5..e2a412891b44 100644
--- a/app-emulation/mol/Manifest
+++ b/app-emulation/mol/Manifest
@@ -1,8 +1,8 @@
-MD5 b573bb19c749a6de594484c2c444d7f4 ChangeLog 3762
+MD5 889a6f8389d7baf6e01850e110d008d9 ChangeLog 3759
MD5 3263d375abba2d098c636efc2b135ea5 metadata.xml 333
MD5 b7e52869ba5660f854a75db5a7746713 mol-0.9.69_pre1.ebuild 2323
MD5 a9bf5f05329cb83f1cf6727f79d151d7 mol-0.9.69_pre2.ebuild 2325
-MD5 7055607714d56186fc1aecb94e455a93 mol-0.9.69_pre3.ebuild 2259
+MD5 916962c262a207a28e8e9e9fa27f8538 mol-0.9.69_pre3.ebuild 2256
MD5 84c32ed763ae9c3851d03607a6bd1684 mol-0.9.68-r4.ebuild 2217
MD5 74a86e79153cbc402d0152b5144680f7 files/dhcpd-mol.conf.patch 455
MD5 105aff90cbe982385f05386a1b7acdd8 files/digest-mol-0.9.69_pre2 69
diff --git a/app-emulation/mol/files/digest-mol-0.9.69_pre3 b/app-emulation/mol/files/digest-mol-0.9.69_pre3
new file mode 100644
index 000000000000..b8eaa78fdac1
--- /dev/null
+++ b/app-emulation/mol/files/digest-mol-0.9.69_pre3
@@ -0,0 +1 @@
+MD5 b93db130b13d7a7631fcdc5943296855 mol-0.9.69_pre3.tar.bz2 2765800
diff --git a/app-emulation/mol/metadata.xml b/app-emulation/mol/metadata.xml
new file mode 100644
index 000000000000..6d8cee981a2a
--- /dev/null
+++ b/app-emulation/mol/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="utf-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ppc</herd>
+ <longdescription>
+ mac-on-linux -- Running Mac OS (X) from within Linux
+ </longdescription>
+ <maintainer><email>pylon@gentoo.org</email><name>Lars Weiler</name></maintainer>
+</pkgmetadata>
diff --git a/app-emulation/mol/mol-0.9.69_pre3.ebuild b/app-emulation/mol/mol-0.9.69_pre3.ebuild
new file mode 100644
index 000000000000..6fac5a586647
--- /dev/null
+++ b/app-emulation/mol/mol-0.9.69_pre3.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/mol-0.9.69_pre3.ebuild,v 1.1 2003/07/10 09:47:18 pylon Exp $
+
+inherit flag-o-matic
+
+S=${WORKDIR}/${P}
+DESCRIPTION="MOL (Mac-on-Linux) lets PPC users run MacOS (X) under Linux (rsync snapshot)"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+HOMEPAGE="http://www.maconlinux.net/"
+
+DEPEND=">=sys-apps/sed-4"
+RDEPEND="net-misc/dhcp
+ net-firewall/iptables"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~ppc -x86 -sparc -alpha -mips"
+IUSE=""
+
+src_compile() {
+
+ filter-flags -fsigned-char
+
+ # dhcp config fix and show dchpd messages on starting mol
+ cd ${S}
+ sed -i "s:#ddns-update-style:ddns-update-style:g" Doc/config/dhcpd-mol.conf || die
+ sed -i "s:DHCPD\ -q\ -cf:DHCPD\ -cf:g" Doc/config/tunconfig || die
+
+ ./autogen.sh
+ ./configure --prefix=/usr || die "This is a ppc-only package (time to buy that iBook, no?)"
+ make || die "Failed to compile MOL"
+ #make libimport || die "Failed to compile MOL"
+
+}
+
+src_install() {
+
+ emake DESTDIR=${D} install || die "Failed to install MOL"
+
+ dodoc 0README BUILDING COPYING COPYRIGHT CREDITS Doc/*
+
+}
+
+pkg_postinst() {
+ echo
+ einfo "Mac-on-Linux is now installed. To run, use the command startmol."
+ einfo "You might want to configure video modes first with molvconfig."
+ einfo "Other configuration is in /etc/molrc. For more info see:"
+ einfo " www.maconlinux.net"
+ einfo "Also try man molrc, man molvconfig, man startmol"
+ echo
+ einfo "For networking and sound you might install the drivers in the"
+ einfo "folder \"MOL-Install\" on your Mac OS X-Desktop."
+ echo
+ einfo "If errors with networking occur, make sure you have the following"
+ einfo "kernel functions enabled:"
+ einfo "For the dhcp server:"
+ einfo " Socket Filtering (CONFIG_FILTER)"
+ einfo " Packet Socket (CONFIG_PACKET)"
+ einfo "For NAT:"
+ einfo " Network packet filtering (CONFIG_NETFILTER)"
+ einfo " Connection tracking (CONFIG_IP_NF_CONNTRACK)"
+ einfo " IP tables support (CONFIG_IP_NF_IPTABLES)"
+ einfo " Packet filtering (CONFIG_IP_NF_FILTER)"
+ einfo " Full NAT (CONFIG_IP_NF_NAT)"
+ einfo " MASQUERADE target support (CONFIG_IP_NF_TARGET_MASQUERADE)"
+ echo
+}