summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2008-03-26 13:17:59 +0000
committerCaleb Tennis <caleb@gentoo.org>2008-03-26 13:17:59 +0000
commit208bb65a4062d7a1b3cd0ebe40c379e92342e6f8 (patch)
tree43e3589e59d835aa5cedbde2fca0fcbf3c3fb76d
parentAdded check for imagemagick's hdri useflag which breaks compilation (see bug ... (diff)
downloadhistorical-208bb65a4062d7a1b3cd0ebe40c379e92342e6f8.tar.gz
historical-208bb65a4062d7a1b3cd0ebe40c379e92342e6f8.tar.bz2
historical-208bb65a4062d7a1b3cd0ebe40c379e92342e6f8.zip
version bump
Package-Manager: portage-2.1.4.4
-rw-r--r--dev-db/postgresql/ChangeLog13
-rw-r--r--dev-db/postgresql/files/postgresql-8.2.7-gentoo.patch58
-rw-r--r--dev-db/postgresql/files/postgresql-8.2.7-no-test.patch12
-rw-r--r--dev-db/postgresql/files/postgresql-8.2.7-python-threads.patch50
-rw-r--r--dev-db/postgresql/files/postgresql-8.2.7-regress_fix.patch31
-rw-r--r--dev-db/postgresql/files/postgresql-8.2.7-regress_su.patch15
-rw-r--r--dev-db/postgresql/files/postgresql-8.2.7-sh.patch34
-rw-r--r--dev-db/postgresql/postgresql-8.2.7.ebuild235
8 files changed, 447 insertions, 1 deletions
diff --git a/dev-db/postgresql/ChangeLog b/dev-db/postgresql/ChangeLog
index f837d7a3d1cf..5a06b8f8749f 100644
--- a/dev-db/postgresql/ChangeLog
+++ b/dev-db/postgresql/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for dev-db/postgresql
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/ChangeLog,v 1.373 2008/01/20 00:07:25 mjolnir Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/ChangeLog,v 1.374 2008/03/26 13:17:58 caleb Exp $
+
+*postgresql-8.2.7 (26 Mar 2008)
+
+ 26 Mar 2008; Caleb Tennis <caleb@gentoo.org>
+ +files/postgresql-8.2.7-gentoo.patch,
+ +files/postgresql-8.2.7-no-test.patch,
+ +files/postgresql-8.2.7-python-threads.patch,
+ +files/postgresql-8.2.7-regress_fix.patch,
+ +files/postgresql-8.2.7-regress_su.patch,
+ +files/postgresql-8.2.7-sh.patch, +postgresql-8.2.7.ebuild:
+ Version bump
20 Jan 2008; Martin Jackson <mjolnir@gentoo.org>
-files/postgresql-7.3.19-cubeparse.patch,
diff --git a/dev-db/postgresql/files/postgresql-8.2.7-gentoo.patch b/dev-db/postgresql/files/postgresql-8.2.7-gentoo.patch
new file mode 100644
index 000000000000..6d47d2535980
--- /dev/null
+++ b/dev-db/postgresql/files/postgresql-8.2.7-gentoo.patch
@@ -0,0 +1,58 @@
+--- postgresql-8.2.3.orig/src/bin/Makefile 2006-03-05 16:58:50.000000000 +0100
++++ postgresql-8.2.3/src/bin/Makefile 2007-03-29 12:12:26.000000000 +0200
+@@ -14,7 +14,7 @@
+ include $(top_builddir)/src/Makefile.global
+
+ DIRS := initdb ipcclean pg_ctl pg_dump \
+- psql scripts pg_config pg_controldata pg_resetxlog
++ psql scripts pg_controldata pg_resetxlog
+ ifeq ($(PORTNAME), win32)
+ DIRS+=pgevent
+ endif
+--- postgresql-8.2.3.orig/src/interfaces/Makefile 2004-04-20 02:33:51.000000000 +0200
++++ postgresql-8.2.3/src/interfaces/Makefile 2007-03-29 12:14:01.000000000 +0200
+@@ -12,7 +12,7 @@
+ top_builddir = ../..
+ include $(top_builddir)/src/Makefile.global
+
+-DIRS := libpq ecpg
++DIRS := ecpg
+
+ ALLDIRS := $(DIRS)
+
+--- postgresql-8.2.3.orig/src/Makefile 2006-06-23 01:50:35.000000000 +0200
++++ postgresql-8.2.3/src/Makefile 2007-03-29 12:54:59.000000000 +0200
+@@ -18,12 +18,10 @@
+ $(MAKE) -C timezone $@
+ $(MAKE) -C backend $@
+ $(MAKE) -C backend/utils/mb/conversion_procs $@
+- $(MAKE) -C include $@
+ $(MAKE) -C interfaces $@
+ $(MAKE) -C bin $@
+ $(MAKE) -C pl $@
+ $(MAKE) -C makefiles $@
+- $(MAKE) -C test/regress $@
+
+ install: install-local
+
+@@ -47,7 +45,6 @@
+ $(MAKE) -C port $@
+ $(MAKE) -C timezone $@
+ $(MAKE) -C backend $@
+- $(MAKE) -C include $@
+ $(MAKE) -C interfaces $@
+ $(MAKE) -C bin $@
+ $(MAKE) -C pl $@
+@@ -60,12 +57,10 @@
+ -$(MAKE) -C port $@
+ -$(MAKE) -C timezone $@
+ -$(MAKE) -C backend $@
+- -$(MAKE) -C include $@
+ -$(MAKE) -C interfaces $@
+ -$(MAKE) -C bin $@
+ -$(MAKE) -C pl $@
+ -$(MAKE) -C makefiles $@
+- -$(MAKE) -C test $@
+ -$(MAKE) -C tutorial NO_PGXS=1 $@
+ -$(MAKE) -C test/thread $@
+ rm -f Makefile.port Makefile.global
diff --git a/dev-db/postgresql/files/postgresql-8.2.7-no-test.patch b/dev-db/postgresql/files/postgresql-8.2.7-no-test.patch
new file mode 100644
index 000000000000..0f887e28d22c
--- /dev/null
+++ b/dev-db/postgresql/files/postgresql-8.2.7-no-test.patch
@@ -0,0 +1,12 @@
+diff --git a/src/Makefile b/src/Makefile
+index 5eb7c4a..0f9fff0 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -22,7 +22,6 @@ all install installdirs uninstall dep de
+ $(MAKE) -C bin $@
+ $(MAKE) -C pl $@
+ $(MAKE) -C makefiles $@
+- $(MAKE) -C test/regress $@
+
+ install: install-local
+
diff --git a/dev-db/postgresql/files/postgresql-8.2.7-python-threads.patch b/dev-db/postgresql/files/postgresql-8.2.7-python-threads.patch
new file mode 100644
index 000000000000..520ba13a6473
--- /dev/null
+++ b/dev-db/postgresql/files/postgresql-8.2.7-python-threads.patch
@@ -0,0 +1,50 @@
+diff -ur a/config/python.m4 b/config/python.m4
+--- a/config/python.m4 2006-10-16 18:24:54 +0100
++++ b/config/python.m4 2007-08-17 15:37:00 +0100
+@@ -78,18 +78,4 @@
+ AC_SUBST(python_libspec)[]dnl
+ AC_SUBST(python_additional_libs)[]dnl
+
+-# threaded python is not supported on bsd's
+-AC_MSG_CHECKING(whether Python is compiled with thread support)
+-pythreads=`${PYTHON} -c "import sys; print int('thread' in sys.builtin_module_names)"`
+-if test "$pythreads" = "1"; then
+- AC_MSG_RESULT(yes)
+- case $host_os in
+- openbsd*|freebsd*)
+- AC_MSG_ERROR([threaded Python not supported on this platform])
+- ;;
+- esac
+-else
+- AC_MSG_RESULT(no)
+-fi
+-
+ ])# PGAC_CHECK_PYTHON_EMBED_SETUP
+diff -ur a/configure b/configure
+--- a/configure 2007-04-20 04:20:41 +0100
++++ b/configure 2007-08-17 15:37:20 +0100
+@@ -5002,24 +5002,6 @@
+ echo "${ECHO_T}${python_libspec} ${python_additional_libs}" >&6
+
+
+-# threaded python is not supported on bsd's
+-echo "$as_me:$LINENO: checking whether Python is compiled with thread support" >&5
+-echo $ECHO_N "checking whether Python is compiled with thread support... $ECHO_C" >&6
+-pythreads=`${PYTHON} -c "import sys; print int('thread' in sys.builtin_module_names)"`
+-if test "$pythreads" = "1"; then
+- echo "$as_me:$LINENO: result: yes" >&5
+-echo "${ECHO_T}yes" >&6
+- case $host_os in
+- openbsd*|freebsd*)
+- { { echo "$as_me:$LINENO: error: threaded Python not supported on this platform" >&5
+-echo "$as_me: error: threaded Python not supported on this platform" >&2;}
+- { (exit 1); exit 1; }; }
+- ;;
+- esac
+-else
+- echo "$as_me:$LINENO: result: no" >&5
+-echo "${ECHO_T}no" >&6
+-fi
+
+
+ fi
diff --git a/dev-db/postgresql/files/postgresql-8.2.7-regress_fix.patch b/dev-db/postgresql/files/postgresql-8.2.7-regress_fix.patch
new file mode 100644
index 000000000000..0af8c3fbfd80
--- /dev/null
+++ b/dev-db/postgresql/files/postgresql-8.2.7-regress_fix.patch
@@ -0,0 +1,31 @@
+diff --git a/src/test/regress/expected/interval.out b/src/test/regress/expected/interval.out
+index f7c35de..183a963 100644
+--- a/src/test/regress/expected/interval.out
++++ b/src/test/regress/expected/interval.out
+@@ -293,12 +293,6 @@ (10 rows)
+ -- test avg(interval), which is somewhat fragile since people have been
+ -- known to change the allowed input syntax for type interval without
+ -- updating pg_aggregate.agginitval
+-select avg(f1) from interval_tbl;
+- avg
+--------------------------------------------------
+- @ 4 years 1 mon 10 days 4 hours 18 mins 23 secs
+-(1 row)
+-
+ -- test long interval input
+ select '4 millenniums 5 centuries 4 decades 1 year 4 months 4 days 17 minutes 31 seconds'::interval;
+ interval
+diff --git a/src/test/regress/sql/interval.sql b/src/test/regress/sql/interval.sql
+index 9b2e625..cb44d12 100644
+--- a/src/test/regress/sql/interval.sql
++++ b/src/test/regress/sql/interval.sql
+@@ -101,9 +101,6 @@ SELECT '' AS ten, * FROM INTERVAL_TBL;
+ -- test avg(interval), which is somewhat fragile since people have been
+ -- known to change the allowed input syntax for type interval without
+ -- updating pg_aggregate.agginitval
+-
+-select avg(f1) from interval_tbl;
+-
+ -- test long interval input
+ select '4 millenniums 5 centuries 4 decades 1 year 4 months 4 days 17 minutes 31 seconds'::interval;
+
diff --git a/dev-db/postgresql/files/postgresql-8.2.7-regress_su.patch b/dev-db/postgresql/files/postgresql-8.2.7-regress_su.patch
new file mode 100644
index 000000000000..83c56d7ab100
--- /dev/null
+++ b/dev-db/postgresql/files/postgresql-8.2.7-regress_su.patch
@@ -0,0 +1,15 @@
+diff --git a/src/test/regress/GNUmakefile b/src/test/regress/GNUmakefile
+index f2319d2..b14a6f0 100644
+--- a/src/test/regress/GNUmakefile
++++ b/src/test/regress/GNUmakefile
+@@ -148,7 +148,8 @@ ##
+ check: all
+ -rm -rf ./testtablespace
+ mkdir ./testtablespace
+- ./pg_regress --temp-install=./tmp_check --top-builddir=$(top_builddir) --temp-port=$(TEMP_PORT) --schedule=$(srcdir)/parallel_schedule --multibyte=$(MULTIBYTE) --load-language=plpgsql $(MAXCONNOPT) $(NOLOCALE)
++ chown portage testtablespace .
++ su -s /bin/sh portage -c "./pg_regress --psqldir=`pwd`/../../bin/psql --temp-install=./tmp_check --top-builddir=$(top_builddir) --temp-port=$(TEMP_PORT) --schedule=$(srcdir)/parallel_schedule --multibyte=$(MULTIBYTE) --load-language=plpgsql $(MAXCONNOPT) $(NOLOCALE)"
+
+ installcheck: all
+ -rm -rf ./testtablespace
+diff --git a/src/test/regress/pg_regress.c b/src/test/regress/pg_regress.c
diff --git a/dev-db/postgresql/files/postgresql-8.2.7-sh.patch b/dev-db/postgresql/files/postgresql-8.2.7-sh.patch
new file mode 100644
index 000000000000..295bb6cfb600
--- /dev/null
+++ b/dev-db/postgresql/files/postgresql-8.2.7-sh.patch
@@ -0,0 +1,34 @@
+--- postgresql-8.2.3.orig/src/include/storage/s_lock.h 2006-06-08 00:24:45.000000000 +0200
++++ postgresql-8.2.3/src/include/storage/s_lock.h 2007-03-29 12:25:56.000000000 +0200
+@@ -299,6 +299,31 @@
+ #endif /* __s390__ || __s390x__ */
+
+
++#if defined(__sh__)
++#define HAS_TEST_AND_SET
++
++typedef unsigned char slock_t;
++
++#define TAS(lock) tas(lock)
++
++static __inline__ int
++tas(volatile slock_t *lock)
++{
++ register int _res = 1;
++
++ __asm__ __volatile__(
++ "tas.b @%1\n\t"
++ "movt %0\n\t"
++ "xor #1,%0"
++: "=z"(_res)
++: "r"(lock)
++: "t","memory");
++ return _res;
++}
++
++#endif /* __sh__ */
++
++
+ #if defined(__sparc__) /* Sparc */
+ #define HAS_TEST_AND_SET
+
diff --git a/dev-db/postgresql/postgresql-8.2.7.ebuild b/dev-db/postgresql/postgresql-8.2.7.ebuild
new file mode 100644
index 000000000000..3bc862aac31f
--- /dev/null
+++ b/dev-db/postgresql/postgresql-8.2.7.ebuild
@@ -0,0 +1,235 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-8.2.7.ebuild,v 1.1 2008/03/26 13:17:58 caleb Exp $
+
+inherit eutils flag-o-matic multilib toolchain-funcs versionator
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+
+DESCRIPTION="Sophisticated and powerful Object-Relational DBMS."
+HOMEPAGE="http://www.postgresql.org/"
+SRC_URI="mirror://postgresql/source/v${PV}/${PN}-${PV}.tar.bz2"
+LICENSE="POSTGRESQL"
+SLOT="0"
+IUSE="doc kerberos kernel_linux nls pam perl pg-intdatetime python readline selinux ssl tcl test xml zlib"
+
+RDEPEND="~dev-db/libpq-${PV}
+ >=sys-libs/ncurses-5.2
+ kerberos? ( virtual/krb5 )
+ pam? ( virtual/pam )
+ perl? ( >=dev-lang/perl-5.6.1-r2 )
+ python? ( >=dev-lang/python-2.2 dev-python/egenix-mx-base )
+ readline? ( >=sys-libs/readline-4.1 )
+ selinux? ( sec-policy/selinux-postgresql )
+ ssl? ( >=dev-libs/openssl-0.9.6-r1 )
+ tcl? ( >=dev-lang/tcl-8 )
+ xml? ( dev-libs/libxml2 dev-libs/libxslt )
+ zlib? ( >=sys-libs/zlib-1.1.3 )"
+DEPEND="${RDEPEND}
+ sys-devel/autoconf
+ >=sys-devel/bison-1.875
+ nls? ( sys-devel/gettext )
+ xml? ( dev-util/pkgconfig )"
+
+PG_DIR="/var/lib/postgresql"
+[[ -z "${PG_MAX_CONNECTIONS}" ]] && PG_MAX_CONNECTIONS="512"
+
+pkg_setup() {
+ if [[ -f "${PG_DIR}/data/PG_VERSION" ]] ; then
+ if [[ $(cat "${PG_DIR}/data/PG_VERSION") != $(get_version_component_range 1-2) ]] ; then
+ eerror "PostgreSQL ${PV} cannot upgrade your existing databases, you must"
+ eerror "use pg_dump to export your existing databases to a file, and then"
+ eerror "pg_restore to import them when you have upgraded completely."
+ eerror "You must remove your entire database directory to continue."
+ eerror "(database directory = ${PG_DIR})."
+ die "Remove your database directory to continue"
+ fi
+ fi
+ enewgroup postgres 70
+ enewuser postgres 70 /bin/bash /var/lib postgres
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-${PV}-gentoo.patch"
+ epatch "${FILESDIR}/${PN}-${PV}-sh.patch"
+
+ # Prepare package for future tests
+ if use test ; then
+ # Fix sandbox violation
+ sed -e "s|/no/such/location|${S}/src/test/regress/tmp_check/no/such/location|g" -i src/test/regress/{input,output}/tablespace.source
+
+ # Fix broken tests
+ epatch "${FILESDIR}/${PN}-${PV}-regress_fix.patch"
+
+ # We need to run the tests as a non-root user, portage seems the most fitting here,
+ # so if userpriv is enabled, we use it directly. If userpriv is disabled, we need to
+ # su - to a valid user, portage again, so we patch the test-scripts to do that.
+ mkdir -p "${S}/src/test/regress/tmp_check"
+ chown portage "${S}/src/test/regress/tmp_check"
+ einfo "Tests will be run as user portage."
+ if ! hasq userpriv ${FEATURES} ; then
+ mkdir -p "${S}/src/test/regress/results"
+ chown portage "${S}/src/test/regress/results"
+ epatch "${FILESDIR}/${PN}-${PV}-regress_su.patch"
+ fi
+ fi
+}
+
+src_compile() {
+ filter-flags -ffast-math -feliminate-dwarf2-dups
+
+ econf --prefix=/usr \
+ --includedir=/usr/include/postgresql/pgsql \
+ --sysconfdir=/etc/postgresql \
+ --mandir=/usr/share/man \
+ --host=${CHOST} \
+ --with-docdir=/usr/share/doc/${PF} \
+ --libdir=/usr/$(get_libdir) \
+ --enable-depend \
+ $(use_with kerberos krb5) \
+ $(use_enable nls ) \
+ $(use_with pam) \
+ $(use_with perl) \
+ $(use_enable pg-intdatetime integer-datetimes ) \
+ $(use_with python) \
+ $(use_with readline) \
+ $(use_with ssl openssl) \
+ $(use_with tcl) \
+ $(use_with zlib) \
+ || die "configure failed"
+
+ emake -j1 LD="$(tc-getLD) $(get_abi_LDFLAGS)" || die "main emake failed"
+
+ cd "${S}/contrib"
+ emake -j1 LD="$(tc-getLD) $(get_abi_LDFLAGS)" || die "contrib emake failed"
+
+ if use xml ; then
+ cd "${S}/contrib/xml2"
+ emake -j1 LD="$(tc-getLD) $(get_abi_LDFLAGS)" || die "contrib/xml2 emake failed"
+ fi
+}
+
+src_install() {
+ if use perl ; then
+ mv -f "${S}/src/pl/plperl/GNUmakefile" "${S}/src/pl/plperl/GNUmakefile_orig"
+ sed -e "s:\$(DESTDIR)\$(plperl_installdir):\$(plperl_installdir):" \
+ "${S}/src/pl/plperl/GNUmakefile_orig" > "${S}/src/pl/plperl/GNUmakefile"
+ fi
+
+ cd "${S}"
+ emake -j1 DESTDIR="${D}" LIBDIR="${D}/usr/$(get_libdir)" install || die "main emake install failed"
+
+ cd "${S}/contrib"
+ emake -j1 DESTDIR="${D}" LIBDIR="${D}/usr/$(get_libdir)" install || die "contrib emake install failed"
+
+ if use xml ; then
+ cd "${S}/contrib/xml2"
+ emake -j1 DESTDIR="${D}" LIBDIR="${D}/usr/$(get_libdir)" install || die "contrib/xml2 emake install failed"
+ fi
+
+ cd "${S}"
+ dodoc README HISTORY
+
+ cd "${S}/doc"
+ dodoc FAQ* README.* TODO bug.template
+
+ if use doc ; then
+ cd "${S}/doc"
+ docinto FAQ_html
+ dodoc src/FAQ/*
+ docinto sgml
+ dodoc src/sgml/*.{sgml,dsl}
+ docinto sgml/ref
+ dodoc src/sgml/ref/*.sgml
+ docinto TODO.detail
+ dodoc TODO.detail/*
+ fi
+
+ newinitd "${FILESDIR}/postgresql.init-${PV%.*}" postgresql || die "Inserting init.d-file failed"
+ newconfd "${FILESDIR}/postgresql.conf-${PV%.*}" postgresql || die "Inserting conf.d-file failed"
+}
+
+pkg_postinst() {
+ elog "Execute the following command to setup the initial database environment:"
+ elog
+ elog "emerge --config =${PF}"
+ elog
+ elog "The autovacuum function, which was in contrib, has been moved to the main"
+ elog "PostgreSQL functions starting with 8.1."
+ elog "You can enable it in ${ROOT}/etc/postgresql/postgresql.conf."
+ elog
+ elog "If you need a global psqlrc-file, you can place it in '${ROOT}/etc/postgresql/'."
+}
+
+pkg_config() {
+ einfo "Creating the data directory ..."
+ mkdir -p "${PG_DIR}/data"
+ chown -Rf postgres:postgres "${PG_DIR}"
+ chmod 0700 "${PG_DIR}/data"
+
+ einfo "Initializing the database ..."
+ if [[ -f "${PG_DIR}/data/PG_VERSION" ]] ; then
+ eerror "PostgreSQL ${PV} cannot upgrade your existing databases."
+ eerror "You must remove your entire database directory to continue."
+ eerror "(database directory = ${PG_DIR})."
+ die "Remove your database directory to continue"
+ else
+ if use kernel_linux ; then
+ local SEM=`sysctl -n kernel.sem | cut -f-3`
+ local SEMMNI=`sysctl -n kernel.sem | cut -f4`
+ local SEMMNI_MIN=`expr \( ${PG_MAX_CONNECTIONS} + 15 \) / 16`
+ local SHMMAX=`sysctl -n kernel.shmmax`
+ local SHMMAX_MIN=`expr 500000 + 30600 \* ${PG_MAX_CONNECTIONS}`
+
+ if [ ${SEMMNI} -lt ${SEMMNI_MIN} ] ; then
+ eerror "The current value of SEMMNI is too low"
+ eerror "for PostgreSQL to run ${PG_MAX_CONNECTIONS} connections!"
+ eerror "Temporary setting this value to ${SEMMNI_MIN} while creating the initial database."
+ echo ${SEM} ${SEMMNI_MIN} > /proc/sys/kernel/sem
+ fi
+
+ su postgres -c "/usr/bin/initdb --pgdata ${PG_DIR}/data"
+
+ if [ ! `sysctl -n kernel.sem | cut -f4` -eq ${SEMMNI} ] ; then
+ echo ${SEM} ${SEMMNI} > /proc/sys/kernel/sem
+ ewarn "Restoring the SEMMNI value to the previous value."
+ ewarn "Please edit the last value of kernel.sem in /etc/sysctl.conf"
+ ewarn "and set it to at least ${SEMMNI_MIN}:"
+ ewarn
+ ewarn " kernel.sem = ${SEM} ${SEMMNI_MIN}"
+ ewarn
+ fi
+
+ if [ ${SHMMAX} -lt ${SHMMAX_MIN} ] ; then
+ eerror "The current value of SHMMAX is too low for postgresql to run."
+ eerror "Please edit /etc/sysctl.conf and set this value to at least ${SHMMAX_MIN}:"
+ eerror
+ eerror " kernel.shmmax = ${SHMMAX_MIN}"
+ eerror
+ fi
+ else
+ su postgres -c "/usr/bin/initdb --pgdata ${PG_DIR}/data"
+ fi
+
+ einfo
+ einfo "You can use the '${ROOT}/etc/init.d/postgresql' script to run PostgreSQL instead of 'pg_ctl'."
+ einfo
+ fi
+}
+
+src_test() {
+ einfo ">>> Test phase [check]: ${CATEGORY}/${PF}"
+ if ! emake -j1 check ; then
+ hasq test ${FEATURES} && die "Make check failed. See above for details."
+ hasq test ${FEATURES} || eerror "Make check failed. See above for details."
+ fi
+
+ einfo "Yes, there are other tests which could be run."
+ einfo "... and no, we don't plan to add/support them."
+ einfo "For now, the main regressions tests will suffice."
+ einfo "If you think other tests are necessary, please submit a"
+ einfo "bug including a patch for this ebuild to enable them."
+}