summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2011-08-04 21:03:17 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2011-08-04 21:03:17 +0000
commit063e8144d4aef74f19c05136427f3855618a2116 (patch)
tree737eb5366a71e39df3827f525bf47e5dc98f1c0b
parentAnd apparently now it turns out --without-network doesn't just disable the vi... (diff)
downloadhistorical-063e8144d4aef74f19c05136427f3855618a2116.tar.gz
historical-063e8144d4aef74f19c05136427f3855618a2116.tar.bz2
historical-063e8144d4aef74f19c05136427f3855618a2116.zip
dev-vcs/darcs: version bump (and it's minimal depends)
Package-Manager: portage-2.1.10.10/cvs/Linux x86_64
-rw-r--r--dev-haskell/hashed-storage/ChangeLog8
-rw-r--r--dev-haskell/hashed-storage/files/hashed-storage-0.5.7-ghc-7.2.patch20
-rw-r--r--dev-haskell/hashed-storage/hashed-storage-0.5.7.ebuild46
-rw-r--r--dev-haskell/mmap/ChangeLog7
-rw-r--r--dev-haskell/mmap/mmap-0.5.7.ebuild43
5 files changed, 122 insertions, 2 deletions
diff --git a/dev-haskell/hashed-storage/ChangeLog b/dev-haskell/hashed-storage/ChangeLog
index 0fd180724358..ab2821fcbea8 100644
--- a/dev-haskell/hashed-storage/ChangeLog
+++ b/dev-haskell/hashed-storage/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/hashed-storage
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hashed-storage/ChangeLog,v 1.12 2011/08/04 13:17:35 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hashed-storage/ChangeLog,v 1.13 2011/08/04 21:03:16 slyfox Exp $
+
+*hashed-storage-0.5.7 (04 Aug 2011)
+
+ 04 Aug 2011; Sergei Trofimovich <slyfox@gentoo.org>
+ +hashed-storage-0.5.7.ebuild, +files/hashed-storage-0.5.7-ghc-7.2.patch:
+ Version bump.
04 Aug 2011; Sergei Trofimovich <slyfox@gentoo.org>
-hashed-storage-0.4.10.ebuild:
diff --git a/dev-haskell/hashed-storage/files/hashed-storage-0.5.7-ghc-7.2.patch b/dev-haskell/hashed-storage/files/hashed-storage-0.5.7-ghc-7.2.patch
new file mode 100644
index 000000000000..01940fe44596
--- /dev/null
+++ b/dev-haskell/hashed-storage/files/hashed-storage-0.5.7-ghc-7.2.patch
@@ -0,0 +1,20 @@
+diff --git a/Storage/Hashed/Monad.hs b/Storage/Hashed/Monad.hs
+index b86a702..5d96d4d 100644
+--- a/Storage/Hashed/Monad.hs
++++ b/Storage/Hashed/Monad.hs
+@@ -1,4 +1,5 @@
+ {-# LANGUAGE ScopedTypeVariables, BangPatterns, TypeSynonymInstances, UndecidableInstances #-}
++{-# LANGUAGE FlexibleInstances #-}
+
+ -- | An experimental monadic interface to Tree mutation. The main idea is to
+ -- simulate IO-ish manipulation of real filesystem (that's the state part of
+diff --git a/Storage/Hashed/Tree.hs b/Storage/Hashed/Tree.hs
+index 0bef0e6..c4bb669 100644
+--- a/Storage/Hashed/Tree.hs
++++ b/Storage/Hashed/Tree.hs
+@@ -1,4 +1,5 @@
+ {-# LANGUAGE ScopedTypeVariables, MultiParamTypeClasses, FlexibleInstances #-}
++{-# LANGUAGE BangPatterns #-}
+
+ -- | The abstract representation of a Tree and useful abstract utilities to
+ -- handle those.
diff --git a/dev-haskell/hashed-storage/hashed-storage-0.5.7.ebuild b/dev-haskell/hashed-storage/hashed-storage-0.5.7.ebuild
new file mode 100644
index 000000000000..205785bb504f
--- /dev/null
+++ b/dev-haskell/hashed-storage/hashed-storage-0.5.7.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hashed-storage/hashed-storage-0.5.7.ebuild,v 1.1 2011/08/04 21:03:16 slyfox Exp $
+
+# ebuild generated by hackport 0.2.13
+
+EAPI="3"
+
+CABAL_FEATURES="bin lib profile haddock hscolour"
+inherit base haskell-cabal
+
+DESCRIPTION="Hashed file storage support code."
+HOMEPAGE="http://hackage.haskell.org/package/hashed-storage"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="test"
+
+RDEPEND="dev-haskell/binary
+ dev-haskell/dataenc
+ =dev-haskell/mmap-0.5*
+ dev-haskell/mtl
+ dev-haskell/zlib
+ >=dev-lang/ghc-6.12"
+DEPEND=">=dev-haskell/cabal-1.6
+ test? (
+ dev-haskell/test-framework
+ dev-haskell/test-framework-hunit
+ dev-haskell/test-framework-quickcheck2
+ dev-haskell/zip-archive
+ )
+ ${RDEPEND}"
+
+PATCHES=("${FILESDIR}/${PN}-0.5.7-ghc-7.2.patch")
+
+src_configure() {
+ cabal_src_configure $(cabal_flag test)
+}
+
+src_install() {
+ haskell-cabal_src_install
+
+ use test && rm "${D}/usr/bin/hashed-storage-test"
+}
diff --git a/dev-haskell/mmap/ChangeLog b/dev-haskell/mmap/ChangeLog
index 30dc8334dffd..2f377efcc4b5 100644
--- a/dev-haskell/mmap/ChangeLog
+++ b/dev-haskell/mmap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/mmap
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/mmap/ChangeLog,v 1.12 2011/04/10 18:56:58 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/mmap/ChangeLog,v 1.13 2011/08/04 21:03:16 slyfox Exp $
+
+*mmap-0.5.7 (04 Aug 2011)
+
+ 04 Aug 2011; Sergei Trofimovich <slyfox@gentoo.org> +mmap-0.5.7.ebuild:
+ Version bump.
10 Apr 2011; Fabian Groffen <grobian@gentoo.org> mmap-0.4.1.ebuild:
Marked ~x86-macos
diff --git a/dev-haskell/mmap/mmap-0.5.7.ebuild b/dev-haskell/mmap/mmap-0.5.7.ebuild
new file mode 100644
index 000000000000..d6b21ee4f33a
--- /dev/null
+++ b/dev-haskell/mmap/mmap-0.5.7.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/mmap/mmap-0.5.7.ebuild,v 1.1 2011/08/04 21:03:16 slyfox Exp $
+
+# ebuild generated by hackport 0.2.9
+EAPI="3"
+
+CABAL_FEATURES="lib profile haddock hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Memory mapped files for POSIX and Windows"
+HOMEPAGE="http://hackage.haskell.org/package/mmap"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~ppc-macos ~x86-macos"
+#IUSE="test"
+IUSE=""
+
+RESTRICT="test" # the test suit isn't included in this release! :(
+
+RDEPEND=">=dev-lang/ghc-6.8.2"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2
+ test? ( dev-haskell/hunit )"
+
+src_configure() {
+ cabal_src_configure # $(cabal_flag test mmaptest)
+}
+
+src_test() {
+ # breaking the abstraction a bit, we're not supposed to know about ./setup
+ # and how it works...
+ ./dist/build/mmaptest/mmaptest || die "tests failed"
+}
+
+src_install() {
+ cabal_src_install
+
+ rm "${D}/usr/bin/mmaptest"
+ rmdir "${D}/usr/bin" 2> /dev/null # only if empty
+}