summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-07-15 23:59:39 +0000
committerMike Frysinger <vapier@gentoo.org>2003-07-15 23:59:39 +0000
commit02e5e2d4e6ad5ff66bc05844ee20673f27f3355c (patch)
tree1ec120a811a873f280a2c95be8eef172adb3328b
parentbugfix for setup.py (diff)
downloadhistorical-02e5e2d4e6ad5ff66bc05844ee20673f27f3355c.tar.gz
historical-02e5e2d4e6ad5ff66bc05844ee20673f27f3355c.tar.bz2
historical-02e5e2d4e6ad5ff66bc05844ee20673f27f3355c.zip
dev pkg not a game
-rw-r--r--dev-games/cel-cvs/cel-cvs-0.97.ebuild11
-rw-r--r--dev-games/cel/cel-20030413-r2.ebuild11
-rw-r--r--dev-games/crystalspace-cvs/crystalspace-cvs-0.97.ebuild13
-rw-r--r--dev-games/crystalspace/crystalspace-20030413-r1.ebuild13
4 files changed, 18 insertions, 30 deletions
diff --git a/dev-games/cel-cvs/cel-cvs-0.97.ebuild b/dev-games/cel-cvs/cel-cvs-0.97.ebuild
index c04b39fadca1..0a6b38d6dd4a 100644
--- a/dev-games/cel-cvs/cel-cvs-0.97.ebuild
+++ b/dev-games/cel-cvs/cel-cvs-0.97.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/cel-cvs/cel-cvs-0.97.ebuild,v 1.3 2003/07/13 04:59:03 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/cel-cvs/cel-cvs-0.97.ebuild,v 1.4 2003/07/15 23:58:24 vapier Exp $
-inherit games cvs
+inherit cvs
ECVS_SERVER="cvs.cel.sourceforge.net:/cvsroot/cel"
ECVS_MODULE="cel"
ECVS_TOP_DIR="${DISTDIR}/cvs-src/${PN}"
@@ -20,8 +20,8 @@ DEPEND="dev-games/crystalspace
dev-util/jam
!dev-games/cel-cvs"
-CEL_PREFIX=${GAMES_PREFIX_OPT}/crystal
-CS_PREFIX=${GAMES_PREFIX_OPT}/crystal
+CEL_PREFIX=/opt/crystal
+CS_PREFIX=/opt/crystal
src_compile() {
./autogen.sh || die
@@ -35,6 +35,5 @@ src_install() {
# attention don't put a / between ${D} and ${CEL_PREFIX} jam has a bug where
# it fails with 3 following slashes.
jam -sFILEMODE=0640 -sEXEMODE=0750 -sprefix=${D}${CEL_PREFIX} install || die
- dogamesbin cel.cex
- prepgamesdirs
+ dobin cel.cex
}
diff --git a/dev-games/cel/cel-20030413-r2.ebuild b/dev-games/cel/cel-20030413-r2.ebuild
index d51bb5541be3..fb8c64b2c192 100644
--- a/dev-games/cel/cel-20030413-r2.ebuild
+++ b/dev-games/cel/cel-20030413-r2.ebuild
@@ -1,8 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/cel/cel-20030413-r2.ebuild,v 1.3 2003/07/13 04:59:38 vapier Exp $
-
-inherit games
+# $Header: /var/cvsroot/gentoo-x86/dev-games/cel/cel-20030413-r2.ebuild,v 1.4 2003/07/15 23:58:28 vapier Exp $
DESCRIPTION="A game entity layer based on Crystal Space"
HOMEPAGE="http://cel.sourceforge.net/"
@@ -18,8 +16,8 @@ DEPEND="dev-games/crystalspace
S=${WORKDIR}/${PN}
-CEL_PREFIX=${GAMES_PREFIX_OPT}/crystal
-CS_PREFIX=${GAMES_PREFIX_OPT}/crystal
+CEL_PREFIX=/opt/crystal
+CS_PREFIX=/opt/crystal
src_unpack() {
unpack ${A}
@@ -39,6 +37,5 @@ src_install() {
# attention don't put a / between ${D} and ${CEL_PREFIX} jam has a bug where
# it fails with 3 following slashes.
jam -sFILEMODE=0640 -sEXEMODE=0750 -sprefix=${D}${CEL_PREFIX} install || die
- dogamesbin cel.cex
- prepgamesdirs
+ dobin cel.cex
}
diff --git a/dev-games/crystalspace-cvs/crystalspace-cvs-0.97.ebuild b/dev-games/crystalspace-cvs/crystalspace-cvs-0.97.ebuild
index c94285949650..3889b6df69ec 100644
--- a/dev-games/crystalspace-cvs/crystalspace-cvs-0.97.ebuild
+++ b/dev-games/crystalspace-cvs/crystalspace-cvs-0.97.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace-cvs/crystalspace-cvs-0.97.ebuild,v 1.1 2003/07/13 03:13:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace-cvs/crystalspace-cvs-0.97.ebuild,v 1.2 2003/07/15 23:59:39 vapier Exp $
-inherit games cvs
+inherit cvs
ECVS_SERVER="cvs.sourceforge.net:/cvsroot/crystal"
ECVS_MODULE="CS"
ECVS_TOP_DIR="${DISTDIR}/cvs-src/${PN}"
@@ -31,7 +31,7 @@ DEPEND=">=media-libs/libpng-1.2.1
>=dev-lang/perl-5.6.1
!dev-libs/crystalspace"
-CRYSTAL_PREFIX=${GAMES_PREFIX_OPT}/crystal
+CRYSTAL_PREFIX=/opt/crystal
src_compile() {
./configure --prefix=${CRYSTAL_PREFIX} || die
@@ -41,9 +41,6 @@ src_compile() {
src_install() {
dodir ${CRYSTAL_PREFIX}
make INSTALL_DIR=${D}/${CRYSTAL_PREFIX} install || die
-
- dodir ${GAMES_BINDIR}
- dosym ${CRYSTAL_PREFIX}/bin/cs-config ${GAMES_BINDIR}/cs-config
-
- prepgamesdirs
+ dodir /usr/bin
+ dosym ${CRYSTAL_PREFIX}/bin/cs-config /usr/bin/cs-config
}
diff --git a/dev-games/crystalspace/crystalspace-20030413-r1.ebuild b/dev-games/crystalspace/crystalspace-20030413-r1.ebuild
index c5e01eb35421..0e3457cd321f 100644
--- a/dev-games/crystalspace/crystalspace-20030413-r1.ebuild
+++ b/dev-games/crystalspace/crystalspace-20030413-r1.ebuild
@@ -1,8 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/crystalspace-20030413-r1.ebuild,v 1.1 2003/07/13 03:13:40 vapier Exp $
-
-inherit games
+# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/crystalspace-20030413-r1.ebuild,v 1.2 2003/07/15 23:59:01 vapier Exp $
DESCRIPTION="portable 3D Game Development Kit written in C++"
SRC_URI="mirror://gentoo/distfiles/${P}.tar.gz"
@@ -30,7 +28,7 @@ DEPEND=">=media-libs/libpng-1.2.1
S=${WORKDIR}/CS
-CRYSTAL_PREFIX=${GAMES_PREFIX_OPT}/crystal
+CRYSTAL_PREFIX=/opt/crystal
src_compile() {
./configure --prefix=${CRYSTAL_PREFIX} || die
@@ -40,9 +38,6 @@ src_compile() {
src_install() {
dodir ${CRYSTAL_PREFIX}
make INSTALL_DIR=${D}/${CRYSTAL_PREFIX} install || die
-
- dodir ${GAMES_BINDIR}
- dosym ${CRYSTAL_PREFIX}/bin/cs-config ${GAMES_BINDIR}/cs-config
-
- prepgamesdirs
+ dodir /usr/bin
+ dosym ${CRYSTAL_PREFIX}/bin/cs-config /usr/bin/cs-config
}