summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/libxklavier/libxklavier-5.4.ebuild')
-rw-r--r--x11-libs/libxklavier/libxklavier-5.4.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/x11-libs/libxklavier/libxklavier-5.4.ebuild b/x11-libs/libxklavier/libxklavier-5.4.ebuild
index 6506faf579bb..610b2e00fd94 100644
--- a/x11-libs/libxklavier/libxklavier-5.4.ebuild
+++ b/x11-libs/libxklavier/libxklavier-5.4.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit libtool vala xdg-utils
@@ -27,7 +27,8 @@ RDEPEND="
introspection? ( >=dev-libs/gobject-introspection-1.30:= )
vala? ( $(vala_depend) )
"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
dev-util/glib-utils
>=dev-util/gtk-doc-am-1.4
sys-devel/gettext
@@ -54,5 +55,5 @@ src_configure() {
src_install() {
default
dodoc CREDITS
- find "${D}" -name '*.la' -delete || die
+ find "${ED}" -type f -name '*.la' -delete || die
}