summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/rutorrent')
-rw-r--r--www-apps/rutorrent/Manifest2
-rw-r--r--www-apps/rutorrent/metadata.xml11
-rw-r--r--www-apps/rutorrent/rutorrent-3.4-r1.ebuild55
3 files changed, 68 insertions, 0 deletions
diff --git a/www-apps/rutorrent/Manifest b/www-apps/rutorrent/Manifest
new file mode 100644
index 000000000000..b992d279735b
--- /dev/null
+++ b/www-apps/rutorrent/Manifest
@@ -0,0 +1,2 @@
+DIST plugins-3.4.tar.gz 674444 SHA256 d8e8e4b2887fb15e97c7ecdfe5c76039d55fab7dc40f27655229e96e43bb507c
+DIST rutorrent-3.4.tar.gz 241253 SHA256 358c19f439ed9eb27318d5cc04f467e8b894ee2752c12946ef6f9226466f1629
diff --git a/www-apps/rutorrent/metadata.xml b/www-apps/rutorrent/metadata.xml
new file mode 100644
index 000000000000..e814a67b0855
--- /dev/null
+++ b/www-apps/rutorrent/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>web-apps</herd>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">rutorrent</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/www-apps/rutorrent/rutorrent-3.4-r1.ebuild b/www-apps/rutorrent/rutorrent-3.4-r1.ebuild
new file mode 100644
index 000000000000..56e6db779b3a
--- /dev/null
+++ b/www-apps/rutorrent/rutorrent-3.4-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit webapp eutils
+
+DESCRIPTION="ruTorrent is a front-end for the popular Bittorrent client rTorrent"
+HOMEPAGE="http://code.google.com/p/rutorrent/"
+SRC_URI="
+ http://rutorrent.googlecode.com/files/${P}.tar.gz
+ http://rutorrent.googlecode.com/files/plugins-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE=""
+
+need_httpd_cgi
+
+DEPEND="
+ || ( dev-lang/php[xml,gd] dev-lang/php[xml,gd-external] )
+"
+RDEPEND="virtual/httpd-php"
+
+S="${WORKDIR}"
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ mv plugins rutorrent
+ cd rutorrent
+ doins -r .
+
+ chmod +x "${ED}${MY_HTDOCSDIR}"/plugins/*/*.sh \
+ "$ED${MY_HTDOCSDIR}"/php/test.sh || die "chmod failed"
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/share
+ webapp_serverowned "${MY_HTDOCSDIR}"/share/settings
+ webapp_serverowned "${MY_HTDOCSDIR}"/share/torrents
+ webapp_serverowned "${MY_HTDOCSDIR}"/share/users
+
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/.htaccess
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/config.php
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/access.ini
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/plugins.ini
+ webapp_configfile "${MY_HTDOCSDIR}"/share/.htaccess
+
+ webapp_src_install
+}