summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/linux-docs/Manifest1
-rw-r--r--sys-kernel/linux-docs/linux-docs-5.4.15.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/sys-kernel/linux-docs/Manifest b/sys-kernel/linux-docs/Manifest
index 808f102201e2..caf133827484 100644
--- a/sys-kernel/linux-docs/Manifest
+++ b/sys-kernel/linux-docs/Manifest
@@ -1 +1,2 @@
DIST linux-4.19.99.tar.xz 103405792 BLAKE2B 0e6354dc89f2b8375d16d814377279dcd2df5fced046995c0641548268bb43e973bdeeaf67565c50c5299c670944dc3c9580a372bffc0195fe4492b206fd5267 SHA512 a4275bb56791377e89771b11c5fe12e0607f54a6bffddddc077df629795a88a0cbf332291157c6c88d350f289713d4ce007c90cc5bfdd7c24a7d9020213a3917
+DIST linux-5.4.15.tar.xz 109461584 BLAKE2B 0384ac416aaca05ac73e77fae2cf85b2d773f343aa9a95191818a237354904b2c36404cbe08e373be832fa9f17c7961362dfe3be50f8cfe040c2eaddbab37da1 SHA512 be890d2f893e4470bf51ea84e60088e33420083ffd39e50d204a063e8405176035f2364333657ebabdd68bd4635ae3ea535d0c939de6c88e3e118c3619be1866
diff --git a/sys-kernel/linux-docs/linux-docs-5.4.15.ebuild b/sys-kernel/linux-docs/linux-docs-5.4.15.ebuild
new file mode 100644
index 000000000000..5c6088729753
--- /dev/null
+++ b/sys-kernel/linux-docs/linux-docs-5.4.15.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+MY_P=linux-${PV}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Developer documentation generated from the Linux kernel"
+HOMEPAGE="https://www.kernel.org/"
+SRC_URI="https://www.kernel.org/pub/linux/kernel/v5.x/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+IUSE=""
+DEPEND="dev-python/sphinx"
+RDEPEND=""
+
+src_compile() {
+ local ARCH=$(tc-arch-kernel)
+ unset KBUILD_OUTPUT
+ emake htmldocs
+}
+
+src_install() {
+ HTML_DOCS=( Documentation/output/. )
+ einstalldocs
+}