summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/coinor-symphony')
-rw-r--r--sci-libs/coinor-symphony/Manifest1
-rw-r--r--sci-libs/coinor-symphony/coinor-symphony-5.5.7.ebuild87
-rw-r--r--sci-libs/coinor-symphony/metadata.xml18
3 files changed, 106 insertions, 0 deletions
diff --git a/sci-libs/coinor-symphony/Manifest b/sci-libs/coinor-symphony/Manifest
new file mode 100644
index 000000000000..be0eecf8fc3f
--- /dev/null
+++ b/sci-libs/coinor-symphony/Manifest
@@ -0,0 +1 @@
+DIST SYMPHONY-5.5.7.tgz 7628863 SHA256 7828620ebe240239f6392a23a54fbacdb39f91c6571f2b98346b5b42436a20f0 SHA512 a3ce66b0b1373c58024ce6840277423a1a3684af8e3179a777fbb33a8d266849ae1cde694a527c3776ff67ce0a5ae3c2bfe0dc29f4e0b3ca51ddc2b299eefb24 WHIRLPOOL aa43df2d558bb328b9d226e7e15f8164cfd18eeac326b6ecd9306887703f2b8619b0343750415b526cfba73eb78319b6509f266ec527fbbb4bb2c84ae134f553
diff --git a/sci-libs/coinor-symphony/coinor-symphony-5.5.7.ebuild b/sci-libs/coinor-symphony/coinor-symphony-5.5.7.ebuild
new file mode 100644
index 000000000000..689ecb3680e7
--- /dev/null
+++ b/sci-libs/coinor-symphony/coinor-symphony-5.5.7.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils multilib
+
+MYPN=SYMPHONY
+
+DESCRIPTION="COIN-OR solver for mixed-integer linear programs"
+HOMEPAGE="https://projects.coin-or.org/SYMPHONY/"
+SRC_URI="http://www.coin-or.org/download/source/${MYPN}/${MYPN}-${PV}.tgz"
+
+LICENSE="EPL-1.0"
+SLOT="0/3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples glpk static-libs test"
+
+RDEPEND="
+ sci-libs/coinor-cgl:=
+ sci-libs/coinor-clp:=
+ sci-libs/coinor-dylp:=
+ sci-libs/coinor-osi:=
+ sci-libs/coinor-utils:=
+ sci-libs/coinor-vol:=
+ glpk? ( sci-mathematics/glpk:= )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( virtual/latex-base )
+ test? ( sci-libs/coinor-sample )"
+
+S="${WORKDIR}/${MYPN}-${PV}/${MYPN}"
+
+src_prepare() {
+ # needed for the --with-coin-instdir
+ dodir /usr
+ sed -i \
+ -e "s:lib/pkgconfig:$(get_libdir)/pkgconfig:g" \
+ configure || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-dependency-linking
+ --with-coin-instdir="${ED}"/usr
+ )
+ if use glpk; then
+ myeconfargs+=(
+ --with-glpk-incdir="${EPREFIX}"/usr/include
+ --with-glpk-lib=-lglpk )
+ else
+ myeconfargs+=( --without-glpk )
+ fi
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ # hack for parallel build, to overcome not patching Makefile.am above
+ autotools-utils_src_compile -C src libSym.la
+ autotools-utils_src_compile
+ if use doc; then
+ pushd Doc /dev/null
+ pdflatex Walkthrough && pdflatex Walkthrough
+ # does not compile and doc is online
+ #pdflatex man && pdflatex man
+ popd > /dev/null
+ fi
+}
+
+src_test() {
+ autotools-utils_src_test test
+}
+
+src_install() {
+ # hack for parallel install, to overcome not patching Makefile.am above
+ autotools-utils_src_install -C src install-am
+ autotools-utils_src_install
+ use doc && dodoc Doc/Walkthrough.pdf
+ # already installed
+ rm "${ED}"/usr/share/coin/doc/${MYPN}/{README,AUTHORS,LICENSE} || die
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r Examples/*
+ fi
+}
diff --git a/sci-libs/coinor-symphony/metadata.xml b/sci-libs/coinor-symphony/metadata.xml
new file mode 100644
index 000000000000..4940c67df094
--- /dev/null
+++ b/sci-libs/coinor-symphony/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ SYMPHONY is a generic mixed-integer linear programs
+ (MILP) solver, callable library, and extensible framework for implementing
+ customized solvers. SYMPHONY has a number of advanced capabilities,
+ including the ability to solve multi-objective MILPs, the ability to
+ warm start its solution procedure.
+ SYMPHONY is part of the larger COIN-OR initiative (Computational
+ Infrastructurefor Operations Research).
+</longdescription>
+<use>
+ <flag name='glpk'>Enable GNU Linear Programming Kit
+ <pkg>sci-mathematics/glpk</pkg> support</flag>
+</use>
+</pkgmetadata>