summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/tm-align/tm-align-20150914.ebuild')
-rw-r--r--sci-chemistry/tm-align/tm-align-20150914.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/sci-chemistry/tm-align/tm-align-20150914.ebuild b/sci-chemistry/tm-align/tm-align-20150914.ebuild
index 6732f611eaad..f84b13e9e8f8 100644
--- a/sci-chemistry/tm-align/tm-align-20150914.ebuild
+++ b/sci-chemistry/tm-align/tm-align-20150914.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
inherit cmake-utils flag-o-matic fortran-2
@@ -12,14 +12,14 @@ SRC_URI="http://zhanglab.ccmb.med.umich.edu/TM-align/TMtools${PV}.tar.gz"
LICENSE="tm-align"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="static custom-cflags"
+IUSE="custom-cflags static"
S="${WORKDIR}"
src_prepare() {
+ cp "${FILESDIR}"/CMakeLists.txt . || die
cmake-utils_src_prepare
- cp "${FILESDIR}"/CMakeLists.txt . || die
use static && append-fflags -static && append-ldflags -static
# recommended by upstream
use custom-cflags || replace-flags -O* -O3 && append-fflags -ffast-math